Add ftp-tls 20020906, ftp client supporting FTP AUTH TLS.

Submitted by:	marius@alchemy.franken.de
This commit is contained in:
Alexander Leidinger 2002-10-30 12:08:24 +00:00
parent f98326ff7b
commit a76838b770
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=69148
11 changed files with 230 additions and 0 deletions

View File

@ -12,6 +12,7 @@
SUBDIR += emirror
SUBDIR += fget
SUBDIR += frox
SUBDIR += ftp-tls
SUBDIR += ftpcopy
SUBDIR += ftpcube
SUBDIR += ftpfind

32
ftp/ftp-tls/Makefile Normal file
View File

@ -0,0 +1,32 @@
# Ports collection makefile for: ftp-tls
# Date created: 24 October 2002
# Whom: marius@alchemy.franken.de
#
# $FreeBSD$
#
PORTNAME= ftp-tls
PORTVERSION= 20020906
CATEGORIES= ftp security
MASTER_SITES= ftp://ftp.runestig.com/pub/ftp-tls/
MAINTAINER= marius@alchemy.franken.de
USE_AUTOCONF= YES
GNU_CONFIGURE= YES
USE_OPENSSL= YES
MAN1= ftp-tls.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400000
BROKEN= "Not supported on systems prior to FreeBSD 4.0 (missing getaddrinfo())"
.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/ftp ${PREFIX}/bin/ftp-tls
@${INSTALL_MAN} ${WRKSRC}/ftp.1.TLS ${PREFIX}/man/man1/ftp-tls.1
.include <bsd.port.post.mk>

1
ftp/ftp-tls/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ftp-tls-20020906.tar.gz) = 8823a6f9388add4e3fcd4459422d57d8

View File

@ -0,0 +1,9 @@
--- config.h.in.orig Fri Oct 25 14:59:53 2002
+++ config.h.in Fri Oct 25 15:02:02 2002
@@ -338,3 +338,6 @@
/* Define to `unsigned' if <sys/types.h> does not define. */
#undef size_t
+
+/* Define if libedit has the NetBSD enhancements. */
+#undef ENHANCED_LIBEDIT

View File

@ -0,0 +1,57 @@
--- configure.in.orig Thu Oct 24 21:28:06 2002
+++ configure.in Fri Oct 25 15:03:04 2002
@@ -56,6 +56,7 @@
AC_CHECK_LIB(nsl, inet_addr)
dnl Replace `main' with a function in -lsocks5:
dnl AC_CHECK_LIB(socks5, main)
+AC_SEARCH_LIBS(el_init, edit, have_libedit=yes, have_libedit=no)
# Checks for header files.
AC_HEADER_DIRENT
@@ -302,11 +303,11 @@
AC_CHECK_LIB(krb5, krb5_init_context, ,
AC_MSG_ERROR(Could not find Kerberos 5 library needed. Try again using --with-krb5-dir=DIR))
fi
- # look for OpenSSL libraries, also in the legacy (strange) place "/usr/local/ssl"
+ # look for OpenSSL libraries
AC_CHECK_LIB(crypto, X509_STORE_load_locations, , found_openssl=no)
if test "$found_openssl" = no; then
- CPPFLAGS="$CPPFLAGS -I/usr/local/ssl/include"
- LDFLAGS="$LDFLAGS -L/usr/local/ssl/lib"
+ CPPFLAGS="$CPPFLAGS -I$OPENSSLINC"
+ LDFLAGS="$LDFLAGS -L$OPENSSLLIB"
# remove the cached result of the previous AC_CHECK_LIB()
unset ac_cv_lib_crypto_X509_STORE_load_locations
AC_CHECK_LIB(crypto, X509_STORE_load_locations, ,
@@ -336,10 +337,27 @@
if test "$enable_small" = yes; then
AC_DEFINE(SMALL)
else
- LIBS="-ledit -L./libedit $LIBS"
- CPPFLAGS="$CPPFLAGS -I./libedit"
- LIBEDITTARGET=libedit-all
- MANEDITRC=editrc.5
+ AC_MSG_CHECKING([for libedit])
+ if test $have_libedit = no; then
+ AC_MSG_RESULT([no, using my own])
+ LIBS="./libedit/libedit.a $LIBS"
+ CPPFLAGS="$CPPFLAGS -I./libedit"
+ LIBEDITTARGET=libedit-all
+ MANEDITRC=editrc.5
+ else
+ AC_MSG_RESULT([yes])
+ LIBEDITTARGET=
+
+ AC_MSG_CHECKING([for NetBSD enhancements in libedit])
+ AC_TRY_COMPILE([#include <histedit.h>], [int X = EL_RPROMPT],
+ have_enhanced_libedit=yes)
+ if test "$have_enhanced_libedit" = yes; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(ENHANCED_LIBEDIT)
+ else
+ AC_MSG_RESULT([no])
+ fi
+ fi
fi
AC_SUBST(LIBEDITTARGET)
AC_SUBST(MANEDITRC)

View File

@ -0,0 +1,78 @@
--- ftp.1.TLS.orig Thu Sep 5 21:00:21 2002
+++ ftp.1.TLS Fri Oct 25 15:28:06 2002
@@ -38,23 +38,23 @@
.Dt FTP 1
.Os
.Sh NAME
-.Nm ftp
+.Nm ftp-tls
.Nd
.Tn ARPANET
-file transfer program
+file transfer program supporting FTP AUTH TLS
.Sh SYNOPSIS
-.Nm ftp
+.Nm ftp-tls
.Op Fl AVadegimnptv
.Op Fl o Ar output
.Op Fl P Ar port
.Op Fl r Ar seconds
.Op Fl z Ar TLS option
.Op Ar host Op Ar port
-.Nm ftp
+.Nm ftp-tls
ftp://[\fIuser\fR:\fIpassword\fR@]\fIhost\fR[:\fIport\fR]/\fIfile\fR[/]
-.Nm ftp
+.Nm ftp-tls
http://\fIhost\fR[:\fIport\fR]/\fIfile\fR
-.Nm ftp
+.Nm ftp-tls
\fIhost\fR:[/\fIpath\fR/]\fIfile\fR[/]
.Sh DESCRIPTION
.Nm
@@ -299,7 +299,7 @@
is provided to the user.
The following commands are recognized
by
-.Nm ftp :
+.Nm ftp-tls :
.Bl -tag -width Fl
.It Ic \&! Op Ar command Op Ar args
Invoke an interactive shell on the local machine.
@@ -351,7 +351,7 @@
.Tn FTP
session with the remote server
and exit
-.Nm ftp .
+.Nm ftp-tls .
An end-of-file will also terminate the session and exit.
.It Ic case
Toggle remote computer file name case mapping during
@@ -1135,7 +1135,7 @@
on remote machine.
.It Ic status
Show the current status of
-.Nm ftp .
+.Nm ftp-tls .
.It Ic struct Op Ar struct-name
Set the file transfer
.Ar structure
@@ -1374,9 +1374,7 @@
c.f. the
.Ic glob
command.
-If the
-.Nm
-command expects a single local file (e.g.,
+If the ftp command expects a single local file (e.g.,
.Ic put ) ,
only the first filename generated by the
.Dq globbing
@@ -1608,6 +1606,7 @@
URL of HTTP proxy to use when making HTTP URL requests.
.El
.Sh SEE ALSO
+.Xr tftp 1 ,
.Xr tftp 1 ,
.Xr getservbyname 3 ,
.Xr editrc 5 ,

View File

@ -0,0 +1,24 @@
--- main.c.orig Fri Oct 25 14:15:16 2002
+++ main.c Fri Oct 25 15:05:09 2002
@@ -518,6 +518,9 @@
#ifndef SMALL
} else {
const char *buf;
+#ifdef ENHANCED_LIBEDIT
+ HistEvent ev;
+#endif
cursor_pos = NULL;
if ((buf = el_gets(el, &num)) == NULL || num == 0)
@@ -532,7 +535,11 @@
}
memcpy(line, buf, (size_t)num);
line[num] = '\0';
+#ifndef ENHANCED_LIBEDIT
history(hist, H_ENTER, buf);
+#else
+ history(hist, &ev, H_ENTER, buf);
+#endif
}
#endif /* !SMALL */

View File

@ -0,0 +1,22 @@
--- util.c.orig Fri Oct 25 14:17:24 2002
+++ util.c Fri Oct 25 15:07:39 2002
@@ -1013,9 +1013,19 @@
controlediting()
{
if (editing && el == NULL && hist == NULL) {
+#ifdef ENHANCED_LIBEDIT
+ HistEvent ev;
+
+ el = el_init(progname, stdin, ttyout, stderr); /* init editline */
+#else
el = el_init(progname, stdin, ttyout); /* init editline */
+#endif
hist = history_init(); /* init the builtin history */
+#ifndef ENHANCED_LIBEDIT
history(hist, H_EVENT, 100); /* remember 100 events */
+#else
+ history(hist, &ev, H_SETSIZE, 100); /* remember 100 events */
+#endif
el_set(el, EL_HIST, history, hist); /* use history */
el_set(el, EL_EDITOR, "emacs"); /* default editor is emacs */

1
ftp/ftp-tls/pkg-comment Normal file
View File

@ -0,0 +1 @@
Ftp client supporting FTP AUTH TLS

4
ftp/ftp-tls/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
Ftp client based on the OpenBSD ftp client code, implements the
FTP AUTH TLS IETF draft.
WWW: http://www.runestig.com/osp.html

1
ftp/ftp-tls/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/ftp-tls