Update to 1.2.13 to fix a build with Mozilla 1.5 and 1.6.a.

Reported by:	bento via kris
Approved by:	portmgr (implicit)
This commit is contained in:
Joe Marcus Clarke 2003-11-26 06:02:15 +00:00
parent 7df6a56ab8
commit a73b45419f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94788
3 changed files with 5 additions and 21 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= galeon
PORTVERSION= 1.2.12
PORTREVISION= 2
PORTVERSION= 1.2.13
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -20,7 +19,7 @@ BUILD_DEPENDS= ${X11BASE}/include/mozilla${HEADERS_SUFX}/gtkembedmoz/gtkmozembed
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZILLA}
MOZ_CONFIGURE_ARGS=--with-mozilla-snapshot="trunk"
MOZ_CONFIGURE_ARGS=--with-mozilla-snapshot="1.5"
.if !defined(WITH_MOZILLA)
MOZILLA= mozilla
@ -29,7 +28,7 @@ HEADERS_SUFX=
.if ${WITH_MOZILLA}=="mozilla-devel"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.5b"
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6a"
.else
MOZILLA= mozilla
HEADERS_SUFX=
@ -37,7 +36,7 @@ HEADERS_SUFX=
.endif
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack bonobo libglade gnomevfs
USE_GNOME= gnomeprefix gnomehack bonobo libglade gnomevfs gnometarget
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
@ -55,11 +54,7 @@ CONFLICTS= galeon2-*
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.
NO_WERROR= yes
.endif
# allow build with more warnings enabled
.if defined(NO_WERROR)
CONFIGURE_ARGS+= --disable-werror

View File

@ -1 +1 @@
MD5 (galeon-1.2.12.tar.gz) = 301cc69894a4bb8ba7e9330acd6ebc66
MD5 (galeon-1.2.13.tar.gz) = 62f0c497b8165fc567f8d2016b40a319

View File

@ -1,11 +0,0 @@
--- src/mozilla/GlobalHistory.cpp.orig Tue Oct 14 17:43:42 2003
+++ src/mozilla/GlobalHistory.cpp Tue Oct 14 17:44:08 2003
@@ -108,7 +108,7 @@
return NS_OK;
}
-#if MOZILLA_SNAPSHOT > 9
+#if MOZILLA_SNAPSHOT >= 9
NS_IMETHODIMP GlobalHistory::SetLastPageVisited(const char * aLastPageVisited)
{
mLastPageVisited.Assign(aLastPageVisited);