microdc is a command-line based Direct Connect client that uses the

GNU Readline library for user interaction. It was developed from
ground up and does not depend on any other program. Despite the
command-line user interface, microdc was designed to be user
friendly and simple to use.

PR:	ports/101899
Submitted by:	Pankov Pavel <pankov_p@mail.ru>
This commit is contained in:
Andrej Zverev 2006-09-07 16:41:50 +00:00
parent 07bb6c3560
commit a730fd4e64
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=172509
6 changed files with 65 additions and 0 deletions

View File

@ -63,6 +63,7 @@
SUBDIR += linux-jigdo
SUBDIR += linux-overnet-core
SUBDIR += linuxdcpp
SUBDIR += microdc
SUBDIR += minder
SUBDIR += mldonkey
SUBDIR += mldonkey-core

41
net-p2p/microdc/Makefile Normal file
View File

@ -0,0 +1,41 @@
# New ports collection makefile for: microdc
# Date created: 2006-08-11
# Whom: Pankov Pavel <pankov_p@mail.ru>
#
# $FreeBSD$
#
PORTNAME= microdc
PORTVERSION= 0.11.0
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pankov_p@mail.ru
COMMENT= A command-line based Direct Connect client
USE_GCC= 3.2+
GNU_CONFIGURE= yes
USE_ICONV= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
MAN1= ${PORTNAME}.1
MANLANG= "" pl
post-install:
@${MKDIR} ${MAN1PREFIX}/man/pl
@${MKDIR} ${MAN1PREFIX}/man/pl/man1
@${MV} ${MAN1PREFIX}/man/man1/${PORTNAME}.pl.1 ${MAN1PREFIX}/man/pl/man1/${PORTNAME}.1
.include <bsd.port.mk>

3
net-p2p/microdc/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (microdc-0.11.0.tar.gz) = 2481e31495f7e809ea3fe7c460862b63
SHA256 (microdc-0.11.0.tar.gz) = 57e12a6cfdf1feb5c526f4bfc9b250bb25c652e1ed81db28c9db1ab64af67b7e
SIZE (microdc-0.11.0.tar.gz) = 517879

View File

@ -0,0 +1,10 @@
--- src/filelist-in.c-orig Wed Sep 21 23:28:10 2005
+++ src/filelist-in.c Fri Aug 11 23:21:51 2006
@@ -20,6 +20,7 @@
#include <config.h>
#include <unistd.h>
#include <sys/signal.h>
+#include <sys/stat.h>
#include <stdbool.h>
#include "gettext.h" /* Gnulib/GNU gettext */
#define _(s) gettext(s)

View File

@ -0,0 +1,7 @@
microdc is a command-line based Direct Connect client that uses the
GNU Readline library for user interaction. It was developed from
ground up and does not depend on any other program. Despite the
command-line user interface, microdc was designed to be user
friendly and simple to use.
WWW: http://www.nongnu.org/microdc/

View File

@ -0,0 +1,3 @@
bin/microdc
%%NLS%%share/locale/pl/LC_MESSAGES/microdc.mo
%%NLS%%share/locale/sv/LC_MESSAGES/microdc.mo