Add libdts, a free library for decoding DTS Coherent Acoustics streams.

This commit is contained in:
Pav Lucistnik 2004-05-12 11:06:46 +00:00
parent e258b7a507
commit a7108b251b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108992
11 changed files with 117 additions and 0 deletions

View File

@ -45,6 +45,7 @@
SUBDIR += libdivxdecore
SUBDIR += libdivxdecore-devel
SUBDIR += libdivxencore
SUBDIR += libdts
SUBDIR += libdv
SUBDIR += libdvbpsi
SUBDIR += libdvdcss

View File

@ -0,0 +1,21 @@
# New ports collection makefile for: libdts
# Date created: 12th May 2004
# Whom: Pav Lucistnik <pav@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= libdts
PORTVERSION= 0.0.2
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/libdts/${PORTVERSION}/
MAINTAINER= pav@FreeBSD.org
COMMENT= Free DTS Coherent Acoustics decoder
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig gnomehack
MAN1= dtsdec.1 extract_dts.1
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (libdts-0.0.2.tar.gz) = a1c0dac95d7031498c2d19d7a3107469
SIZE (libdts-0.0.2.tar.gz) = 295185

View File

@ -0,0 +1,24 @@
--- libao/audio_out_oss.c.orig Thu Feb 5 10:14:12 2004
+++ libao/audio_out_oss.c Wed May 12 11:49:35 2004
@@ -34,8 +34,9 @@
#if defined(__OpenBSD__) || defined(__NetBSD__)
#include <soundcard.h>
-#elif defined(__FreeBSD__)
-#include <machine/soundcard.h>
+#else
+#include <sys/soundcard.h>
+#if defined(__FreeBSD__)
#ifndef AFMT_S16_NE
#include <machine/endian.h>
#if BYTE_ORDER == LITTLE_ENDIAN
@@ -44,8 +45,7 @@
#define AFMT_S16_NE AFMT_S16_BE
#endif
#endif
-#else
-#include <sys/soundcard.h>
+#endif
#endif
#if defined(__NetBSD__)

View File

@ -0,0 +1,5 @@
libdts is a free library for decoding DTS Coherent Acoustics streams.
libdts is still in early development stage so don't expect too much from it.
WWW: http://www.videolan.org/dtsdec.html

View File

@ -0,0 +1,6 @@
bin/dtsdec
bin/extract_dts
include/dts.h
lib/libdts.a
lib/libdts_pic.a
libdata/pkgconfig/libdts.pc

View File

@ -0,0 +1,21 @@
# New ports collection makefile for: libdts
# Date created: 12th May 2004
# Whom: Pav Lucistnik <pav@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= libdts
PORTVERSION= 0.0.2
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/libdts/${PORTVERSION}/
MAINTAINER= pav@FreeBSD.org
COMMENT= Free DTS Coherent Acoustics decoder
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig gnomehack
MAN1= dtsdec.1 extract_dts.1
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (libdts-0.0.2.tar.gz) = a1c0dac95d7031498c2d19d7a3107469
SIZE (libdts-0.0.2.tar.gz) = 295185

View File

@ -0,0 +1,24 @@
--- libao/audio_out_oss.c.orig Thu Feb 5 10:14:12 2004
+++ libao/audio_out_oss.c Wed May 12 11:49:35 2004
@@ -34,8 +34,9 @@
#if defined(__OpenBSD__) || defined(__NetBSD__)
#include <soundcard.h>
-#elif defined(__FreeBSD__)
-#include <machine/soundcard.h>
+#else
+#include <sys/soundcard.h>
+#if defined(__FreeBSD__)
#ifndef AFMT_S16_NE
#include <machine/endian.h>
#if BYTE_ORDER == LITTLE_ENDIAN
@@ -44,8 +45,7 @@
#define AFMT_S16_NE AFMT_S16_BE
#endif
#endif
-#else
-#include <sys/soundcard.h>
+#endif
#endif
#if defined(__NetBSD__)

View File

@ -0,0 +1,5 @@
libdts is a free library for decoding DTS Coherent Acoustics streams.
libdts is still in early development stage so don't expect too much from it.
WWW: http://www.videolan.org/dtsdec.html

View File

@ -0,0 +1,6 @@
bin/dtsdec
bin/extract_dts
include/dts.h
lib/libdts.a
lib/libdts_pic.a
libdata/pkgconfig/libdts.pc