net/unfs3: Fix build with -fno-common (FreeBSD 13 or later)

* Update MASTER_SITES and WWW as project has moved to GitHub
* Pass maintainership to submitter
* Clean up and reformat Makefile

PR:		258326
Approved by:	meta (mentor)
MFH:		2021Q3
Differential Revision:	https://reviews.freebsd.org/D32220

(cherry picked from commit 4c35fa18e7)
This commit is contained in:
Robert Clausecker 2021-09-07 00:48:54 +02:00 committed by Yasuhiro Kimura
parent 5e019790c2
commit a6dfa43d8f
4 changed files with 43 additions and 11 deletions

View File

@ -1,30 +1,33 @@
# Created by: Clement Laforet <clement@FreeBSD.org>
PORTNAME= unfs3
PORTVERSION= 0.9.22
PORTREVISION= 1
DISTVERSION= 0.9.22
PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= SF
MASTER_SITES= https://github.com/unfs3/unfs3/releases/download/unfs3-${DISTVERSION}/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= fuz@fuz.su
COMMENT= User-space implementation of the NFSv3 server specification
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_FreeBSD_13= ld: error: duplicate symbol: export_path
BROKEN_FreeBSD_14= ld: error: duplicate symbol: export_path
USES= autoreconf
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
CONFIGURE_ENV= YACC=byacc
PLIST_FILES= sbin/unfsd man/man7/tags.7.gz man/man8/unfsd.8.gz
MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
PLIST_FILES= man/man7/tags.7.gz \
man/man8/unfsd.8.gz \
sbin/unfsd
OPTIONS_DEFINE= CLUSTER_EXT
CLUSTER_EXT_DESC= include clustering extensions
CLUSTER_EXT_CONFIGURE_ON= --enable-cluster
post-extract:
@${RM} ${WRKSRC}/Config/lex.yy.c
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- Config/exports.h.orig 2021-09-06 22:17:18 UTC
+++ Config/exports.h
@@ -22,7 +22,7 @@
extern exports exports_nfslist;
/* Options cache */
extern int exports_opts;
-const char *export_path;
+extern const char *export_path;
extern uint32 export_fsid;
extern uint32 export_password_hash;

View File

@ -0,0 +1,18 @@
--- Config/exports.l.orig 2021-09-06 22:20:46 UTC
+++ Config/exports.l
@@ -14,7 +14,7 @@
#define YY_NO_UNPUT
-YYSTYPE yylval;
+extern YYSTYPE yylval;
extern int e_error;
/*
@@ -67,4 +67,4 @@ OLDNET {IP}"/"{IP}
. { return *yytext; }
\n { return '\n'; }
-
\ No newline at end of file
+

View File

@ -3,4 +3,4 @@ provides a daemon for the MOUNT and NFS protocols, which are used by NFS
clients for accessing files on the server.
Since it runs in user-space, you can use it in a jail.
WWW: http://unfs3.sourceforge.net/
WWW: https://unfs3.github.io/