- Update to 0.1.6
Note: this no longer builds on 4.x, I don't know enough inline assembly to fix.
This commit is contained in:
parent
4a427c034d
commit
a6db41ae63
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=134525
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= jpeg-mmx
|
||||
PORTVERSION= 0.1.5
|
||||
PORTVERSION= 0.1.6
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= mjpeg
|
||||
@ -19,6 +19,7 @@ RUN_DEPENDS= cjpeg:${PORTSDIR}/graphics/jpeg
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
WRKSRC= ${WRKDIR}/jpeg-mmx
|
||||
USE_LIBTOOL_VER=15
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
@ -63,4 +64,10 @@ do-install:
|
||||
@${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
IGNORE= Does not build on 4.x
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (jpeg-mmx-0.1.5.tar.gz) = da10eb1bdea0ca3798636b2b7a645ed8
|
||||
SIZE (jpeg-mmx-0.1.5.tar.gz) = 578350
|
||||
MD5 (jpeg-mmx-0.1.6.tar.gz) = 9156c429bd8c4dea65c877c50ed89e15
|
||||
SIZE (jpeg-mmx-0.1.6.tar.gz) = 597439
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- jdcolor.c.orig Mon Nov 1 23:58:16 2004
|
||||
+++ jdcolor.c Tue Nov 2 00:01:30 2004
|
||||
@@ -129,9 +129,9 @@
|
||||
static const int64 bpte1 = 0x7168e9f97168e9f9; // for cb (Cb/b, Cb/g, Cb/b, Cb/g)
|
||||
static const int64 bpte2 = 0xd21a59bad21a59ba; // for cr (Cr/g, Cr/r, Cr/g, Cr/r)
|
||||
#else
|
||||
-static const int64 te0 = 0x0200020002000200; // -128 << 2
|
||||
-static const int64 te1 = 0xe9fa7168e9fa7168; // for cb
|
||||
-static const int64 te2 = 0x59bad24d59bad24d; // for cr
|
||||
+ const int64 te0 = 0x0200020002000200; // -128 << 2
|
||||
+ const int64 te1 = 0xe9fa7168e9fa7168; // for cb
|
||||
+ const int64 te2 = 0x59bad24d59bad24d; // for cr
|
||||
#endif
|
||||
//static const int64 te2 = 0x59ba524b59ba524b; // for cr
|
||||
/* How to calculate the constants (see constants from above for YCbCr->RGB):
|
@ -1,59 +0,0 @@
|
||||
--- jidctint.c.orig Tue Nov 2 00:03:08 2004
|
||||
+++ jidctint.c Tue Nov 2 00:10:06 2004
|
||||
@@ -173,32 +173,32 @@
|
||||
* Perform dequantization and inverse DCT on one block of coefficients.
|
||||
*/
|
||||
#define __int64 unsigned long long
|
||||
- static __int64 fix_029_n089n196 = 0x098ea46e098ea46e;
|
||||
- static __int64 fix_n196_n089 = 0xc13be333c13be333;
|
||||
- static __int64 fix_205_n256n039 = 0x41b3a18141b3a181;
|
||||
- static __int64 fix_n039_n256 = 0xf384adfdf384adfd;
|
||||
- static __int64 fix_307n256_n196 = 0x1051c13b1051c13b;
|
||||
- static __int64 fix_n256_n196 = 0xadfdc13badfdc13b;
|
||||
- static __int64 fix_150_n089n039 = 0x300bd6b7300bd6b7;
|
||||
- static __int64 fix_n039_n089 = 0xf384e333f384e333;
|
||||
- static __int64 fix_117_117 = 0x25a125a125a125a1;
|
||||
- static __int64 fix_054_054p076 = 0x115129cf115129cf;
|
||||
- static __int64 fix_054n184_054 = 0xd6301151d6301151;
|
||||
+ const __int64 fix_029_n089n196 = 0x098ea46e098ea46e;
|
||||
+ const __int64 fix_n196_n089 = 0xc13be333c13be333;
|
||||
+ const __int64 fix_205_n256n039 = 0x41b3a18141b3a181;
|
||||
+ const __int64 fix_n039_n256 = 0xf384adfdf384adfd;
|
||||
+ const __int64 fix_307n256_n196 = 0x1051c13b1051c13b;
|
||||
+ const __int64 fix_n256_n196 = 0xadfdc13badfdc13b;
|
||||
+ const __int64 fix_150_n089n039 = 0x300bd6b7300bd6b7;
|
||||
+ const __int64 fix_n039_n089 = 0xf384e333f384e333;
|
||||
+ const __int64 fix_117_117 = 0x25a125a125a125a1;
|
||||
+ const __int64 fix_054_054p076 = 0x115129cf115129cf;
|
||||
+ const __int64 fix_054n184_054 = 0xd6301151d6301151;
|
||||
|
||||
- static __int64 fix_054n184 = 0xd630d630d630d630;
|
||||
- static __int64 fix_054 = 0x1151115111511151;
|
||||
- static __int64 fix_054p076 = 0x29cf29cf29cf29cf;
|
||||
- static __int64 fix_n196p307n256 = 0xd18cd18cd18cd18c;
|
||||
- static __int64 fix_n089n039p150 = 0x06c206c206c206c2;
|
||||
- static __int64 fix_n256 = 0xadfdadfdadfdadfd;
|
||||
- static __int64 fix_n039 = 0xf384f384f384f384;
|
||||
- static __int64 fix_n256n039p205 = 0xe334e334e334e334;
|
||||
- static __int64 fix_n196 = 0xc13bc13bc13bc13b;
|
||||
- static __int64 fix_n089 = 0xe333e333e333e333;
|
||||
- static __int64 fixn089n196p029 = 0xadfcadfcadfcadfc;
|
||||
+ const __int64 fix_054n184 = 0xd630d630d630d630;
|
||||
+ const __int64 fix_054 = 0x1151115111511151;
|
||||
+ const __int64 fix_054p076 = 0x29cf29cf29cf29cf;
|
||||
+ const __int64 fix_n196p307n256 = 0xd18cd18cd18cd18c;
|
||||
+ const __int64 fix_n089n039p150 = 0x06c206c206c206c2;
|
||||
+ const __int64 fix_n256 = 0xadfdadfdadfdadfd;
|
||||
+ const __int64 fix_n039 = 0xf384f384f384f384;
|
||||
+ const __int64 fix_n256n039p205 = 0xe334e334e334e334;
|
||||
+ const __int64 fix_n196 = 0xc13bc13bc13bc13b;
|
||||
+ const __int64 fix_n089 = 0xe333e333e333e333;
|
||||
+ const __int64 fixn089n196p029 = 0xadfcadfcadfcadfc;
|
||||
|
||||
- static __int64 const_0x2xx8 = 0x0000010000000100;
|
||||
- static __int64 const_0x0808 = 0x0808080808080808;
|
||||
+ const __int64 const_0x2xx8 = 0x0000010000000100;
|
||||
+ const __int64 const_0x0808 = 0x0808080808080808;
|
||||
|
||||
__inline void domidct8x8llmW(short *inptr, short *quantptr, int *wsptr,
|
||||
JSAMPARRAY outptr, int output_col);
|
Loading…
Reference in New Issue
Block a user