- Add LICENSE

- Switch to PLIST_FILES, PORTDOCS
- Remove bunch of patches, replaced by REINPLACE_CMD

PR:		ports/172062
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
Feature safe:	yes
This commit is contained in:
Pawel Pekala 2012-11-10 17:07:42 +00:00
parent 6ec5eaf60c
commit a6d974d908
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=307295
6 changed files with 15 additions and 94 deletions

View File

@ -1,9 +1,5 @@
# New ports collection makefile for: sslwrap
# Date created: 1999 november 7.
# Whom: Zahemszky, Gabor <ZGabor at CoDe dot HU>
#
# Created by: Zahemszky, Gabor <ZGabor at CoDe dot HU>
# $FreeBSD$
#
PORTNAME= sslwrap
PORTVERSION= 2.0.6
@ -15,25 +11,27 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Another SSL Wrapper application, which uses SSLEay/OpenSSL
USE_OPENSSL= YES
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
DOCS= README docs.html
USE_OPENSSL= yes
PORTDOCS= README docs.html
PLIST_FILES= bin/sslwrap
.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e \
's/SSL_OP_NON_EXPORT_FIRST/SSL_OP_CIPHER_SERVER_PREFERENCE/g' \
${WRKSRC}/s_server.c
${REINPLACE_CMD} -e \
's,%%OPENSSL%%,openssl/,g' \
${WRKSRC}/s_server.c ${WRKSRC}/s_cb.c ${WRKSRC}/apps.h ${WRKSRC}/s_socket.c
@${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
's|SSL_OP_NON_EXPORT_FIRST|SSL_OP_CIPHER_SERVER_PREFERENCE|g ; \
s|OPENSSL"|"openssl/|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sslwrap ${PREFIX}/bin/sslwrap
.if !defined(NOPORTDOCS)
${INSTALL_PROGRAM} ${WRKSRC}/sslwrap ${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.for i in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1,15 +0,0 @@
--- apps.h.orig Wed Oct 15 22:28:24 2003
+++ apps.h Wed Oct 15 22:28:45 2003
@@ -65,9 +65,9 @@
#include "../e_os.h"
#endif
-#include OPENSSL"buffer.h"
-#include OPENSSL"bio.h"
-#include OPENSSL"crypto.h"
+#include "%%OPENSSL%%/buffer.h"
+#include "%%OPENSSL%%/bio.h"
+#include "%%OPENSSL%%/crypto.h"
/*#include "progs.h"*/
#ifdef WIN16

View File

@ -1,15 +0,0 @@
--- s_cb.c.orig Wed Oct 15 22:29:17 2003
+++ s_cb.c Wed Oct 15 22:29:31 2003
@@ -63,9 +63,9 @@
#include "apps.h"
#undef NON_MAIN
#undef USE_SOCKETS
-#include OPENSSL"err.h"
-#include OPENSSL"x509.h"
-#include OPENSSL"ssl.h"
+#include "%%OPENSSL%%/err.h"
+#include "%%OPENSSL%%/x509.h"
+#include "%%OPENSSL%%/ssl.h"
#include "s_apps.h"
int verify_depth=0;

View File

@ -1,32 +0,0 @@
--- s_server.c.orig Sat Nov 11 14:11:18 2000
+++ s_server.c Wed Oct 15 22:31:56 2003
@@ -121,14 +121,14 @@
#ifdef WIN16
#define APPS_WIN16
#endif
-#include OPENSSL"lhash.h"
-#include OPENSSL"bn.h"
+#include "openssl//lhash.h"
+#include "openssl//bn.h"
#define USE_SOCKETS
#include "apps.h"
-#include OPENSSL"err.h"
-#include OPENSSL"pem.h"
-#include OPENSSL"x509.h"
-#include OPENSSL"ssl.h"
+#include "openssl//err.h"
+#include "openssl//pem.h"
+#include "openssl//x509.h"
+#include "openssl//ssl.h"
#include "s_apps.h"
#ifndef NOPROTO
@@ -468,7 +468,7 @@
if (bugs) SSL_CTX_set_options(ctx,SSL_OP_ALL);
if (hack) SSL_CTX_set_options(ctx,SSL_OP_NETSCAPE_DEMO_CIPHER_CHANGE_BUG);
- if (hack) SSL_CTX_set_options(ctx,SSL_OP_NON_EXPORT_FIRST);
+ if (hack) SSL_CTX_set_options(ctx,SSL_OP_CIPHER_SERVER_PREFERENCE);
if (state) SSL_CTX_set_info_callback(ctx,apps_ssl_info_callback);

View File

@ -1,11 +0,0 @@
--- s_socket.c.orig Wed Oct 15 22:32:33 2003
+++ s_socket.c Wed Oct 15 22:32:45 2003
@@ -67,7 +67,7 @@
#undef USE_SOCKETS
#undef NON_MAIN
#include "s_apps.h"
-#include OPENSSL"ssl.h"
+#include "%%OPENSSL%%/ssl.h"
#ifndef NOPROTO
static struct hostent *GetHostByName(char *name);

View File

@ -1,4 +0,0 @@
bin/sslwrap
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/docs.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%