Update to 1.4.5.

This commit is contained in:
Maxim Sobolev 2001-01-02 19:32:20 +00:00
parent 16f2e27f6c
commit a6bb6554f4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36608
5 changed files with 43 additions and 7 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= extace
PORTVERSION= 1.3.2
PORTVERSION= 1.4.5
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= eXtace
@ -20,6 +20,7 @@ USE_IMLIB= yes
USE_ESOUND= yes
WANT_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --disable-alsa
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_LIBFFTW" \
LIBS="-L${LOCALBASE}/lib"
@ -30,6 +31,8 @@ USE_GNOME= yes
.endif
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g'

View File

@ -1 +1 @@
MD5 (extace-1.3.2.tar.gz) = 31302335dde169f34b4b07c458ebca52
MD5 (extace-1.4.5.tar.gz) = eb3975c05dbf94a3d52b3aea495349a2

View File

@ -1,6 +1,15 @@
--- extace/Makefile.in.orig Fri Jun 2 23:30:29 2000
+++ extace/Makefile.in Fri Jun 2 23:32:26 2000
@@ -108,7 +108,9 @@
--- extace/Makefile.in.orig Tue Jan 2 11:26:24 2001
+++ extace/Makefile.in Tue Jan 2 11:33:29 2001
@@ -101,7 +101,7 @@
extace_LDADD = @GTK_LIBS@ @ESD_LIBS@ @EXTRA_LIBS@ @ALSA_LIBS@ -lgdk_imlib
#extace_LDADD = -lefence @GTK_LIBS@ @ESD_LIBS@ @EXTRA_LIBS@ @ALSA_LIBS@ -lgdk_imlib
-LIBS = -lpthread
+LIBS = #-lpthread
COMMON_FLAGS = @PFLAGS@ @DFLAGS@
@@ -109,7 +109,9 @@
EXTRA_DIST = extace.desktop README NEWS TODO
@ -10,7 +19,7 @@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h
CONFIG_CLEAN_FILES =
@@ -237,7 +239,6 @@
@@ -239,7 +241,6 @@
install-MultimediaDATA: $(Multimedia_DATA)
@$(NORMAL_INSTALL)
@ -18,7 +27,7 @@
@list='$(Multimedia_DATA)'; for p in $$list; do \
if test -f $(srcdir)/$$p; then \
echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(Multimediadir)/$$p"; \
@@ -340,7 +341,7 @@
@@ -325,7 +326,7 @@
install-strip:
$(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
installdirs:

View File

@ -0,0 +1,12 @@
--- extace/misc.c 2001/01/02 09:29:43 1.1
+++ extace/misc.c 2001/01/02 09:30:30
@@ -20,7 +20,9 @@
#include <protos.h>
#include <math.h>
#include <gtk/gtk.h>
+#ifndef __FreeBSD__
#include <asm/errno.h>
+#endif
#include "convolve.h"
#ifdef HAVE_LIBRFFTW
#include <rfftw.h>

View File

@ -0,0 +1,12 @@
--- extace/sound.c 2001/01/02 09:31:56 1.1
+++ extace/sound.c 2001/01/02 09:32:16
@@ -24,7 +24,9 @@
#include <fcntl.h>
#include <gtk/gtk.h>
#include <esd.h>
+#ifndef __FreeBSD__
#include <asm/errno.h>
+#endif
#ifdef HAVE_PTHREAD_H
#include <pthread.h>
#endif