comms/limesuite: update 20.10.0 -> 22.09.0

- REMOTE option has been removed, because upstream dropped the feature
  (https://github.com/myriadrf/LimeSuite/issues/366)

PR:		266307
Changes:	https://github.com/myriadrf/LimeSuite/blob/master/Changelog.txt
This commit is contained in:
Tomasz "CeDeROM" CEDRO 2022-09-10 09:28:25 +02:00 committed by Kurt Jaeger
parent 4bf471e758
commit a69f092f0d
9 changed files with 55 additions and 173 deletions

View File

@ -1,7 +1,7 @@
PORTNAME= limesuite
DISTVERSIONPREFIX= v
DISTVERSION= 20.10.0
PORTREVISION= 4
DISTVERSION= 22.09.0
PORTREVISION= 0
CATEGORIES= comms astro hamradio
MAINTAINER= tomek@cedro.info
@ -23,26 +23,31 @@ GH_PROJECT= LimeSuite
CMAKE_ARGS= -DENABLE_SIMD_FLAGS:STRING="none"
# DESKTOP IS LINUX ONLY.
# SPI IS LINUX ONLY.
# STREAM UNITE BROKEN UPSTREAM
CMAKE_OFF= ENABLE_DESKTOP \
ENABLE_SPI \
ENABLE_STREAM \
ENABLE_STREAM_UNITE
ENABLE_SPI
CMAKE_ON= ENABLE_LIBRARY \
ENABLE_LIME_UTIL \
CMAKE_ON= ENABLE_EVB7COM \
ENABLE_EXAMPLES \
ENABLE_STREAM \
ENABLE_STREAM_UNITE \
ENABLE_FTDI \
ENABLE_FX3 \
ENABLE_HEADERS \
ENABLE_LIBRARY \
ENABLE_LIMERFE \
ENABLE_EVB7COM
ENABLE_LIME_UTIL \
ENABLE_MCU_TESTBENCH \
ENABLE_NEW_GAIN_BEHAVIOUR \
ENABLE_PCIE_XILLYBUS
OPTIONS_DEFINE= DOCS GUI QUICKTEST OCTAVE REMOTE SOAPYSDR DEBUG
OPTIONS_DEFAULT= GUI QUICKTEST SOAPYSDR DEBUG
OPTIONS_DEFINE= DOCS GUI QUICKTEST OCTAVE SOAPYSDR UTILITIES DEBUG
OPTIONS_DEFAULT= GUI QUICKTEST SOAPYSDR UTILITIES DEBUG
OPTIONS_UNSET= DOCS
OPTIONS_SUB= yes
QUICKTEST_DESC= Build QuickTest Self-Test suite
OCTAVE_DESC= Enable Octave integration
REMOTE_DESC= Enable remote testing operations
SOAPYSDR_DESC= Build LMS7 SoapySDR bindings
UTILITIES_DESC= Build the Utilities
PLIST_SUB= PORTVERSION=${PORTVERSION}
@ -57,28 +62,29 @@ QUICKTEST_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
OCTAVE_CMAKE_BOOL= ENABLE_OCTAVE
OCTAVE_BUILD_DEPENDS= octave:math/octave
REMOTE_CMAKE_BOOL= ENABLE_REMOTE
SOAPYSDR_CMAKE_BOOL= ENABLE_SOAPY_LMS7
SOAPYSDR_LIB_DEPENDS= libSoapySDR.so:misc/soapysdr
UTILITIES_CMAKE_BOOL= ENABLE_UTILITIES
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGUI}
USES+= gl xorg
USE_XORG+= x11 ice sm xcursor xext xfixes xinerama xft xrender
USE_GL+= gl glu
USE_WX+= 3.1
USE_GL+= gl glu
USE_WX+= 3.1
WX_COMPS+= wx:lib
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
.endif
.if ${PORT_OPTIONS:MOCTAVE}
.include "${.CURDIR}/../../math/octave/Makefile.version"
OCTAVE_OCT_SITE_DIR= "lib/octave/${OCTAVE_VERSION}/site/oct/${CONFIGURE_TARGET}/"
PLIST_SUB+= OCTAVE_OCT_SITE_DIR=${OCTAVE_OCT_SITE_DIR}
OCTAVE_M_SITE_DIR= "share/octave/${OCTAVE_VERSION}/site/m/"
PLIST_SUB+= OCTAVE_M_SITE_DIR=${OCTAVE_M_SITE_DIR}
# Use octave-config to obtain paths from installed and working Octave.
# Paths from Makefile will cause problems when using Port and Pkg builds.
OCTAVE_OCT_SITE_DIR= (octave-config --oct-site-dir)
OCTAVE_M_SITE_DIR= (octave-config --m-site-dir)
PLIST_SUB+= OCTAVE_OCT_SITE_DIR=${OCTAVE_OCT_SITE_DIR:sh}/
PLIST_SUB+= OCTAVE_M_SITE_DIR=${OCTAVE_M_SITE_DIR:sh}/
.endif
.if ${PORT_OPTIONS:MDEBUG}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1608434916
SHA256 (myriadrf-LimeSuite-v20.10.0_GH0.tar.gz) = f6d79dc67cb52a5aea839d1dc00e65f85367cb2c275d77f149833d32cf79b467
SIZE (myriadrf-LimeSuite-v20.10.0_GH0.tar.gz) = 5421065
TIMESTAMP = 1662669378
SHA256 (myriadrf-LimeSuite-v22.09.0_GH0.tar.gz) = 521e45298e1ffd0fd65006598e1edf37bd92a13667afaab262582fc681f1cf16
SIZE (myriadrf-LimeSuite-v22.09.0_GH0.tar.gz) = 5198877

View File

@ -1,14 +0,0 @@
--- CMakeLists.txt.orig 2020-10-29 09:52:56 UTC
+++ CMakeLists.txt
@@ -171,6 +171,11 @@ if (ENABLE_NEW_GAIN_BEHAVIOUR)
add_definitions(-DNEW_GAIN_BEHAVIOUR)
endif()
+if (CMAKE_SYSTEM_NAME MATCHES "BSD")
+ include_directories("/usr/local/include")
+ add_definitions(-D__unix__=1) #we use this for unix detection, but clang does not define it
+endif()
+
########################################################################
# rpath setup - http://www.cmake.org/Wiki/CMake_RPATH_handling
########################################################################

View File

@ -1,19 +0,0 @@
--- Desktop/CMakeLists.txt.orig 2020-10-29 09:52:56 UTC
+++ Desktop/CMakeLists.txt
@@ -1,13 +1,13 @@
########################################################################
## Feature registration
########################################################################
-if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
- set(LINUX TRUE)
+if(CMAKE_SYSTEM_NAME STREQUAL "Linux" OR "FreeBSD")
+ set(UNIX TRUE)
endif()
include(FeatureSummary)
include(CMakeDependentOption)
-cmake_dependent_option(ENABLE_DESKTOP "Enable LimeSuite launcher and icons" ON "ENABLE_GUI;LINUX" OFF)
+cmake_dependent_option(ENABLE_DESKTOP "Enable LimeSuite launcher and icons" ON "ENABLE_GUI;UNIX" OFF)
add_feature_info(LimeSuiteDesktop ENABLE_DESKTOP "LimeSuite freedesktop integration")
if (NOT ENABLE_DESKTOP)
return()

View File

@ -1,13 +0,0 @@
--- src/ConnectionRemote/ConnectionRemote.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/ConnectionRemote/ConnectionRemote.cpp
@@ -31,6 +31,10 @@
#include <Winsock.h>
#endif // LINUX
+#if defined(__FreeBSD__)
+#include <sys/socket.h>
+#endif
+
using namespace std;
using namespace lime;

View File

@ -1,10 +0,0 @@
--- src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITE.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITE.cpp
@@ -5,7 +5,6 @@
*/
#include "ConnectionSTREAM_UNITE.h"
-#include "ErrorReporting.h"
using namespace std;
namespace lime
{

View File

@ -1,11 +0,0 @@
--- src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITEEntry.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITEEntry.cpp
@@ -16,7 +16,7 @@ static ConnectionSTREAM_UNITEEntry STREAM_UNITEEntry;
}
ConnectionSTREAM_UNITEEntry::ConnectionSTREAM_UNITEEntry(void):
- ConnectionFX3Entry("STREAM+UNITE")
+ ConnectionFX3Entry()
{
}

View File

@ -1,11 +0,0 @@
--- src/FPGAcontrols_wxgui/FPGAcontrols_wxgui.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/FPGAcontrols_wxgui/FPGAcontrols_wxgui.cpp
@@ -166,7 +166,7 @@ int ReadWFM(const wxString filename, std::vector<int16
if( fpin.IsOpened() == false)
{
#ifndef NDEBUG
- lime::debug("WFM reading: Input file can not be opened (%s)", filename);
+ lime::debug("WFM reading: Input file can not be opened (%s)", filename.mb_str().data());
#endif
return -1;
}

View File

@ -6,6 +6,7 @@ bin/gpio_example
bin/limeRFE_ADC_example
bin/limeRFE_I2C_example
bin/limeRFE_USB_example
bin/pll_sweep
bin/singleRX
include/lime/ADCUnits.h
include/lime/ADF4002.h
@ -35,7 +36,7 @@ include/lime/lms7_device.h
lib/cmake/LimeSuite/LimeSuiteConfig.cmake
lib/cmake/LimeSuite/LimeSuiteConfigVersion.cmake
lib/libLimeSuite.so
lib/libLimeSuite.so.20.10-1
lib/libLimeSuite.so.22.09-1
lib/libLimeSuite.so.%%PORTVERSION%%
libdata/pkgconfig/LimeSuite.pc
%%SOAPYSDR%%lib/SoapySDR/modules0.8/libLMS7Support.so
@ -56,21 +57,23 @@ libdata/pkgconfig/LimeSuite.pc
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/annotated_dup.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/bc_s.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/bc_sd.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/bdwn.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/classes.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/closed.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/deprecated.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_32ceaae954650ed827ac1560ef6f4ef9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_32ceaae954650ed827ac1560ef6f4ef9.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_34940aac630699970110928b60ddb4bc.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d250019ea536d42a5797d8e92eb15235.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d250019ea536d42a5797d8e92eb15235.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d2e0d63e6f0c29b47fae2fad83249b64.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d2e0d63e6f0c29b47fae2fad83249b64.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_e3821db3a7cd44f7328e850c7cb284c9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_0d2dd864200361bd34e849fed8019e44.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_0d2dd864200361bd34e849fed8019e44.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_25fe8f646ea38f0865d7c839495fe687.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_4290afb369ac5dd3f9f380897747314e.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_4290afb369ac5dd3f9f380897747314e.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_80cd1a8354dceaec9fe94a66b50d8e63.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_ac3d0cd76366fce9f9a40cf6131e4399.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_ac3d0cd76366fce9f9a40cf6131e4399.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/doc.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/docd.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/doxygen.svg
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dynsections.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/files.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/files_dup.js
@ -113,135 +116,82 @@ libdata/pkgconfig/LimeSuite.pc
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/modules.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/modules.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_f.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_fd.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_g.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_hd.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtree.css
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtree.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtreedata.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtreeindex0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtreeindex1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/open.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/page_changelog.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/pages.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/resize.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_10.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_10.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_11.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_11.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_3.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_3.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_4.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_4.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_5.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_5.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_6.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_6.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_7.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_7.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_8.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_8.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_9.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_a.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_a.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_b.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_b.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_c.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_c.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_d.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_d.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_e.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_e.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_f.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_f.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/classes_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/classes_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/close.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enums_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/close.svg
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enums_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enumvalues_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enumvalues_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/files_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/files_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/functions_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/functions_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_3.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_3.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_4.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_4.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_5.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_5.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_6.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_6.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_7.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_7.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_8.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_8.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/mag_sel.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/nomatches.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/mag.svg
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/mag_d.svg
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/mag_sel.svg
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/mag_seld.svg
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search.css
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search_l.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search_m.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search_r.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/searchdata.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_10.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_10.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_3.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_3.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_4.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_4.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_5.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_5.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_6.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_6.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_7.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_7.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_8.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_8.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_9.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_a.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_a.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_b.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_b.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_c.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_c.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_d.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_d.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_e.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_e.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_f.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_f.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/splitbar.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/splitbard.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__dev__info__t.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__dev__info__t.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__range__t.html
@ -255,9 +205,13 @@ libdata/pkgconfig/LimeSuite.pc
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/sync_off.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/sync_on.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_a.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_ad.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_b.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_bd.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_h.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_hd.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_s.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_sd.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tabs.css
%%PORTDOCS%%%%DOCSDIR%%/Lime_Suite_Compilation_Guide.odt
%%PORTDOCS%%%%DOCSDIR%%/Lime_Suite_Compilation_Guide.pdf