- Update to version 2.5.0

- Respect PTHREAD_{CFLAGS,LIBS}

PR:		ports/63162
Submitted by:	maintainer
This commit is contained in:
Kirill Ponomarev 2004-02-24 09:53:19 +00:00
parent dc228774ef
commit a69387c6d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101955
27 changed files with 6282 additions and 5412 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= xerces-c2
PORTVERSION= 2.3.0
PORTREVISION= 2
PORTVERSION= 2.5.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
@ -24,7 +23,7 @@ PLIST_SUB+= TRANSICU="@comment "
.else
.if (${TRANSCODER} == "icu")
PKGNAMESUFFIX+= -icu2
LIB_DEPENDS+= icuuc.26:${PORTSDIR}/devel/icu2
LIB_DEPENDS+= icuuc.28:${PORTSDIR}/devel/icu2
ICUROOT?= ${LOCALBASE}
CONFIGURE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
@ -61,20 +60,26 @@ CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
CONFIGURE_ARGS+= -t ${TRANSCODER}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502102
FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
.endif
.if defined(DEBUG)
PKGNAMESUFFIX+= -debug
CONFIGURE_ARGS+= -d
STRIP=
.endif
.include <bsd.port.pre.mk>
.if defined(ARCH) && \
(${ARCH} == "alpha" || ${ARCH} == "sparc64" || \
${ARCH} == "amd64" || ${ARCH} == "ia64")
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64
.endif
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
.else
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.endif
XERCESC_LIB_VERSION= ${PORTVERSION:S/.//:R}
@ -92,6 +97,8 @@ SAMPLES_CONFIG_ARGS+= -p freebsd -c ${CC} -x ${CXX}
SAMPLES_CONFIG_ARGS+= -r none
.else
SAMPLES_CONFIG_ARGS+= -r pthread
SAMPLES_CONFIG_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.endif
.else
PLIST_SUB+= NO_SAMPLES="@comment "
@ -99,8 +106,6 @@ PLIST_SUB+= NO_SAMPLES="@comment "
pre-everything::
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
@(/usr/bin/dialog --textbox ${MASTERDIR}/pkg-message 15 75 || \
${TRUE})
@${ECHO} ''
@${ECHO} 'You may use the following build options by defining'
@${ECHO} 'them on the command line with -D'
@ -132,13 +137,17 @@ post-configure:
.if !defined(NO_SAMPLES)
.if defined(TRANSCODER) && (${TRANSCODER} == "icu")
@(cd ${WRKSRC}/samples && \
export XERCESCROOT=${WRKSRC} && \
export ICUROOT=${ICUROOT} && \
export LDFLAGS="-L${LOCALBASE}/lib" && \
${SETENV} \
XERCESCROOT=${WRKSRC} \
ICUROOT=${ICUROOT} \
LDFLAGS="-L${LOCALBASE}/lib" \
${SAMPLES_CONFIG_ENV} \
${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
.else
@(cd ${WRKSRC}/samples && \
export XERCESCROOT=${WRKSRC} && \
${SETENV} \
XERCESCROOT=${WRKSRC} \
${SAMPLES_CONFIG_ENV} \
${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
.endif
.endif
@ -148,13 +157,13 @@ post-install:
@${STRIP_CMD} ${PREFIX}/lib/${XERCESC_LIB}
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xerces-c
@${CP} -r ${WRKSRC}/doc/ ${PREFIX}/share/doc/xerces-c/
@${MKDIR} ${DOCSDIR}
@${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
.endif
.if !defined(NO_SAMPLES)
@${MKDIR} ${PREFIX}/share/xerces-c
@${MKDIR} ${EXAMPLESDIR}
.for i in ${XERCES_BINS} data
@${CP} -r ${WRKSRC}/samples/$i ${PREFIX}/share/xerces-c/
@${CP} -r ${WRKSRC}/samples/$i ${EXAMPLESDIR}
.endfor
.for i in ${XERCES_BINS}
@${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin

View File

@ -1,10 +0,0 @@
# Date created: 29 December 2002
# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
#
# $FreeBSD$
#
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64

View File

@ -1,14 +0,0 @@
# Date created: 26 December 2002
# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
#
# $FreeBSD$
#
# When there are no probs with libc_r / pthreads on sparc64-freebsd we
# should remove this files or make it conditional on OSVERSION
NO_THREADS= yes
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64

View File

@ -1 +1,2 @@
MD5 (xerces-c-src_2_3_0.tar.gz) = 5167dca8942dd2dd719fa5a8ebe0c18b
MD5 (xerces-c-src_2_5_0.tar.gz) = e7ff7d007fabfa7e3fc8c75a8007b0b1
SIZE (xerces-c-src_2_5_0.tar.gz) = 9379748

View File

@ -1,26 +1,35 @@
diff -x CVS -urN src/xercesc/util/Transcoders/ICU/ICUTransService.cpp src.cvs/xercesc/util/Transcoders/ICU/ICUTransService.cpp
--- src/xercesc/util/Transcoders/ICU/ICUTransService.cpp Sat May 17 16:32:17 2003
+++ src.cvs/xercesc/util/Transcoders/ICU/ICUTransService.cpp Sun Jun 15 10:02:16 2003
@@ -55,7 +55,7 @@
*/
/*
- * $Id: ICUTransService.cpp,v 1.9 2003/05/17 16:32:17 knoaman Exp $
+ * $Id: ICUTransService.cpp,v 1.10 2003/05/30 09:19:24 gareth Exp $
*/
@@ -127,11 +127,11 @@
static XMLCh* convertToXMLCh( const UChar* const toConvert,
- , MemoryManager* const manager = 0)
+ MemoryManager* const manager = 0)
{
const unsigned int srcLen = u_strlen(toConvert);
XMLCh* retBuf = (manager)
- ? (XMLCh*) manager->allocate((srcLen+1) sizeof(XMLCh))
+ ? (XMLCh*) manager->allocate((srcLen+1) * sizeof(XMLCh))
: new XMLCh[srcLen + 1];
XMLCh* outPtr = retBuf;
--- samples/runConfigure.orig Mon May 12 09:44:18 2003
+++ samples/runConfigure Tue Feb 17 20:26:46 2004
@@ -262,8 +262,13 @@ else
;;
esac
elif test $platform = "freebsd"; then
- threadingLibs="-pthread -lc_r"
- threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
+ if test -n "${PTHREAD_LIBS}" ; then
+ threadingLibs="${PTHREAD_LIBS}"
+ threadingDefines="${PTHREAD_CFLAGS} -DXML_USE_PTHREADS"
+ else
+ threadingLibs="-lpthread"
+ threadingDefines="-DXML_USE_PTHREADS"
+ fi
elif test $platform = "netbsd"; then
threadingLibs="-pthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
--- src/xercesc/runConfigure.orig Tue Feb 17 20:05:09 2004
+++ src/xercesc/runConfigure Tue Feb 17 20:27:13 2004
@@ -303,8 +303,13 @@ else
;;
esac
elif test $platform = "freebsd"; then
- threadingLibs="-pthread -lc_r"
+ if test -n "${PTHREAD_LIBS}" ; then
+ threadingLibs="${PTHREAD_LIBS}"
+ threadingDefines="${PTHREAD_CFLAGS} -DXML_USE_PTHREADS"
+ else
+ threadingLibs="-lpthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
+ fi
elif test $platform = "netbsd"; then
threadingLibs="-pthread -lpthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"

View File

@ -1,38 +0,0 @@
--- src/xercesc/dom/impl/DOMDeepNodeListPool.c Tue Jun 17 22:09:06 2003
+++ src.cvs/xercesc/dom/impl/DOMDeepNodeListPool.c Tue Jun 17 22:09:39 2003
@@ -90,7 +90,11 @@
initialize(modulus);
// create default hasher
+#if defined (XML_GCC_VERSION) && (XML_GCC_VERSION < 29600)
+ fHash = new HashPtr();
+#else
fHash = new (fMemoryManager) HashPtr();
+#endif
//
// Allocate the initial id pointers array. We don't have to zero them
--- src/xercesc/util/RefHash3KeysIdPool.c Tue Jun 17 22:12:13 2003
+++ src.cvs/xercesc/util/RefHash3KeysIdPool.c Sun Jun 15 09:57:39 2003
@@ -56,6 +56,9 @@
/**
* $Log: RefHash3KeysIdPool.c,v $
+ * Revision 1.6 2003/06/02 15:18:08 neilg
+ * fix for bug #20092; thanks to Berin Lautenbach
+ *
* Revision 1.5 2003/05/21 21:08:04 knoaman
* gcc 2.95.x is generating an internal error for some template definitions, so
* we use the default memory manger in such cases.
@@ -118,7 +121,11 @@
initialize(modulus);
// create default hasher
+#if defined (XML_GCC_VERSION) && (XML_GCC_VERSION < 29600)
+ fHash = new HashXMLCh();
+#else
fHash = new (fMemoryManager) HashXMLCh();
+#endif
//
// Allocate the initial id pointers array. We don't have to zero them

View File

@ -1,20 +0,0 @@
--- src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:32:33 2003
+++ src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:31:16 2003
@@ -298,7 +298,7 @@
XMLExcepts::CPtr_PointerIsZero);
const char* tmpFileName = XMLString::transcode(fileName, fgMemoryManager);
ArrayJanitor<char> janText((char*)tmpFileName, fgMemoryManager);
- FileHandle retVal = (FileHandle)fopen( tmpFileName , "r+" );
+ FileHandle retVal = (FileHandle)fopen( tmpFileName , "r" );
return retVal;
}
@@ -307,7 +307,7 @@
if (fileName == NULL)
ThrowXML(XMLPlatformUtilsException,
XMLExcepts::CPtr_PointerIsZero);
- FileHandle retVal = (FileHandle)fopen( fileName , "r+" );
+ FileHandle retVal = (FileHandle)fopen( fileName , "r" );
return retVal;
}

View File

@ -1,9 +0,0 @@
In the new major version 2, Xerces-C++ has undergone some
significant API changes.
The old java-like API has been moved from <xercesc/dom/*> to
<xercesc/dom/depreceated/*> and is expected to go away in the
near future.
For further information please visit
WWW: http://xml.apache.org/xerces-c/migrate.html

File diff suppressed because it is too large Load Diff

View File

@ -6,8 +6,7 @@
#
PORTNAME= xerces-c2
PORTVERSION= 2.3.0
PORTREVISION= 2
PORTVERSION= 2.5.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
@ -24,7 +23,7 @@ PLIST_SUB+= TRANSICU="@comment "
.else
.if (${TRANSCODER} == "icu")
PKGNAMESUFFIX+= -icu2
LIB_DEPENDS+= icuuc.26:${PORTSDIR}/devel/icu2
LIB_DEPENDS+= icuuc.28:${PORTSDIR}/devel/icu2
ICUROOT?= ${LOCALBASE}
CONFIGURE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
@ -61,20 +60,26 @@ CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
CONFIGURE_ARGS+= -t ${TRANSCODER}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502102
FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
.endif
.if defined(DEBUG)
PKGNAMESUFFIX+= -debug
CONFIGURE_ARGS+= -d
STRIP=
.endif
.include <bsd.port.pre.mk>
.if defined(ARCH) && \
(${ARCH} == "alpha" || ${ARCH} == "sparc64" || \
${ARCH} == "amd64" || ${ARCH} == "ia64")
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64
.endif
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
.else
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.endif
XERCESC_LIB_VERSION= ${PORTVERSION:S/.//:R}
@ -92,6 +97,8 @@ SAMPLES_CONFIG_ARGS+= -p freebsd -c ${CC} -x ${CXX}
SAMPLES_CONFIG_ARGS+= -r none
.else
SAMPLES_CONFIG_ARGS+= -r pthread
SAMPLES_CONFIG_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.endif
.else
PLIST_SUB+= NO_SAMPLES="@comment "
@ -99,8 +106,6 @@ PLIST_SUB+= NO_SAMPLES="@comment "
pre-everything::
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
@(/usr/bin/dialog --textbox ${MASTERDIR}/pkg-message 15 75 || \
${TRUE})
@${ECHO} ''
@${ECHO} 'You may use the following build options by defining'
@${ECHO} 'them on the command line with -D'
@ -132,13 +137,17 @@ post-configure:
.if !defined(NO_SAMPLES)
.if defined(TRANSCODER) && (${TRANSCODER} == "icu")
@(cd ${WRKSRC}/samples && \
export XERCESCROOT=${WRKSRC} && \
export ICUROOT=${ICUROOT} && \
export LDFLAGS="-L${LOCALBASE}/lib" && \
${SETENV} \
XERCESCROOT=${WRKSRC} \
ICUROOT=${ICUROOT} \
LDFLAGS="-L${LOCALBASE}/lib" \
${SAMPLES_CONFIG_ENV} \
${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
.else
@(cd ${WRKSRC}/samples && \
export XERCESCROOT=${WRKSRC} && \
${SETENV} \
XERCESCROOT=${WRKSRC} \
${SAMPLES_CONFIG_ENV} \
${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
.endif
.endif
@ -148,13 +157,13 @@ post-install:
@${STRIP_CMD} ${PREFIX}/lib/${XERCESC_LIB}
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xerces-c
@${CP} -r ${WRKSRC}/doc/ ${PREFIX}/share/doc/xerces-c/
@${MKDIR} ${DOCSDIR}
@${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
.endif
.if !defined(NO_SAMPLES)
@${MKDIR} ${PREFIX}/share/xerces-c
@${MKDIR} ${EXAMPLESDIR}
.for i in ${XERCES_BINS} data
@${CP} -r ${WRKSRC}/samples/$i ${PREFIX}/share/xerces-c/
@${CP} -r ${WRKSRC}/samples/$i ${EXAMPLESDIR}
.endfor
.for i in ${XERCES_BINS}
@${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin

View File

@ -1,10 +0,0 @@
# Date created: 29 December 2002
# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
#
# $FreeBSD$
#
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64

View File

@ -1,14 +0,0 @@
# Date created: 26 December 2002
# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
#
# $FreeBSD$
#
# When there are no probs with libc_r / pthreads on sparc64-freebsd we
# should remove this files or make it conditional on OSVERSION
NO_THREADS= yes
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64

View File

@ -1 +1,2 @@
MD5 (xerces-c-src_2_3_0.tar.gz) = 5167dca8942dd2dd719fa5a8ebe0c18b
MD5 (xerces-c-src_2_5_0.tar.gz) = e7ff7d007fabfa7e3fc8c75a8007b0b1
SIZE (xerces-c-src_2_5_0.tar.gz) = 9379748

View File

@ -1,26 +1,35 @@
diff -x CVS -urN src/xercesc/util/Transcoders/ICU/ICUTransService.cpp src.cvs/xercesc/util/Transcoders/ICU/ICUTransService.cpp
--- src/xercesc/util/Transcoders/ICU/ICUTransService.cpp Sat May 17 16:32:17 2003
+++ src.cvs/xercesc/util/Transcoders/ICU/ICUTransService.cpp Sun Jun 15 10:02:16 2003
@@ -55,7 +55,7 @@
*/
/*
- * $Id: ICUTransService.cpp,v 1.9 2003/05/17 16:32:17 knoaman Exp $
+ * $Id: ICUTransService.cpp,v 1.10 2003/05/30 09:19:24 gareth Exp $
*/
@@ -127,11 +127,11 @@
static XMLCh* convertToXMLCh( const UChar* const toConvert,
- , MemoryManager* const manager = 0)
+ MemoryManager* const manager = 0)
{
const unsigned int srcLen = u_strlen(toConvert);
XMLCh* retBuf = (manager)
- ? (XMLCh*) manager->allocate((srcLen+1) sizeof(XMLCh))
+ ? (XMLCh*) manager->allocate((srcLen+1) * sizeof(XMLCh))
: new XMLCh[srcLen + 1];
XMLCh* outPtr = retBuf;
--- samples/runConfigure.orig Mon May 12 09:44:18 2003
+++ samples/runConfigure Tue Feb 17 20:26:46 2004
@@ -262,8 +262,13 @@ else
;;
esac
elif test $platform = "freebsd"; then
- threadingLibs="-pthread -lc_r"
- threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
+ if test -n "${PTHREAD_LIBS}" ; then
+ threadingLibs="${PTHREAD_LIBS}"
+ threadingDefines="${PTHREAD_CFLAGS} -DXML_USE_PTHREADS"
+ else
+ threadingLibs="-lpthread"
+ threadingDefines="-DXML_USE_PTHREADS"
+ fi
elif test $platform = "netbsd"; then
threadingLibs="-pthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
--- src/xercesc/runConfigure.orig Tue Feb 17 20:05:09 2004
+++ src/xercesc/runConfigure Tue Feb 17 20:27:13 2004
@@ -303,8 +303,13 @@ else
;;
esac
elif test $platform = "freebsd"; then
- threadingLibs="-pthread -lc_r"
+ if test -n "${PTHREAD_LIBS}" ; then
+ threadingLibs="${PTHREAD_LIBS}"
+ threadingDefines="${PTHREAD_CFLAGS} -DXML_USE_PTHREADS"
+ else
+ threadingLibs="-lpthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
+ fi
elif test $platform = "netbsd"; then
threadingLibs="-pthread -lpthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"

View File

@ -1,38 +0,0 @@
--- src/xercesc/dom/impl/DOMDeepNodeListPool.c Tue Jun 17 22:09:06 2003
+++ src.cvs/xercesc/dom/impl/DOMDeepNodeListPool.c Tue Jun 17 22:09:39 2003
@@ -90,7 +90,11 @@
initialize(modulus);
// create default hasher
+#if defined (XML_GCC_VERSION) && (XML_GCC_VERSION < 29600)
+ fHash = new HashPtr();
+#else
fHash = new (fMemoryManager) HashPtr();
+#endif
//
// Allocate the initial id pointers array. We don't have to zero them
--- src/xercesc/util/RefHash3KeysIdPool.c Tue Jun 17 22:12:13 2003
+++ src.cvs/xercesc/util/RefHash3KeysIdPool.c Sun Jun 15 09:57:39 2003
@@ -56,6 +56,9 @@
/**
* $Log: RefHash3KeysIdPool.c,v $
+ * Revision 1.6 2003/06/02 15:18:08 neilg
+ * fix for bug #20092; thanks to Berin Lautenbach
+ *
* Revision 1.5 2003/05/21 21:08:04 knoaman
* gcc 2.95.x is generating an internal error for some template definitions, so
* we use the default memory manger in such cases.
@@ -118,7 +121,11 @@
initialize(modulus);
// create default hasher
+#if defined (XML_GCC_VERSION) && (XML_GCC_VERSION < 29600)
+ fHash = new HashXMLCh();
+#else
fHash = new (fMemoryManager) HashXMLCh();
+#endif
//
// Allocate the initial id pointers array. We don't have to zero them

View File

@ -1,20 +0,0 @@
--- src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:32:33 2003
+++ src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:31:16 2003
@@ -298,7 +298,7 @@
XMLExcepts::CPtr_PointerIsZero);
const char* tmpFileName = XMLString::transcode(fileName, fgMemoryManager);
ArrayJanitor<char> janText((char*)tmpFileName, fgMemoryManager);
- FileHandle retVal = (FileHandle)fopen( tmpFileName , "r+" );
+ FileHandle retVal = (FileHandle)fopen( tmpFileName , "r" );
return retVal;
}
@@ -307,7 +307,7 @@
if (fileName == NULL)
ThrowXML(XMLPlatformUtilsException,
XMLExcepts::CPtr_PointerIsZero);
- FileHandle retVal = (FileHandle)fopen( fileName , "r+" );
+ FileHandle retVal = (FileHandle)fopen( fileName , "r" );
return retVal;
}

View File

@ -1,9 +0,0 @@
In the new major version 2, Xerces-C++ has undergone some
significant API changes.
The old java-like API has been moved from <xercesc/dom/*> to
<xercesc/dom/depreceated/*> and is expected to go away in the
near future.
For further information please visit
WWW: http://xml.apache.org/xerces-c/migrate.html

File diff suppressed because it is too large Load Diff

View File

@ -6,8 +6,7 @@
#
PORTNAME= xerces-c2
PORTVERSION= 2.3.0
PORTREVISION= 2
PORTVERSION= 2.5.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
@ -24,7 +23,7 @@ PLIST_SUB+= TRANSICU="@comment "
.else
.if (${TRANSCODER} == "icu")
PKGNAMESUFFIX+= -icu2
LIB_DEPENDS+= icuuc.26:${PORTSDIR}/devel/icu2
LIB_DEPENDS+= icuuc.28:${PORTSDIR}/devel/icu2
ICUROOT?= ${LOCALBASE}
CONFIGURE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
@ -61,20 +60,26 @@ CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
CONFIGURE_ARGS+= -t ${TRANSCODER}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502102
FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
.endif
.if defined(DEBUG)
PKGNAMESUFFIX+= -debug
CONFIGURE_ARGS+= -d
STRIP=
.endif
.include <bsd.port.pre.mk>
.if defined(ARCH) && \
(${ARCH} == "alpha" || ${ARCH} == "sparc64" || \
${ARCH} == "amd64" || ${ARCH} == "ia64")
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64
.endif
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
.else
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.endif
XERCESC_LIB_VERSION= ${PORTVERSION:S/.//:R}
@ -92,6 +97,8 @@ SAMPLES_CONFIG_ARGS+= -p freebsd -c ${CC} -x ${CXX}
SAMPLES_CONFIG_ARGS+= -r none
.else
SAMPLES_CONFIG_ARGS+= -r pthread
SAMPLES_CONFIG_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.endif
.else
PLIST_SUB+= NO_SAMPLES="@comment "
@ -99,8 +106,6 @@ PLIST_SUB+= NO_SAMPLES="@comment "
pre-everything::
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
@(/usr/bin/dialog --textbox ${MASTERDIR}/pkg-message 15 75 || \
${TRUE})
@${ECHO} ''
@${ECHO} 'You may use the following build options by defining'
@${ECHO} 'them on the command line with -D'
@ -132,13 +137,17 @@ post-configure:
.if !defined(NO_SAMPLES)
.if defined(TRANSCODER) && (${TRANSCODER} == "icu")
@(cd ${WRKSRC}/samples && \
export XERCESCROOT=${WRKSRC} && \
export ICUROOT=${ICUROOT} && \
export LDFLAGS="-L${LOCALBASE}/lib" && \
${SETENV} \
XERCESCROOT=${WRKSRC} \
ICUROOT=${ICUROOT} \
LDFLAGS="-L${LOCALBASE}/lib" \
${SAMPLES_CONFIG_ENV} \
${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
.else
@(cd ${WRKSRC}/samples && \
export XERCESCROOT=${WRKSRC} && \
${SETENV} \
XERCESCROOT=${WRKSRC} \
${SAMPLES_CONFIG_ENV} \
${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
.endif
.endif
@ -148,13 +157,13 @@ post-install:
@${STRIP_CMD} ${PREFIX}/lib/${XERCESC_LIB}
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xerces-c
@${CP} -r ${WRKSRC}/doc/ ${PREFIX}/share/doc/xerces-c/
@${MKDIR} ${DOCSDIR}
@${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
.endif
.if !defined(NO_SAMPLES)
@${MKDIR} ${PREFIX}/share/xerces-c
@${MKDIR} ${EXAMPLESDIR}
.for i in ${XERCES_BINS} data
@${CP} -r ${WRKSRC}/samples/$i ${PREFIX}/share/xerces-c/
@${CP} -r ${WRKSRC}/samples/$i ${EXAMPLESDIR}
.endfor
.for i in ${XERCES_BINS}
@${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin

View File

@ -1,10 +0,0 @@
# Date created: 29 December 2002
# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
#
# $FreeBSD$
#
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64

View File

@ -1,14 +0,0 @@
# Date created: 26 December 2002
# Whom: "Bjoern A. Zeeb" (bzeeb+freebsdports@zabbadoz.net)
#
# $FreeBSD$
#
# When there are no probs with libc_r / pthreads on sparc64-freebsd we
# should remove this files or make it conditional on OSVERSION
NO_THREADS= yes
# set bitsToBuild to 64
CONFIGURE_ARGS+= -b 64
SAMPLES_CONFIG_ARGS+= -b 64

View File

@ -1 +1,2 @@
MD5 (xerces-c-src_2_3_0.tar.gz) = 5167dca8942dd2dd719fa5a8ebe0c18b
MD5 (xerces-c-src_2_5_0.tar.gz) = e7ff7d007fabfa7e3fc8c75a8007b0b1
SIZE (xerces-c-src_2_5_0.tar.gz) = 9379748

View File

@ -1,26 +1,35 @@
diff -x CVS -urN src/xercesc/util/Transcoders/ICU/ICUTransService.cpp src.cvs/xercesc/util/Transcoders/ICU/ICUTransService.cpp
--- src/xercesc/util/Transcoders/ICU/ICUTransService.cpp Sat May 17 16:32:17 2003
+++ src.cvs/xercesc/util/Transcoders/ICU/ICUTransService.cpp Sun Jun 15 10:02:16 2003
@@ -55,7 +55,7 @@
*/
/*
- * $Id: ICUTransService.cpp,v 1.9 2003/05/17 16:32:17 knoaman Exp $
+ * $Id: ICUTransService.cpp,v 1.10 2003/05/30 09:19:24 gareth Exp $
*/
@@ -127,11 +127,11 @@
static XMLCh* convertToXMLCh( const UChar* const toConvert,
- , MemoryManager* const manager = 0)
+ MemoryManager* const manager = 0)
{
const unsigned int srcLen = u_strlen(toConvert);
XMLCh* retBuf = (manager)
- ? (XMLCh*) manager->allocate((srcLen+1) sizeof(XMLCh))
+ ? (XMLCh*) manager->allocate((srcLen+1) * sizeof(XMLCh))
: new XMLCh[srcLen + 1];
XMLCh* outPtr = retBuf;
--- samples/runConfigure.orig Mon May 12 09:44:18 2003
+++ samples/runConfigure Tue Feb 17 20:26:46 2004
@@ -262,8 +262,13 @@ else
;;
esac
elif test $platform = "freebsd"; then
- threadingLibs="-pthread -lc_r"
- threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
+ if test -n "${PTHREAD_LIBS}" ; then
+ threadingLibs="${PTHREAD_LIBS}"
+ threadingDefines="${PTHREAD_CFLAGS} -DXML_USE_PTHREADS"
+ else
+ threadingLibs="-lpthread"
+ threadingDefines="-DXML_USE_PTHREADS"
+ fi
elif test $platform = "netbsd"; then
threadingLibs="-pthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
--- src/xercesc/runConfigure.orig Tue Feb 17 20:05:09 2004
+++ src/xercesc/runConfigure Tue Feb 17 20:27:13 2004
@@ -303,8 +303,13 @@ else
;;
esac
elif test $platform = "freebsd"; then
- threadingLibs="-pthread -lc_r"
+ if test -n "${PTHREAD_LIBS}" ; then
+ threadingLibs="${PTHREAD_LIBS}"
+ threadingDefines="${PTHREAD_CFLAGS} -DXML_USE_PTHREADS"
+ else
+ threadingLibs="-lpthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
+ fi
elif test $platform = "netbsd"; then
threadingLibs="-pthread -lpthread"
threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"

View File

@ -1,38 +0,0 @@
--- src/xercesc/dom/impl/DOMDeepNodeListPool.c Tue Jun 17 22:09:06 2003
+++ src.cvs/xercesc/dom/impl/DOMDeepNodeListPool.c Tue Jun 17 22:09:39 2003
@@ -90,7 +90,11 @@
initialize(modulus);
// create default hasher
+#if defined (XML_GCC_VERSION) && (XML_GCC_VERSION < 29600)
+ fHash = new HashPtr();
+#else
fHash = new (fMemoryManager) HashPtr();
+#endif
//
// Allocate the initial id pointers array. We don't have to zero them
--- src/xercesc/util/RefHash3KeysIdPool.c Tue Jun 17 22:12:13 2003
+++ src.cvs/xercesc/util/RefHash3KeysIdPool.c Sun Jun 15 09:57:39 2003
@@ -56,6 +56,9 @@
/**
* $Log: RefHash3KeysIdPool.c,v $
+ * Revision 1.6 2003/06/02 15:18:08 neilg
+ * fix for bug #20092; thanks to Berin Lautenbach
+ *
* Revision 1.5 2003/05/21 21:08:04 knoaman
* gcc 2.95.x is generating an internal error for some template definitions, so
* we use the default memory manger in such cases.
@@ -118,7 +121,11 @@
initialize(modulus);
// create default hasher
+#if defined (XML_GCC_VERSION) && (XML_GCC_VERSION < 29600)
+ fHash = new HashXMLCh();
+#else
fHash = new (fMemoryManager) HashXMLCh();
+#endif
//
// Allocate the initial id pointers array. We don't have to zero them

View File

@ -1,20 +0,0 @@
--- src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:32:33 2003
+++ src/xercesc/util/Platforms/FreeBSD/FreeBSDPlatformUtils.cpp Wed Nov 12 20:31:16 2003
@@ -298,7 +298,7 @@
XMLExcepts::CPtr_PointerIsZero);
const char* tmpFileName = XMLString::transcode(fileName, fgMemoryManager);
ArrayJanitor<char> janText((char*)tmpFileName, fgMemoryManager);
- FileHandle retVal = (FileHandle)fopen( tmpFileName , "r+" );
+ FileHandle retVal = (FileHandle)fopen( tmpFileName , "r" );
return retVal;
}
@@ -307,7 +307,7 @@
if (fileName == NULL)
ThrowXML(XMLPlatformUtilsException,
XMLExcepts::CPtr_PointerIsZero);
- FileHandle retVal = (FileHandle)fopen( fileName , "r+" );
+ FileHandle retVal = (FileHandle)fopen( fileName , "r" );
return retVal;
}

View File

@ -1,9 +0,0 @@
In the new major version 2, Xerces-C++ has undergone some
significant API changes.
The old java-like API has been moved from <xercesc/dom/*> to
<xercesc/dom/depreceated/*> and is expected to go away in the
near future.
For further information please visit
WWW: http://xml.apache.org/xerces-c/migrate.html

File diff suppressed because it is too large Load Diff