Update to 2002.02.25

PR:		35413
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Patrick Li 2002-03-03 08:09:43 +00:00
parent a1b38dadba
commit a620779771
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55465
4 changed files with 93 additions and 21 deletions

View File

@ -7,21 +7,17 @@
#
PORTNAME= fxt
PORTVERSION= 2001.10.15
PORTVERSION= 2002.02.25
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"
post-patch:
@${PERL} -pi -e "s,^CXX,#CXX,g ; \
s,^PREFIX,#PREFIX,g" ${WRKSRC}/${MAKEFILE}
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
MAKEFILE= makefile
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (fxt-2001.10.15.tgz) = a22c3e539c426bb6c09942d2e0726aae
MD5 (fxt-2002.02.25.tgz) = d0863ba3eb86b6342d510b7c14e875ed

View File

@ -1,14 +1,57 @@
--- makefile.orig Wed Nov 28 11:53:26 2001
+++ makefile Wed Nov 28 11:54:18 2001
@@ -441,9 +441,9 @@
--- makefile.orig Tue Feb 26 07:53:01 2002
+++ makefile Thu Feb 28 21:50:58 2002
@@ -4,7 +4,7 @@
PROJ=fxt
##### GCC 2.x:
-CXX = c++
+#CXX = c++
PPLIBS = -lm -lstdc++
RUNBIN=$(TESTBIN)
@@ -29,7 +29,7 @@
# -mcpu= Schedule code for given CPU
# -march implies -mcpu
-OFLAGS = -O2 -ffast-math
+OFLAGS += -ffast-math
OFLAGS += $(ARCHFLAG)
OFLAGS += -fomit-frame-pointer
OFLAGS += -fno-exceptions
@@ -60,12 +60,12 @@
-Imod -Iwavelet -Isort
#### choose the FLAG combo here:
-CXXFLAGS = -pipe -fno-exceptions
-CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
+#CXXFLAGS = -pipe -fno-exceptions
+#CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
#CXXFLAGS += $(PFLAGS) # uncomment for PROFILING
#CXXFLAGS += $(GFLAGS) # uncomment for DEBUGGING
#CXXFLAGS += -D__NO_MATH_INLINES
-CXXFLAGS += $(WFLAGS) # uncomment for WARNINGS
+#CXXFLAGS += $(WFLAGS) # uncomment for WARNINGS
#-------------------------------------
@@ -378,16 +378,16 @@
# @echo ' ===== make FXT lib DONE. ====='
-PREFIX=/usr/
-LIBDIR=$(PREFIX)/lib/fxt
+#PREFIX=/usr/
+LIBDIR=$(PREFIX)/lib
INCDIR=$(PREFIX)/include/fxt
.PHONY: install ## install to $(PREFIX)/{lib,include}/fxt/
install: lib
@echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR)'
@test -d $(LIBDIR) || mkdir $(LIBDIR)
- cp -auv $(FXTLIB) $(LIBDIR)/
+ ${INSTALL_PROGRAM} $(FXTLIB) $(LIBDIR)/
+ ${BSD_INSTALL_DATA} $(FXTLIB) $(LIBDIR)/
@test -d $(INCDIR) || mkdir $(INCDIR)
- @cp -auv $(FXTHDRS) $(INCDIR)/
+ @${INSTALL_DATA} $(FXTHDRS) $(INCDIR)/
+ ${BSD_INSTALL_DATA} $(FXTHDRS) $(INCDIR)/
.PHONY: uninstall ## opposite of install ;-)
uninstall:

View File

@ -1,10 +1,16 @@
include/fxt/applyfunc.h
include/fxt/arith.h
include/fxt/arith2d.h
include/fxt/array.h
include/fxt/array2d.h
include/fxt/aux2dlazy.h
include/fxt/auxbitlazy.h
include/fxt/auxdouble.h
include/fxt/auxlazy.h
include/fxt/auxprint.h
include/fxt/bit2pow.h
include/fxt/bitarray.h
include/fxt/bitasm.h
include/fxt/bitcombination.h
include/fxt/bitcount.h
include/fxt/bitcount01.h
@ -12,26 +18,30 @@ include/fxt/bithigh.h
include/fxt/bitlow.h
include/fxt/bitmisc.h
include/fxt/bitrotate.h
include/fxt/bits2pow.h
include/fxt/bitsasm.h
include/fxt/bitsequency.h
include/fxt/bitslazy.h
include/fxt/bitsperlong.h
include/fxt/bitsubset.h
include/fxt/bitswap.h
include/fxt/bitzip.h
include/fxt/branchless.h
include/fxt/cholesky.h
include/fxt/cmult.h
include/fxt/comblazy.h
include/fxt/comblex.h
include/fxt/combminchange.h
include/fxt/combnum.h
include/fxt/complextype.h
include/fxt/constants.h
include/fxt/convex.h
include/fxt/copy.h
include/fxt/copy2d.h
include/fxt/cycles.h
include/fxt/daubechies.h
include/fxt/debruijn.h
include/fxt/diff.h
include/fxt/diskaux.h
include/fxt/factor.h
include/fxt/fhtmulsqr.h
include/fxt/funcemu.h
include/fxt/fxt.h
include/fxt/fxtauxlazy.h
@ -42,33 +52,44 @@ include/fxt/fxttypes.h
include/fxt/gcd.h
include/fxt/graycode.h
include/fxt/graypermute.h
include/fxt/haarpermute.h
include/fxt/hilbert.h
include/fxt/inline.h
include/fxt/intarith.h
include/fxt/jjassert.h
include/fxt/ldn2rc.h
include/fxt/matrix.h
include/fxt/matrixsymmetryq.h
include/fxt/minmax.h
include/fxt/minmax2d.h
include/fxt/misc.h
include/fxt/misc2d.h
include/fxt/mmult.h
include/fxt/mod.h
include/fxt/modarith.h
include/fxt/modlazy.h
include/fxt/modm.h
include/fxt/moduli.h
include/fxt/monotone.h
include/fxt/mtypes.h
include/fxt/newop.h
include/fxt/ntt.h
include/fxt/paren.h
include/fxt/partition.h
include/fxt/permapply.h
include/fxt/permderange.h
include/fxt/permlazy.h
include/fxt/permlex.h
include/fxt/permminchange.h
include/fxt/permtrotter.h
include/fxt/permutation.h
include/fxt/permutelazy.h
include/fxt/permvisit.h
include/fxt/primes.h
include/fxt/primestring.h
include/fxt/printbin.h
include/fxt/quantise.h
include/fxt/radixpermute.h
include/fxt/range.h
include/fxt/restrict.h
include/fxt/revbin.h
include/fxt/revbinpermute.h
include/fxt/revbinpermute0.h
@ -80,6 +101,7 @@ include/fxt/scale.h
include/fxt/scale2d.h
include/fxt/scan.h
include/fxt/scanbox.h
include/fxt/scanfunc.h
include/fxt/search.h
include/fxt/searchidx.h
include/fxt/searchptr.h
@ -97,15 +119,26 @@ include/fxt/sortfunc.h
include/fxt/sortidx.h
include/fxt/sortlazy.h
include/fxt/sortptr.h
include/fxt/subsetdebruijn.h
include/fxt/subsetminchange.h
include/fxt/subsetordered.h
include/fxt/sumdiff.h
include/fxt/symbolify.h
include/fxt/symmetricpart.h
include/fxt/symmetry.h
include/fxt/testmatrix.h
include/fxt/testnum.h
include/fxt/tinyfactors.h
include/fxt/toeplitz.h
include/fxt/transpose.h
include/fxt/transpose2_ba.h
include/fxt/transpose_ba.h
include/fxt/unique.h
include/fxt/vector.h
include/fxt/waveletfilter.h
include/fxt/workspace.h
include/fxt/zerobyte.h
include/fxt/zip.h
include/fxt/ziprev.h
lib/fxt/libfxt.a
lib/libfxt.a
@dirrm include/fxt
@dirrm lib/fxt