Remove unneeded patches (discussed with upstream)

Internationalization setup is now in 'src/PlankMain.vala' file since 0.9.1
release
This commit is contained in:
Olivier Duchateau 2015-05-12 15:19:14 +00:00
parent 77b30916fd
commit a608b2fcfc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=386156
4 changed files with 0 additions and 56 deletions

View File

@ -1,10 +0,0 @@
--- config.h.in.orig 2015-05-02 15:04:04 UTC
+++ config.h.in
@@ -1,5 +1,7 @@
/* config.h.in. Generated from configure.ac by autoheader. */
+#undef INSTALL_PREFIX
+
/* Define the gettext package to be used */
#undef GETTEXT_PACKAGE

View File

@ -1,20 +0,0 @@
--- configure.orig 2015-05-02 15:04:03 UTC
+++ configure
@@ -797,6 +797,7 @@ PLANK_MICRO_VERSION
PLANK_MINOR_VERSION
PLANK_MAJOR_VERSION
PLANK_MAJOR_MINOR_VERSION
+INSTALL_PREFIX
LT_AGE
LT_REVISION
LT_CURRENT
@@ -2330,6 +2331,9 @@ cat >>confdefs.h <<_ACEOF
#define PACKAGE_URL "$PACKAGE_URL"
_ACEOF
+cat >>confdefs.h <<_ACEOF
+#define INSTALL_PREFIX "${prefix}"
+_ACEOF
# Let the site file select an alternate cache file if it wants to.
# Prefer an explicitly selected file to automatically selected ones.

View File

@ -1,15 +0,0 @@
--- lib/Widgets/PreferencesWindow.vala.orig 2015-04-07 07:42:22 UTC
+++ lib/Widgets/PreferencesWindow.vala
@@ -59,6 +59,12 @@ namespace Plank.Widgets
construct
{
+ GLib.Intl.setlocale (LocaleCategory.ALL, "");
+ string langpack_dir = GLib.Path.build_filename (Build.INSTALL_PREFIX, "share", "locale");
+ GLib.Intl.bindtextdomain (Build.GETTEXT_PACKAGE, langpack_dir);
+ GLib.Intl.bind_textdomain_codeset (Build.GETTEXT_PACKAGE, "UTF-8");
+ GLib.Intl.textdomain (Build.GETTEXT_PACKAGE);
+
skip_pager_hint = true;
skip_taskbar_hint = true;
title = _("Preferences");

View File

@ -1,11 +0,0 @@
--- vapi/config.vapi.orig 2015-04-27 13:44:43 UTC
+++ vapi/config.vapi
@@ -32,6 +32,8 @@ namespace Build
public const string VERSION;
public const string VERSION_INFO;
+ public const string INSTALL_PREFIX;
+
public const uint VERSION_MAJOR;
public const uint VERSION_MINOR;
public const uint VERSION_MICRO;