Update to 2015.07.09.

PR:		205198
Submitted by:	tkato432 yahoo com
Sponsored by:	Absolight
This commit is contained in:
Mathieu Arnold 2016-03-08 15:55:26 +00:00
parent e3dbe53155
commit a5fe1ac82b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=410622
9 changed files with 91 additions and 103 deletions

View File

@ -2,64 +2,50 @@
# $FreeBSD$
PORTNAME= himenobench
PORTVERSION= 2004.08.16
PORTREVISION= 6
PORTVERSION= 2015.07.09
CATEGORIES= benchmarks
MASTER_SITES= http://accc.riken.jp/secure/4502/:C http://accc.riken.jp/secure/4503/:C \
http://accc.riken.jp/secure/4504/:F90 http://accc.riken.jp/secure/4505/:F77
DISTFILES= himenoBMTxp_xl.lzh:F77 himenoBMTxp_l.lzh:F77 himenoBMTxp_m.lzh:F77 \
himenoBMTxp_s.lzh:F77 cc_himenoBMTxp_xl.lzh:C cc_himenoBMTxp_l.lzh:C \
cc_himenoBMTxp_m.lzh:C cc_himenoBMTxp_s.lzh:C f90_xp.lzh:F90 himenobmtxpa.lzh:C
MASTER_SITES= http://accc.riken.jp/wp-content/uploads/2015/07/
DISTFILES= himenobmtxp_xl.zip himenobmtxp_l.zip \
himenobmtxp_m.zip himenobmtxp_s.zip \
cc_himenobmtxp_xl.zip cc_himenobmtxp_l.zip \
cc_himenobmtxp_m.zip cc_himenobmtxp_s.zip \
f90_xp.zip himenobmtxpa.zip
DIST_SUBDIR= himeno
MAINTAINER= ports@FreeBSD.org
COMMENT= Himeno bench benchmark, solves Poisson eq. with Jacobi's method
COMMENT= Tool for measureing performance of floating point operation
BROKEN= unfetchable
LICENSE= LGPL20 # (or later)
USES= lha
EXTRACT_DEPENDS= lha:${PORTSDIR}/archivers/lha
USES= zip
NO_WRKSUBDIR= yes
.if defined(WITH_ICC)
BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
.if defined(WITH_IFC)
USES+= fortran:ifort
.else
USES+= fortran
.endif
OPTIONS_DEFINE= ICC IFC OPTIMIZED_CFLAGS
OPTIONS_SUB= yes
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O2 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
CFLAGS+= -O2 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
.endif
ICC_DESC= Intel C compiler support
ICC_BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
IFC_DESC= Intel Fortran compiler support
IFC_USES= fortran:ifort
IFC_USES_OFF= fortran
OPTIMIZED_CFLAGS_CFLAGS=${OPTFLAGS}
OPTIMIZED_CFLAGS_VARS= FFLAGS+="${OPTFLAGS}"
.if defined(WITH_ICC)
CFLAGS_ICC+= -O3 -tpp7 -axN -Vaxlib
ICC= ${LOCALBASE}/intel_cc_80/bin/icc
PLIST_SUB+= WITH_ICC=""
.else
PLIST_SUB+= WITH_ICC="@comment "
.endif
.if defined(WITH_IFC)
FFLAGS_IFC+= -O3 -tpp7 -axN -Vaxlib -ipo
CFLAGS_ICC= -O3 -tpp7 -axN -Vaxlib
IFC= ${LOCALBASE}/intel_fc_80/bin/ifort
PLIST_SUB+= WITH_IFC=""
.else
PLIST_SUB+= WITH_IFC="@comment "
.endif
FFLAGS_IFC= -O3 -tpp7 -axN -Vaxlib -ipo
OPTFLAGS= -O2 -ffast-math -finline-functions -fomit-frame-pointer \
-funroll-loops -fexpensive-optimizations
.if defined(WITH_IFC)
PLIST_SUB+= WITH_GFORTRAN="@comment "
.else
PLIST_SUB+= WITH_GFORTRAN=""
.endif
post-extract:
@${FIND} ${WRKSRC} -name "*.lzh" -type f -maxdepth 1 -exec lha \
xfpw=${WRKSRC} {} \;
do-build:
.if ! defined(WITH_IFC)
cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp himenobmtxp.f90
.endif
# cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp_xl himenobmtxp_xl.f #Too large
cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp_l himenobmtxp_l.f
cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp_m himenobmtxp_m.f
@ -70,28 +56,27 @@ do-build:
cd ${WRKSRC} ; ${CC} ${CFLAGS} -DSMALL -o himenobmtxps_s himenobmtxps.c
cd ${WRKSRC} ; ${CC} ${CFLAGS} -DSSMALL -o himenobmtxps_ss himenobmtxps.c
cd ${WRKSRC} ; ${CC} ${CFLAGS} -o himenobmtxpa himenobmtxpa.c
.if defined(WITH_IFC)
do-build-IFC-off:
cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp himenobmtxp.f90
do-build-IFC-on:
# cd ${WRKSRC} ; ${IFC} ${FFLAGS_IFC} -o himenobmtxp_xl.ifc himenobmtxp_xl.f #Too large
cd ${WRKSRC} ; ${IFC} ${FFLAGS_IFC} -o himenobmtxp_l.ifc himenobmtxp_l.f
cd ${WRKSRC} ; ${IFC} ${FFLAGS_IFC} -o himenobmtxp_m.ifc himenobmtxp_m.f
cd ${WRKSRC} ; ${IFC} ${FFLAGS_IFC} -o himenobmtxp_s.ifc himenobmtxp_s.f
cd ${WRKSRC} ; ${IFC} ${FFLAGS_IFC} -o himenobmtxp.ifc himenobmtxp.f90
.endif
.if defined(WITH_ICC)
do-build-ICC-on:
# cd ${WRKSRC} ; ${ICC} ${CFLAGS_ICC} -DELARGE -o himenobmtxps_xl.icc himenobmtxps.c #Too large
cd ${WRKSRC} ; ${ICC} ${CFLAGS_ICC} -DLARGE -o himenobmtxps_l.icc himenobmtxps.c
cd ${WRKSRC} ; ${ICC} ${CFLAGS_ICC} -DMIDDLE -o himenobmtxps_m.icc himenobmtxps.c
cd ${WRKSRC} ; ${ICC} ${CFLAGS_ICC} -DSMALL -o himenobmtxps_s.icc himenobmtxps.c
cd ${WRKSRC} ; ${ICC} ${CFLAGS_ICC} -DSSMALL -o himenobmtxps_ss.icc himenobmtxps.c
cd ${WRKSRC} ; ${ICC} ${CFLAGS_ICC} -o himenobmtxpa.icc himenobmtxpa.c
.endif
do-install:
# ${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_xl ${STAGEDIR}${PREFIX}/bin #Too large
.if ! defined(WITH_IFC)
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp ${STAGEDIR}${PREFIX}/bin
.endif
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_l ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_m ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_s ${STAGEDIR}${PREFIX}/bin
@ -100,20 +85,23 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_m ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_s ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_ss ${STAGEDIR}${PREFIX}/bin
.if defined(WITH_IFC)
do-install-IFC-off:
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp ${STAGEDIR}${PREFIX}/bin
do-install-IFC-on:
# ${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_xl.ifc ${STAGEDIR}${PREFIX}/bin #Too large
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_l.ifc ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_m.ifc ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_s.ifc ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp.ifc ${STAGEDIR}${PREFIX}/bin
.endif
.if defined(WITH_ICC)
do-install-ICC-on:
# ${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_xl.icc ${STAGEDIR}${PREFIX}/bin #Too large
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_l.icc ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_m.icc ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_s.icc ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxps_ss.icc ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxpa.icc ${STAGEDIR}${PREFIX}/bin
.endif
.include <bsd.port.mk>

View File

@ -1,20 +1,20 @@
SHA256 (himeno/himenoBMTxp_xl.lzh) = e9af4c00bfa071fc7837ebed15023947e47f8141a2abb7e5e176cf70a252d223
SIZE (himeno/himenoBMTxp_xl.lzh) = 2177
SHA256 (himeno/himenoBMTxp_l.lzh) = 514acb0513dac0bf6d09d434f35dbde259b192330bb4071bed3ffa86c974a824
SIZE (himeno/himenoBMTxp_l.lzh) = 2165
SHA256 (himeno/himenoBMTxp_m.lzh) = b6497cc47609b0d36b77ae72490fc68da25888dc0d0270a59011c433d0591f51
SIZE (himeno/himenoBMTxp_m.lzh) = 2165
SHA256 (himeno/himenoBMTxp_s.lzh) = 3d07917e4e432c00083412def05e607b041c9a675484d8d5191f3aa0c4d5165a
SIZE (himeno/himenoBMTxp_s.lzh) = 2165
SHA256 (himeno/cc_himenoBMTxp_xl.lzh) = 1752e0cd80e3d9d46778b5450256fab8db8970151d6fbd0eac41f9e578bce157
SIZE (himeno/cc_himenoBMTxp_xl.lzh) = 2553
SHA256 (himeno/cc_himenoBMTxp_l.lzh) = 68847e6c54f9665793b8a89c25b7684e480f259fe2db2b01183dc7d90303afd2
SIZE (himeno/cc_himenoBMTxp_l.lzh) = 2555
SHA256 (himeno/cc_himenoBMTxp_m.lzh) = 4dd207dd4bff79b5d0df8385bdb80e6462270fe7a39d7a91d93f4f50ec099d2d
SIZE (himeno/cc_himenoBMTxp_m.lzh) = 2555
SHA256 (himeno/cc_himenoBMTxp_s.lzh) = 6a10ef802e3d9b2dbc4a8561af0961d0bf7540fcabf6060b72a79fa93c61ecfd
SIZE (himeno/cc_himenoBMTxp_s.lzh) = 2554
SHA256 (himeno/f90_xp.lzh) = 68a79474958338e388f0e258ccb67a1dbf2abf76ee33c50125ccef8da4adfed4
SIZE (himeno/f90_xp.lzh) = 2631
SHA256 (himeno/himenobmtxpa.lzh) = 0a2964e3ea5f2b2b70d3fe6390faf31951b27b2b3f3e1e7667454caff231e673
SIZE (himeno/himenobmtxpa.lzh) = 3006
SHA256 (himeno/himenobmtxp_xl.zip) = d40a3eb9e101d3cd39a1ea1d1d19b757b0cb98ab260d281b4366c9ca47e8f9fe
SIZE (himeno/himenobmtxp_xl.zip) = 2347
SHA256 (himeno/himenobmtxp_l.zip) = 3083269ed7b0744278904d57f0059ad1cd6d2c07c2afe5622402a6d45e354fd3
SIZE (himeno/himenobmtxp_l.zip) = 2333
SHA256 (himeno/himenobmtxp_m.zip) = 049dc710a1bf0b6d752e5d366c97738fb4644bc9782cc5b00448ee222ffc4bfd
SIZE (himeno/himenobmtxp_m.zip) = 2333
SHA256 (himeno/himenobmtxp_s.zip) = d0c754282406698d772f65cf188e702895e28ab4382473d85c8c6736e2a993eb
SIZE (himeno/himenobmtxp_s.zip) = 2333
SHA256 (himeno/cc_himenobmtxp_xl.zip) = c4415418a481091da82a7bd2d454ea887885955ee0e621d7a4f35024a3024cf6
SIZE (himeno/cc_himenobmtxp_xl.zip) = 2729
SHA256 (himeno/cc_himenobmtxp_l.zip) = 44d57f0f76ff039b4afb53175fa4634cf2057ce662f3e16963d0936a1127d364
SIZE (himeno/cc_himenobmtxp_l.zip) = 2729
SHA256 (himeno/cc_himenobmtxp_m.zip) = ee9b365b13bf26cf3cc02f7155bab46f873a0f2a2085c75a80434807be29b5c9
SIZE (himeno/cc_himenobmtxp_m.zip) = 2729
SHA256 (himeno/cc_himenobmtxp_s.zip) = e1e1c615fab54a54b5ee7657bef075d7957b25d81ac94bc663253aacdefe36f6
SIZE (himeno/cc_himenobmtxp_s.zip) = 2728
SHA256 (himeno/f90_xp.zip) = 821e2deef31045f0b33b848af0a4c2ace599a498c35d44def576ce7bacfbe3d2
SIZE (himeno/f90_xp.zip) = 2785
SHA256 (himeno/himenobmtxpa.zip) = 84661f06eb863650b0397d6f67af4b7fc1828cc68eb3bed113b15d913bf962cc
SIZE (himeno/himenobmtxpa.zip) = 3172

View File

@ -1,6 +1,6 @@
--- himenobmtxp_l.f.orig Mon Aug 16 15:39:44 2004
+++ himenobmtxp_l.f Mon Aug 16 15:39:54 2004
@@ -39,7 +39,6 @@
--- himenobmtxp_l.f.orig 2002-01-07 04:54:46 UTC
+++ himenobmtxp_l.f
@@ -39,7 +39,6 @@ C -------------------
C "use portlib" statement on the next line is for Visual fortran
C to use UNIX libraries. Please remove it if your system is UNIX.
C -------------------

View File

@ -1,10 +1,10 @@
--- himenobmtxp_m.f.orig Mon Aug 16 15:39:44 2004
+++ himenobmtxp_m.f Mon Aug 16 15:39:54 2004
@@ -39,7 +39,6 @@
--- himenobmtxp_m.f.orig 2002-01-07 04:54:48 UTC
+++ himenobmtxp_m.f
@@ -39,7 +39,6 @@ C -------------------
C "use portlib" statement on the next line is for Visual fortran
C to use UNIX libraries. Please remove it if your system is UNIX.
C -------------------
- use portlib
IMPLICIT REAL*4(a-h,o-z)
C
PARAMETER (mimax=513,mjmax=257,mkmax=257)
C PARAMETER (mimax=513,mjmax=257,mkmax=257)

View File

@ -1,10 +1,10 @@
--- himenobmtxp_s.f.orig Mon Aug 16 15:39:44 2004
+++ himenobmtxp_s.f Mon Aug 16 15:39:54 2004
@@ -39,7 +39,6 @@
--- himenobmtxp_s.f.orig 2001-12-17 07:45:16 UTC
+++ himenobmtxp_s.f
@@ -39,7 +39,6 @@ C -------------------
C "use portlib" statement on the next line is for Visual fortran
C to use UNIX libraries. Please remove it if your system is UNIX.
C -------------------
- use portlib
IMPLICIT REAL*4(a-h,o-z)
C
PARAMETER (mimax=513,mjmax=257,mkmax=257)
C PARAMETER (mimax=513,mjmax=257,mkmax=257)

View File

@ -1,10 +1,10 @@
--- himenobmtxp_xl.f.orig Mon Aug 16 15:39:44 2004
+++ himenobmtxp_xl.f Mon Aug 16 15:39:54 2004
@@ -39,7 +39,6 @@
--- himenobmtxp_xl.f.orig 2002-01-07 04:54:42 UTC
+++ himenobmtxp_xl.f
@@ -39,7 +39,6 @@ C -------------------
C "use portlib" statement on the next line is for Visual fortran
C to use UNIX libraries. Please remove it if your system is UNIX.
C -------------------
- use portlib
IMPLICIT REAL*4(a-h,o-z)
C
PARAMETER (mimax=513,mjmax=257,mkmax=257)
PARAMETER (mimax=1025,mjmax=513,mkmax=513)

View File

@ -1,5 +1,5 @@
--- himenobmtxps.c~ Thu Feb 21 09:27:59 2002
+++ himenobmtxps.c Mon Aug 16 16:13:42 2004
--- himenobmtxps.c.orig 2002-02-21 00:27:48 UTC
+++ himenobmtxps.c
@@ -37,6 +37,7 @@
********************************************************************/
@ -8,7 +8,7 @@
#ifdef SSMALL
#define MIMAX 33
@@ -245,7 +246,6 @@
@@ -245,7 +246,6 @@ mflops(int nn,double cpu,double flop)
double
second()
{

View File

@ -1,6 +1,6 @@
Himeno Benchmark is made by HIMENO, Ryutaro,
for evaluation of performance of the calculation
of incompressible flow analysis. This program solves Poisson equation
by Jacobi's iterative method which have many loops
by Jacobi's iterative method which have many loops.
WWW: http://accc.riken.jp/HPC/HimenoBMT.html
WWW: http://accc.riken.jp/en/supercom/himenobmt/

View File

@ -1,4 +1,4 @@
%%WITH_GFORTRAN%%bin/himenobmtxp
%%NO_IFC%%bin/himenobmtxp
bin/himenobmtxp_l
bin/himenobmtxp_m
bin/himenobmtxp_s
@ -7,12 +7,12 @@ bin/himenobmtxps_l
bin/himenobmtxps_m
bin/himenobmtxps_s
bin/himenobmtxps_ss
%%WITH_ICC%%bin/himenobmtxpa.icc
%%WITH_ICC%%bin/himenobmtxps_l.icc
%%WITH_ICC%%bin/himenobmtxps_m.icc
%%WITH_ICC%%bin/himenobmtxps_s.icc
%%WITH_ICC%%bin/himenobmtxps_ss.icc
%%WITH_IFC%%bin/himenobmtxp.ifc
%%WITH_IFC%%bin/himenobmtxp_l.ifc
%%WITH_IFC%%bin/himenobmtxp_m.ifc
%%WITH_IFC%%bin/himenobmtxp_s.ifc
%%ICC%%bin/himenobmtxpa.icc
%%ICC%%bin/himenobmtxps_l.icc
%%ICC%%bin/himenobmtxps_m.icc
%%ICC%%bin/himenobmtxps_s.icc
%%ICC%%bin/himenobmtxps_ss.icc
%%IFC%%bin/himenobmtxp.ifc
%%IFC%%bin/himenobmtxp_l.ifc
%%IFC%%bin/himenobmtxp_m.ifc
%%IFC%%bin/himenobmtxp_s.ifc