Remove psyco support

This commit is contained in:
Baptiste Daroussin 2013-10-15 12:56:39 +00:00
parent 048bfa50ce
commit a5d101735a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=330398
6 changed files with 4 additions and 60 deletions

View File

@ -33,14 +33,6 @@ FOF_DIR= ${PREFIX}/lib/${PORTNAME}
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
WITHOUT_PSYCO= yes
.endif
.if !defined(WITHOUT_PSYCO)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
do-install:
${MKDIR} ${FOF_DIR}/${PORTNAME:S/f/F/g:S/o/O/}
@cd ${WRKSRC}/src && \

View File

@ -19,15 +19,9 @@ USE_TWISTED= yes
USES= gettext
NO_BUILD= yes
OPTIONS_DEFINE= PSYCO
PSYCO_DESC= Use just-in-time Python compiler
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPSYCO}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
.include <bsd.port.options.mk>
post-configure:
@${REINPLACE_CMD} -e 's@%%DATADIR%%@${DATADIR}@g' ${WRKSRC}/GalaxyMage.py ${WRKSRC}/src/Resources.py

View File

@ -17,13 +17,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=3-2.5.1_1:${PORTSDIR}/databases/py-
INSTALLS_ICONS= yes
OPTIONS_DEFINE= PYGSTREAMER CRAFTY GNUCHESS PHALANX SJENG STRONGPLAYER STOCKFISH
OPTIONS_DEFINE= PYGSTREAMER CRAFTY GNUCHESS PHALANX SJENG STOCKFISH
PYGSTREAMER_DESC= Install gst-python for audio support
CRAFTY_DESC= Install crafty (chess engine)
GNUCHESS_DESC= Install gnuchess (chess engine)
PHALANX_DESC= Install phalanx (chess engine)
SJENG_DESC= Install sjeng (chess engine)
STRONGPLAYER_DESC= Install psyco/gmpy (strong player)
STOCKFISH_DESC= Install stockfish (chess engine)
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
@ -70,11 +69,6 @@ RUN_DEPENDS+= phalanx:${PORTSDIR}/games/phalanx
RUN_DEPENDS+= sjeng:${PORTSDIR}/games/sjeng
.endif
.if ${PORT_OPTIONS:MSTRONGPLAYER}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psyco>=1.6:${PORTSDIR}/devel/py-psyco
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gmpy>=1.13:${PORTSDIR}/math/py-gmpy
.endif
.if ${PORT_OPTIONS:MSTOCKFISH}
RUN_DEPENDS+= stockfish:${PORTSDIR}/games/stockfish
.endif

View File

@ -15,19 +15,8 @@ INSTALL_TARGET= install-wrapper
MAN1= cfv.1
OPTIONS_DEFINE_i386= PSYCO
PSYCO_DESC= Enable devel/py-psyco optimization support
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPSYCO}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
EXTRA_PATCHES+= ${FILESDIR}/extra-psyco-patch-Makefile
.endif
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- Makefile.orig 2009-03-05 21:47:26.000000000 -0300
+++ Makefile 2009-03-05 21:51:11.000000000 -0300
@@ -37,7 +37,7 @@
#this will create a wrapper script that calls python directly (if we can find it), or using the bin/env trick.
#we don't need to check for PYTHON being set to something, since os.path.join handles the case of the component being an absolute path
cfv.wrapper:
- $(PYTHON) -c 'import string,os; py=filter(lambda x: os.path.isfile(x),map(lambda x: os.path.join(x,"$(PYTHON)"),string.split(os.environ["PATH"],":"))); py.append(" /usr/bin/env $(PYTHON)"); open("cfv.wrapper","w").write("#!%s\nimport cfv\ncfv.main()\n"%py[0])'
+ $(PYTHON) -c 'import string,os; py=filter(lambda x: os.path.isfile(x),map(lambda x: os.path.join(x,"$(PYTHON)"),string.split(os.environ["PATH"],":"))); py.append(" /usr/bin/env $(PYTHON)"); open("cfv.wrapper","w").write("#!%s\ntry:\n import psyco\n import re\n psyco.cannotcompile(re.compile)\n psyco.profile()\nexcept ImportError:\n pass\nimport cfv\ncfv.main()\n"%py[0])'
$(DESTDIR)$(mandir)/man1 $(DESTDIR)$(bindir):
$(install_dir) $@

View File

@ -3,7 +3,7 @@
PORTNAME= umit
PORTVERSION= 1.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -21,22 +21,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" || ${PYTHON_REL} > 260
WITHOUT_PSYCO= yes
.endif
.ifndef(WITHOUT_PSYCO)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
pre-everything::
.ifndef(WITHOUT_PSYCO)
@${ECHO_MSG} '===> Define WITHOUT_PSYCO to disable devel/py-psyco optimization'
.endif
post-patch:
${REINPLACE_CMD} 's/self.build_html_doc()//' ${WRKSRC}/setup.py
.include <bsd.port.post.mk>
.include <bsd.port.mk>