- Add stage support

- USE_GMAKE -> USES=gmake
This commit is contained in:
Rene Ladan 2013-10-01 20:58:48 +00:00
parent f38aad6356
commit a5b6e13d4a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=328995
2 changed files with 13 additions and 3 deletions

View File

@ -10,16 +10,15 @@ MASTER_SITES= http://plib.sourceforge.net/dist/
MAINTAINER= ports@FreeBSD.org
COMMENT= A portable library for joystick/sound/OpenGL GUI/3D math
USES= gmake
USE_XORG= xt xi xmu xext x11
USE_GL= glu
USE_GMAKE= yes
GNU_CONFIGURE= yes
CXXFLAGS+= -fPIC
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
NO_STAGE= yes
.include <bsd.port.pre.mk>
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-js-jsBSD.cxx
@ -36,6 +35,6 @@ post-build:
${CC} ${CFLAGS} -o ${WRKDIR}/plib-jscal ${FILESDIR}/jsBSDCal.c
post-install:
${INSTALL_PROGRAM} ${WRKDIR}/plib-jscal ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKDIR}/plib-jscal ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.post.mk>

View File

@ -0,0 +1,11 @@
--- ./src/util/Makefile.in.orig 2008-03-11 03:10:28.000000000 +0100
+++ ./src/util/Makefile.in 2013-09-29 19:26:01.000000000 +0200
@@ -249,7 +249,7 @@
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
install-libLIBRARIES: $(lib_LIBRARIES)
@$(NORMAL_INSTALL)
- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
+ test -z "$(DESTDIR)$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
@list='$(lib_LIBRARIES)'; for p in $$list; do \
if test -f $$p; then \
f=$(am__strip_dir) \