Fix packaging on broken ExtUtils::MakeMaker

This commit is contained in:
Sergey Skvortsov 2004-12-29 17:20:00 +00:00
parent b907e141c0
commit a57f22e3ab
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=125447
2 changed files with 19 additions and 1 deletions

View File

@ -34,4 +34,10 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
EXTRA_PATCHES= ${PATCHDIR}/500503-Makefile.PL
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,12 @@
--- Makefile.PL.orig Wed Dec 29 20:16:15 2004
+++ Makefile.PL Wed Dec 29 20:18:39 2004
@@ -49,3 +49,9 @@
install_site_config:
$(PERL) -I$(PERL_ARCHLIB) -I$(PERL_LIB) -I$(INST_LIB) -I$(INSTALLSITELIB) -MXML::SAX::Machines::ConfigHelper -we 'XML::SAX::Machines::ConfigHelper::_write_site_config_if_absent(shift)' $(INSTALLSITELIB)
POSTAMBLE_END
+
+sub MY::manifypods {
+ package MY; my $self=shift;
+ $self->{MAN3PODS}->{'lib/XML/SAX/Machines/ConfigHelper.pm'}='$(INST_MAN3DIR)/XML::SAX::Machines::ConfigHelper.$(MAN3EXT)';
+ $self->SUPER::manifypods(@_);
+}