- fix and undeprecate

- add license (GPLv2)
- update MASTER_SITES and CONFLICTS
- tidy up pkg-descr
- pass maintainership to submitter

PR:		197495
Submitted by:	Chris Hutchinson
MFH:		2015Q3
This commit is contained in:
Rene Ladan 2015-07-22 05:27:59 +00:00
parent 688ec36bf9
commit a57213f3df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=392664
9 changed files with 45 additions and 49 deletions

1
GIDs
View File

@ -94,6 +94,7 @@ trircd:*:154:
xorp:*:155:
monetdb:*:156:
barman:*:157:
nocat:*:159:
sfs:*:171:
agk:*:172:
polipo:*:173:

1
UIDs
View File

@ -101,6 +101,7 @@ rbldns:*:153:153::0:0:rbldnsd pseudo-user:/nonexistent:/usr/sbin/nologin
trircd:*:154:154::0:0:& user:/usr/local/etc/tr-ircd:/usr/sbin/nologin
monetdb:*:156:156::0:0:MonetDB user:/usr/local/monetdb5:/bin/sh
barman:*:157:157::0:0:Barman user:/var/barman:/bin/sh
nocat:*:159:159::0:0:NoCat Daemon:/libexec/nocat:/sbin/nologin
sfs:*:171:171::0:0:Self-Certifying File System:/nonexistent:/usr/sbin/nologin
agk:*:172:172::0:0:AquaGateKeeper:/nonexistent:/nonexistent
polipo:*:173:173::0:0:polipo web cache:/nonexistent:/usr/sbin/nologin

View File

@ -6,19 +6,17 @@ PORTVERSION= 0.82
PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://farrokhi.net/distfiles/ \
http://nocat.net/download/NoCatSplash/
http://BSDforge.com/projects/source/net/nocatsplash/
DISTNAME= NoCatSplash-nightly
MAINTAINER= ports@FreeBSD.org
MAINTAINER= portmaster@BSDforge.com
COMMENT= Open 802.11 Splash Screen
BROKEN= Broken pkg-install script, should use USERS and UIDs
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2015-07-21
LICENSE= GPLv2
USE_GNOME= glib12
CONFLICTS= nocatauth-server-*
CONFLICTS= nocatauth-server-[0-9]*
GNU_CONFIGURE= yes
USES= gmake tar:tgz
@ -34,4 +32,7 @@ CONFIGURE_ARGS+= --with-mode=${AUTHMODE}
CONFIGURE_ARGS+= --with-docroot=${DOCROOT}
.endif
USERS= nocat
GROUPS= nocat
.include <bsd.port.mk>

View File

@ -0,0 +1,28 @@
--- mkinstalldirs.orig 2003-01-02 10:39:12 UTC
+++ mkinstalldirs
@@ -7,25 +7,6 @@
errstatus=0
dirmode=""
-usage="\
-Usage: mkinstalldirs [-h] [--help] [-m mode] dir ..."
-
-# process command line arguments
-while test $# -gt 0 ; do
- case "${1}" in
- -h | --help | --h* ) # -h for help
- echo "${usage}" 1>&2; exit 0 ;;
- -m ) # -m PERM arg
- shift
- test $# -eq 0 && { echo "${usage}" 1>&2; exit 1; }
- dirmode="${1}"
- shift ;;
- -- ) shift; break ;; # stop option processing
- -* ) echo "${usage}" 1>&2; exit 1 ;; # unknown option
- * ) break ;; # first non-opt arg
- esac
-done
-
for file
do
if test -d "$file"; then

View File

@ -1,5 +1,5 @@
--- src/http.c.orig Wed Nov 19 16:26:07 2003
+++ src/http.c Wed Nov 19 16:29:22 2003
--- src/http.c.orig 2003-01-16 19:52:17 UTC
+++ src/http.c
@@ -1,8 +1,10 @@
-# include <glib.h>
-# include <fcntl.h>
@ -24,7 +24,7 @@
GIOChannel *http_bind_socket( const char *ip, int port, int queue ) {
struct sockaddr_in addr;
int fd, r, n = 1;
@@ -354,7 +353,7 @@
@@ -354,7 +353,7 @@ ssize_t http_sendfile ( http_request *h,
return -1;
}

View File

@ -1,5 +1,5 @@
--- src/splashd.c.orig Wed Nov 19 16:29:47 2003
+++ src/splashd.c Wed Nov 19 16:30:28 2003
--- src/splashd.c.orig 2003-02-23 03:09:46 UTC
+++ src/splashd.c
@@ -1,7 +1,10 @@
+# include <sys/param.h>
+# include <sys/types.h>

View File

@ -1,5 +1,5 @@
NoCatSplash is a Open Public Network Gateway Daemon. It performs as a
[captive/open/active] portal. When run on a gateway/router on a network,
NoCatSplash is a Open Public Network Gateway Daemon. It performs as a
[captive/open/active] portal. When run on a gateway/router on a network,
all web requests are redirected until the client either logs in or clicks
"I Accept" to an AUP. The gateway daemon then changes the firewall rules
on the gateway to pass traffic for that client (based on IP address and

View File

@ -1,36 +0,0 @@
#!/bin/sh
PATH=/bin:/usr/sbin
if [ -z "${WRAP_USER}" ]; then
WRAP_USER=nocat
fi
case $2 in
PRE-INSTALL)
UID=181
GID=${UID}
if [ ! -d "${NOCAT_DIR}" ]; then
mkdir -p ${NOCAT_DIR}
fi
if pw user show "${WRAP_USER}" 2>/dev/null; then
echo "You already have a user \"${WRAP_USER}\", so I will use it."
if pw usermod ${WRAP_USER} -d ${NOCAT_DIR}
then
echo "Changed home directory of \"${WRAP_USER}\" to \"${NOCAT_DIR}\""
else
"${NOCAT_DIR}\" failed..."
exit 1
fi
else
if pw useradd ${WRAP_USER} -u ${UID} \
-d ${NOCAT_DIR} -s /sbin/nologin -c "NoCat Daemon"
then
echo "Added user \"${WRAP_USER}\"."
else
echo "Adding user \"${WRAP_USER}\" failed..."
exit 1
fi
fi
;;
esac

View File

@ -12,3 +12,4 @@ share/nocat/htdocs/images/auth_logo.gif
sbin/splashd
sbin/ghttpd
etc/nocat.conf
@dir libexec/nocat