Add gedit-autocomplete-plugin.

A simple autocomplete plugin for gedit.

This plugin autocompletes words when you write words twice or more times
in a document.

WWW: http://usuarios.lycos.es/acisif/gedit/autocomplete/autocomplete.html

PR:		ports/87549
Submitted by:	Andreas Kohn <andreas@syndrom23.de>
This commit is contained in:
Jean-Yves Lefort 2005-10-17 06:40:55 +00:00
parent 76b761f182
commit a53c34fba9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145620
5 changed files with 52 additions and 0 deletions

View File

@ -64,6 +64,7 @@
SUBDIR += fte
SUBDIR += gate
SUBDIR += gedit
SUBDIR += gedit-autocomplete-plugin
SUBDIR += gedit-plugins
SUBDIR += ghex
SUBDIR += glimmer

View File

@ -0,0 +1,29 @@
# Ports collection makefile for: gedit-autocomplete-plugin
# Date created: 2005-10-10
# Whom: Andreas Kohn <andreas@syndrom23.de>
#
# $FreeBSD$
#
PORTNAME= autocomplete-plugin
PORTVERSION= 3.0
CATEGORIES= editors
MASTER_SITES= http://usuarios.lycos.es/acisif/gedit/autocomplete/
PKGNAMEPREFIX= gedit-
MAINTAINER= andreas@syndrom23.de
COMMENT= A simple autocompletion plugin for gedit
BUILD_DEPENDS= gedit:${PORTSDIR}/editors/gedit
RUN_DEPENDS= gedit:${PORTSDIR}/editors/gedit
GEDIT_VERSION= 2.10
USE_X_PREFIX= yes
MAKEFILE= makefile
MAKE_ARGS= GEDIT_VERSION=gedit-${GEDIT_VERSION}
PLIST_FILES= lib/gedit-2/plugins/autocomplete.gedit-plugin \
lib/gedit-2/plugins/libautocomplete.so
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (autocomplete-plugin-3.0.tar.gz) = 34e71a3caad1fa29fcaa0a4442406c9a
SIZE (autocomplete-plugin-3.0.tar.gz) = 6187

View File

@ -0,0 +1,14 @@
--- makefile.orig Sun Sep 12 16:11:44 2004
+++ makefile Mon Oct 17 08:06:34 2005
@@ -2,8 +2,8 @@
GEDIT_VERSION=gedit-2.4
all:
- gcc -march=i686 -O3 -s -Wall -fPIC -shared `pkg-config $(GEDIT_VERSION) --libs --cflags` *.c -o libautocomplete.so
+ $(CC) $(CFLAGS) -Wall -fPIC -shared `pkg-config $(GEDIT_VERSION) --libs --cflags` *.c -o libautocomplete.so
install:
- cp libautocomplete.so /usr/lib/gedit-2/plugins/
- cp autocomplete.gedit-plugin /usr/lib/gedit-2/plugins/
+ $(BSD_INSTALL_PROGRAM) libautocomplete.so $(PREFIX)/lib/gedit-2/plugins/
+ $(BSD_INSTALL_DATA) autocomplete.gedit-plugin $(PREFIX)/lib/gedit-2/plugins/

View File

@ -0,0 +1,6 @@
A simple autocomplete plugin for gedit.
This plugin autocompletes words when you write words twice or more times
in a document.
WWW: http://usuarios.lycos.es/acisif/gedit/autocomplete/autocomplete.html