add bg5pdf

Convert Chinese-Big5 encoded files to PDF, using PDFlib

PR:		32473
Submitted by:	Statue <statue@softwareliberty.org>
This commit is contained in:
Ying-Chieh Liao 2001-12-08 09:22:00 +00:00
parent 10011e2645
commit a4fa05b852
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51210
8 changed files with 60 additions and 0 deletions

View File

@ -11,6 +11,7 @@
SUBDIR += aterm
SUBDIR += auto-tw-l10n
SUBDIR += autoconvert
SUBDIR += bg5pdf
SUBDIR += bg5ps
SUBDIR += big5con
SUBDIR += big5fs

29
chinese/bg5pdf/Makefile Normal file
View File

@ -0,0 +1,29 @@
# New ports collection makefile for: bg5pdf
# Date created: 17 June 1998
# Whom: Shen Chuan-Hsing
#
# $FreeBSD$
#
PORTNAME= bg5pdf
PORTVERSION= 1.0.0
CATEGORIES= chinese print
MASTER_SITES= http://students.washington.edu/cschin/bg5ps/bg5pdf/ \
http://freebsd.sinica.edu.tw/~statue/
MAINTAINER= statue@freebsd.sinica.edu.tw
LIB_DEPENDS= pdf.3:${PORTSDIR}/print/pdflib3
USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/bg5pdf ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bg5pdflib.so ${PREFIX}/lib/python2.1/site-packages
${INSTALL_DATA} ${WRKSRC}/test.big5 ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/test.big5.pdf ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/genTest.py ${EXAMPLESDIR}
.include <bsd.port.mk>

1
chinese/bg5pdf/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (bg5pdf-1.0.0.tar.gz) = 4f3cf41bbe90ae1cd06912921fae6234

View File

@ -0,0 +1,8 @@
--- bg5pdf.orig Mon Dec 3 06:53:10 2001
+++ bg5pdf Mon Dec 3 06:53:19 2001
@@ -1,4 +1,4 @@
-#!/usr/bin/env /usr/bin/python
+#!/usr/bin/env /usr/local/bin/python
"""
Bg5pdf is a simple wrapper for wrapping big5 encoding text file into

View File

@ -0,0 +1,5 @@
--- Makefile.orig Mon Dec 3 07:46:28 2001
+++ Makefile Mon Dec 3 07:46:51 2001
@@ -0,0 +1,2 @@
+all:
+ gcc -shared bg5pdflib.c -I/usr/local/include -I /usr/local/include/python2.1 -L/usr/local/lib -lpdf -o bg5pdflib.so

View File

@ -0,0 +1 @@
Convert Chinese-Big5 encoded files to PDF, using PDFlib

9
chinese/bg5pdf/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
Bg5pdf is a simple wrapper for wrapping big5 encoding text file into
PDF file by using PDFlib. The output of this program does not contain
embedding fonts. You have to download Acrobat Acroread Asianfont pack
to view and print the output file. This wrapper does not provide any
formatting function except simple line wrapping. If you need
sophisticated formatting, you should try CJK-LaTex or other equivalent
tools.
WWW: http://students.washington.edu/cschin/

6
chinese/bg5pdf/pkg-plist Normal file
View File

@ -0,0 +1,6 @@
bin/bg5pdf
lib/%%PYTHON_VERSION%%/site-packages/bg5pdflib.so
share/examples/bg5pdf/test.big5
share/examples/bg5pdf/test.big5.pdf
share/examples/bg5pdf/genTest.py
@dirrm share/examples/bg5pdf