Update to version 3.96k2.

PR:		6024
Submitted by:	maintainer
This commit is contained in:
Steve Price 1998-03-16 07:51:27 +00:00
parent 2e5eee8514
commit a4b152bafb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10184
14 changed files with 240 additions and 31 deletions

View File

@ -1,42 +1,40 @@
# New ports collection makefile for: pine-3.96k
# New ports collection makefile for: pine-ko
#
# Version required: 3.96k
# Date created: 2 Apr 1997
# Whom: Choi Jun Ho <junker@jazz.snu.ac.kr>
# Version required: 3.96k2
# Date created: 15 Mar 1998
# Whom: CHOI Junho <junker@jazz.snu.ac.kr>
#
# $Id: Makefile,v 1.3 1997/05/18 07:06:41 asami Exp $
# $Id$
#
DISTNAME= pine3.96
PKGNAME= ko-pine-3.96k
CATEGORIES= korean mail
PKGNAME= ko-pine-3.96k.2
CATEGORIES= korean mail news
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
ftp://ftp.kaist.ac.kr/pub/hangul/mail/Others/ \
ftp://sunsite.kren.nm.kr/pub/packages/hangul/mail/Others/
DISTFILES= pine3.96.tar.gz pine395k.patch.tar.gz
ftp://ftp.kaist.ac.kr/pub/hangul/incoming/ \
ftp://ftp.kreonet.re.kr/pub/hangul/cair-archive/incoming/
DISTFILES= pine3.96.tar.gz pine396k2.tar.gz
MAINTAINER= junker@jazz.snu.ac.kr
EXTRACT_ONLY= pine3.96.tar.gz
MAN1= pine.1 pico.1 pilot.1
post-patch:
@cd ${WRKSRC}; \
tar zxf ${DISTDIR}/pine395k.patch.tar.gz; \
(cd pine395k; \
patch < ${FILESDIR}/pine395k.to.396k.patch); \
patch -s -p0 < pine395k/pine395k.patch
@cd ${WRKSRC} && \
${PATCH} -s -p1 < ${WRKDIR}/pine396k2/pine396k2.patch
@cd ${WRKDIR} && \
${PATCH} -s < ${FILESDIR}/dot.pinerc.ko.sample.patch
post-install:
install -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 \
${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 \
${PREFIX}/share/doc/pine
cd ${WRKSRC} && \
${INSTALL_DATA} doc/tech-notes.txt ${PREFIX}/share/doc/pine
cd ${WRKSRC} && \
${INSTALL_DATA} pine395k/README \
${INSTALL_DATA} ${WRKDIR}/pine396k2/README \
${PREFIX}/share/doc/pine/README.patch.ko
cd ${WRKSRC} && \
${INSTALL_DATA} pine395k/README.pine \
${INSTALL_DATA} ${WRKDIR}/pine396k2/pine.doc \
${PREFIX}/share/doc/pine/README.pine.ko
${INSTALL_DATA} ${WRKDIR}/pine396k2/pinerc.sample \
${PREFIX}/etc/dot.pinerc.ko.sample
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (pine3.96.tar.gz) = bf32b0bf1296ff2151e1bc7f546d43ab
MD5 (pine395k.patch.tar.gz) = 11b054b364b98034dd2aca6d44ae995c
MD5 (pine396k2.tar.gz) = 14dc4ffeaf2b09bb856589ba7b1cb2d3

View File

@ -0,0 +1,32 @@
diff -uNr ../../pine.old/work/pine396k2/pinerc.sample pine396k2/pinerc.sample
--- ../../pine.old/work/pine396k2/pinerc.sample Thu Jun 5 02:09:47 1997
+++ pine396k2/pinerc.sample Sun Mar 15 19:28:30 1998
@@ -49,8 +49,8 @@
# List, only needed if nntp-server not set, or news is on a different host
# than used for NNTP posting. Examples: News *[] or News *{host3/nntp}[]
# Syntax: optnl-label *{news-host/protocol}[]
-news-collections=*{babyblue.cs.yale.edu/nntp}[],
- *{net161-61.student.yale.edu/nntp}[]
+#news-collections=*{babyblue.cs.yale.edu/nntp}[],
+# *{net161-61.student.yale.edu/nntp}[]
# List of folder pairs; the first indicates a folder to archive, and the
# second indicates the folder read messages in the first should
@@ -124,7 +124,7 @@
Attchmnt:
# Add these customized headers (and possible default values) when composing
-customized-hdrs=Reply-To: jshin@minerva.cis.yale.edu
+#customized-hdrs=Reply-To: jshin@minerva.cis.yale.edu
# When viewing messages, include this list of headers
viewer-hdrs=From:,
@@ -159,7 +159,7 @@
# Specifies the program invoked by ^_ in the Composer,
# or the "enable-alternate-editor-implicitly" feature.
-editor=hvi
+#editor=hvi
# Specifies the program invoked by ^T in the Composer.
speller=

View File

@ -36,7 +36,7 @@
+ #for normal build
+ #DASHO= -O
+
+ STDCFLAGS= -DBSDI -DBSDI2 -DPOSIX -DJOB_CONTROL -DANSI -DMOUSE
+ STDCFLAGS= -DBSDI -DBSDI2 -DPOSIX -DJOB_CONTROL -DANSI -DMOUSE -DTERMCAP_WINS
+ CFLAGS+= $(EXTRACFLAGS) $(DASHO) $(STDCFLAGS)
+
+ # switches for library building

View File

@ -63,7 +63,7 @@
+ LOCLIBDIR= -L$(PICODIR)
+ LIBES= $(EXTRALIBES) $(LOCLIBDIR) $(LOCLIBES) $(STDLIBES)
+
+ STDCFLAGS= -DBSDI -DSYSTYPE=\"BSF\" -DMOUSE
+ STDCFLAGS= -DBSDI -DSYSTYPE=\"BSF\" -DMOUSE -DTERMCAP_WINS
+ CFLAGS+= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(STDCFLAGS)
+
+ obj= addrbook.o adrbklib.o args.o context.o filter.o \

View File

@ -1,5 +1,37 @@
*** pine/send.c.orig Tue Feb 25 00:57:38 1997
--- pine/send.c Wed Mar 26 04:27:59 1997
--- pine/send.c Sun Jul 20 02:50:31 1997
***************
*** 5352,5364 ****
body->subtype = cpystr("octet-stream");
}
/*
* Apply maximal encoding regardless of previous
* setting. This segment's either not text, or is
* unlikely to be readable with > 30% of the
* text encoded anyway, so we might as well save space...
*/
! new_encoding = ENCBINARY; /* > 30% 8 bit chars */
}
}
--- 5352,5367 ----
body->subtype = cpystr("octet-stream");
}
+ if(body->type == TYPETEXT)
+ new_encoding = ENC8BIT;
+ else
/*
* Apply maximal encoding regardless of previous
* setting. This segment's either not text, or is
* unlikely to be readable with > 30% of the
* text encoded anyway, so we might as well save space...
*/
! new_encoding = ENCBINARY; /* > 30% 8 bit chars */
}
}
***************
*** 6113,6119 ****
@ -9,7 +41,7 @@
break;
case ENCBINARY: /* encode binary into BASE64 */
--- 6113,6120 ----
--- 6116,6123 ----
switch (body->encoding) { /* all else needs filtering */
case ENC8BIT: /* encode 8BIT into QUOTED-PRINTABLE */
@ -27,7 +59,7 @@
? ENCQUOTEDPRINTABLE
: (body->encoding <= ENCMAX)
? body->encoding : ENCOTHER]);
--- 6173,6179 ----
--- 6176,6182 ----
sprintf (*dst += strlen (*dst), "Content-Transfer-Encoding: %s\015\012",
body_encodings[(body->encoding == ENCBINARY)
? ENCBASE64

View File

@ -0,0 +1,17 @@
*** imap/ANSI/c-client/os_bsi.h.bak Wed Feb 7 12:01:07 1996
--- imap/ANSI/c-client/os_bsi.h Sun Jul 20 01:47:23 1997
***************
*** 36,42 ****
--- 36,47 ----
#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
+ #ifdef __FreeBSD__
+ #include <dirent.h>
+ #define direct dirent
+ #else
#include <sys/dir.h>
+ #endif
#include <sys/uio.h> /* needed for writev() prototypes */
#include <fcntl.h>
#include <syslog.h>

View File

@ -0,0 +1,32 @@
*** pico/os_unix.h.orig Thu Jun 13 00:47:23 1996
--- pico/os_unix.h Thu Jan 29 21:29:51 1998
***************
*** 122,133 ****
/*
* Place where mail gets delivered (for pico's new mail checking)
*/
#if defined(sv3) || defined(ct) || defined(isc) || defined(AUX) || defined(sgi)
#define MAILDIR "/usr/mail"
#else
#define MAILDIR "/usr/spool/mail"
#endif
!
/*
* What and where the tool that checks spelling is located. If this is
--- 122,136 ----
/*
* Place where mail gets delivered (for pico's new mail checking)
*/
+ #ifdef __FreeBSD__
+ #define MAILDIR "/var/mail"
+ #else
#if defined(sv3) || defined(ct) || defined(isc) || defined(AUX) || defined(sgi)
#define MAILDIR "/usr/mail"
#else
#define MAILDIR "/usr/spool/mail"
#endif
! #endif
/*
* What and where the tool that checks spelling is located. If this is

View File

@ -0,0 +1,20 @@
*** pico/tcap.c.bak Fri Mar 15 10:42:31 1996
--- pico/tcap.c Thu Jan 29 22:04:28 1998
***************
*** 322,328 ****
KPPU = tgetstr("kP", &p);
KPPD = tgetstr("kN", &p);
KPHOME = tgetstr("kh", &p);
! KPEND = tgetstr("kE", &p);
KPDEL = tgetstr("kD", &p);
KU = tgetstr("ku", &p);
KD = tgetstr("kd", &p);
--- 322,329 ----
KPPU = tgetstr("kP", &p);
KPPD = tgetstr("kN", &p);
KPHOME = tgetstr("kh", &p);
! if((KPEND = tgetstr("@7", &p)) == NULL)
! KPEND = tgetstr("kE", &p);
KPDEL = tgetstr("kD", &p);
KU = tgetstr("ku", &p);
KD = tgetstr("kd", &p);

View File

@ -0,0 +1,20 @@
*** pine/ttyout.c.bak Thu Jul 11 05:45:56 1996
--- pine/ttyout.c Thu Jan 29 22:17:48 1998
***************
*** 289,295 ****
_kppu = tgetstr("kP", &ptr);
_kppd = tgetstr("kN", &ptr);
_kphome = tgetstr("kh", &ptr);
! _kpend = tgetstr("kE", &ptr);
_kpdel = tgetstr("kD", &ptr);
_kf1 = tgetstr("k1", &ptr);
_kf2 = tgetstr("k2", &ptr);
--- 289,296 ----
_kppu = tgetstr("kP", &ptr);
_kppd = tgetstr("kN", &ptr);
_kphome = tgetstr("kh", &ptr);
! if((_kpend = tgetstr("@7", &ptr)) == NULL)
! _kpend = tgetstr("kE", &ptr);
_kpdel = tgetstr("kD", &ptr);
_kf1 = tgetstr("k1", &ptr);
_kf2 = tgetstr("k2", &ptr);

View File

@ -0,0 +1,57 @@
*** pico/display.c.bak Wed Jul 10 20:59:09 1996
--- pico/display.c Thu Jan 29 23:06:07 1998
***************
*** 82,88 ****
{"^X", "Exit", KS_EXIT}, {"^J", "Justify", KS_JUSTIFY},
{"^W", "Where is", KS_WHEREIS}, {"^V", "Next Pg", KS_NEXTPAGE},
{"^U", NULL, KS_NONE},
! #ifdef SPELLER
{"^T", "To Spell", KS_SPELLCHK}
#else
{"^D", "Del Char", KS_NONE}
--- 82,88 ----
{"^X", "Exit", KS_EXIT}, {"^J", "Justify", KS_JUSTIFY},
{"^W", "Where is", KS_WHEREIS}, {"^V", "Next Pg", KS_NEXTPAGE},
{"^U", NULL, KS_NONE},
! #if defined(SPELLER) && !defined(__FreeBSD__)
{"^T", "To Spell", KS_SPELLCHK}
#else
{"^D", "Del Char", KS_NONE}
*** pico/ebind.h.bak Fri Mar 15 10:41:58 1996
--- pico/ebind.h Thu Jan 29 23:04:30 1998
***************
*** 145,151 ****
{CTRL|'O', filewrite},
{CTRL|'P', backline},
{CTRL|'R', insfile},
! #ifdef SPELLER
{CTRL|'T', spell},
#endif /* SPELLER */
{CTRL|'U', yank},
--- 145,151 ----
{CTRL|'O', filewrite},
{CTRL|'P', backline},
{CTRL|'R', insfile},
! #if defined(SPELLER) && !defined(__FreeBSD__)
{CTRL|'T', spell},
#endif /* SPELLER */
{CTRL|'U', yank},
*** pico/main.c.bak Wed May 29 04:05:27 1996
--- pico/main.c Thu Jan 29 23:04:30 1998
***************
*** 72,78 ****
{ F9, (CTRL|'K')},
{ F10, (CTRL|'U')},
{ F11, (CTRL|'C')},
! #ifdef SPELLER
{ F12, (CTRL|'T')}
#else
{ F12, (CTRL|'D')}
--- 72,78 ----
{ F9, (CTRL|'K')},
{ F10, (CTRL|'U')},
{ F11, (CTRL|'C')},
! #if defined(SPELLER) && !defined(__FreeBSD__)
{ F12, (CTRL|'T')}
#else
{ F12, (CTRL|'D')}

View File

@ -1 +1 @@
Program for Internet E-mail and News, patched for Korean E-Mail transfer
Program for Internet E-mail(Korean) and News

View File

@ -1,5 +1,5 @@
pine-3.96k
----------
pine
----
Pine for FreeBSD 2.x is a tool for reading, sending, and managing
electronic messages. It was designed specifically with novice
@ -20,4 +20,4 @@ It is patched to remove a couple of incompatibilities with RFC 1557
and Hangul MTA. Patch is by Jungshik Shin <jshin@pantheon.yale.edu>.
--
Port by Choi Jun Ho <junker@jazz.snu.ac.kr>
Port by CHOI Junho <junker@jazz.snu.ac.kr>

View File

@ -7,6 +7,7 @@ bin/pgpencrypt
bin/pgpdecode
bin/pgpsign
etc/dot.pinerc.pgp.sample
etc/dot.pinerc.ko.sample
man/man1/pico.1.gz
man/man1/pilot.1.gz
man/man1/pine.1.gz