Add wolfssh 1.4.5

The wolfSSH library is a lightweight SSHv2 client and server library written in
ANSI C and targeted for embedded, RTOS, and resource-constrained environments -
primarily because of its small size, speed, and feature set.

WWW: https://www.wolfssl.com/products/wolfssh/
WWW: https://github.com/wolfSSL/wolfssh
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2020-12-13 14:40:35 +00:00
parent cd5e4840a5
commit a49b3f075c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=557899
6 changed files with 70 additions and 0 deletions

View File

@ -1294,6 +1294,7 @@
SUBDIR += webscarab
SUBDIR += whatweb
SUBDIR += wipe
SUBDIR += wolfssh
SUBDIR += wolfssl
SUBDIR += wpa_supplicant
SUBDIR += xca

28
security/wolfssh/Makefile Normal file
View File

@ -0,0 +1,28 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
PORTNAME= wolfssh
PORTVERSION= 1.4.5
CATEGORIES= security
MASTER_SITES= https://www.wolfssl.com/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Lightweight SSH Library
LICENSE= GPLv3
LIB_DEPENDS= libwolfssl.so:security/wolfssl
USES= autoreconf libtool localbase
CONFIGURE_ARGS= --enable-fwd \
--enable-keygen \
--enable-scp \
--enable-sftp \
--enable-shared=yes \
--enable-shell \
--enable-static=yes
GNU_CONFIGURE= yes
TEST_TARGET= check
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1607685345
SHA256 (wolfssh-1.4.5.tar.gz) = 8ed172fd670973b300b0237f0d28127d545a2d21593d1875b1b801a705eb7fb7
SIZE (wolfssh-1.4.5.tar.gz) = 665491

View File

@ -0,0 +1,13 @@
--- wolfssh/test.h.orig 2020-08-31 18:13:34 UTC
+++ wolfssh/test.h
@@ -436,8 +436,8 @@ static INLINE void build_addr(SOCKADDR_IN_T* addr, con
memset(&hints, 0, sizeof(hints));
hints.ai_family = AF_INET_V;
- hints.ai_socktype = udp ? SOCK_DGRAM : SOCK_STREAM;
- hints.ai_protocol = udp ? IPPROTO_UDP : IPPROTO_TCP;
+ hints.ai_socktype = 1 ? SOCK_DGRAM : SOCK_STREAM;
+ hints.ai_protocol = 1 ? IPPROTO_UDP : IPPROTO_TCP;
WSNPRINTF(strPort, sizeof(strPort), "%d", port);
strPort[79] = '\0';

View File

@ -0,0 +1,6 @@
The wolfSSH library is a lightweight SSHv2 client and server library written in
ANSI C and targeted for embedded, RTOS, and resource-constrained environments -
primarily because of its small size, speed, and feature set.
WWW: https://www.wolfssl.com/products/wolfssh/
WWW: https://github.com/wolfSSL/wolfssh

View File

@ -0,0 +1,19 @@
bin/wolfssh-config
include/wolfssh/agent.h
include/wolfssh/certs_test.h
include/wolfssh/error.h
include/wolfssh/keygen.h
include/wolfssh/log.h
include/wolfssh/misc.h
include/wolfssh/port.h
include/wolfssh/settings.h
include/wolfssh/ssh.h
include/wolfssh/test.h
include/wolfssh/version.h
include/wolfssh/visibility.h
include/wolfssh/wolfscp.h
include/wolfssh/wolfsftp.h
lib/libwolfssh.a
lib/libwolfssh.so
lib/libwolfssh.so.9
lib/libwolfssh.so.9.3.0