- Fix package building after switching to 'configure' rebuilding. [1]

- Do not install .la and static library files.

Reported by:	erwin [1]
This commit is contained in:
Stanislav Sedov 2009-04-07 22:00:12 +00:00
parent 8becc787c3
commit a492e87bbd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=231828
10 changed files with 73 additions and 56 deletions

View File

@ -14,12 +14,14 @@ DISTNAME= mpio-${PORTVERSION:S|.p|_pre|}
MAINTAINER= ports@FreeBSD.org
COMMENT= Digit@lway MPIO MP3 player tool
USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:262 libtool:15
ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib -liconv"
.include <bsd.port.pre.mk>
@ -27,9 +29,18 @@ CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
.else
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
USE_AUTOTOOLS= autoconf:262
.endif
patch-autotools:
${DO_NADA}
#
# Get rid of .la and static library files
#
post-configure:
@${REINPLACE_CMD} -E -e \
'/Install the pseudo-library/,/staticlibs=/s,^,#,' ${WRKSRC}/libtool
post-patch:
.if ${OSVERSION} >= 800069
${RM} -f ${WRKSRC}/configure

View File

@ -1,6 +1,6 @@
--- configure.in.orig 2004-05-30 05:45:55.000000000 +0400
+++ configure.in 2009-03-07 01:43:55.000000000 +0300
@@ -60,34 +60,18 @@
--- configure.in.orig 2009-04-08 01:50:59.000000000 +0400
+++ configure.in 2009-04-08 01:52:14.000000000 +0400
@@ -60,23 +60,17 @@
dnl -- check for libusb
dnl -- this is stolen from libgphoto2
@ -8,8 +8,8 @@
-if test -n "${LIBUSB_CONFIG}"; then
- CPPFLAGS_save="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS `$LIBUSB_CONFIG --cflags`"
+CPPFLAGS_save="$CPPFLAGS"
AC_CHECK_HEADER(usb.h,[
- AC_CHECK_HEADER(usb.h,[
+AC_CHECK_HEADER(usb.h,[
LDFLAGS_orig="$LDFLAGS"
- LDFLAGS="`$LIBUSB_CONFIG --libs`"
+ LDFLAGS="-lusb"
@ -24,18 +24,7 @@
usb_msg="no (available version too old)"])
LDFLAGS="$LDFLAGS_orig"])
CPPFLAGS="$CPPFLAGS_save"
-fi
-
- # This 'test' call uses non-standard syntax and will fail on most
- # systems, but it's just informational so any warning can be ignored.
-if test "$LIBUSB_VER" \< "0.1.7"; then
- AC_MSG_WARN([
-*** You need at least version 0.1.7 of the libusb library for USB support
-*** http://sourceforge.net/projects/libusb/
-*** If you cannot find the appropriate version, try CVS
- ])
- exit 1
-fi
case "$usb_msg" in
yes*) AC_DEFINE(HAVE_USB,1,[Whether you have USB support enabled]);;
# This 'test' call uses non-standard syntax and will fail on most
# systems, but it's just informational so any warning can be ignored.

View File

@ -0,0 +1,7 @@
--- Makefile.am.orig 2009-04-08 01:40:10.000000000 +0400
+++ Makefile.am 2009-04-08 01:40:14.000000000 +0400
@@ -1,3 +1,3 @@
-SUBDIRS=@MPIO_KERNEL@ libmpio mpiosh etc tools hotplug
+SUBDIRS=@MPIO_KERNEL@ libmpio mpiosh etc tools
EXTRA_DIST=mpio.spec

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig Mon May 31 09:13:58 2004
+++ Makefile.in Mon May 31 09:14:08 2004
@@ -184,7 +184,7 @@
target_cpu = @target_cpu@
target_os = @target_os@
target_vendor = @target_vendor@
-SUBDIRS = @MPIO_KERNEL@ libmpio mpiosh etc tools hotplug
+SUBDIRS = @MPIO_KERNEL@ libmpio mpiosh etc tools
EXTRA_DIST = mpio.spec
all: all-recursive

View File

@ -1,11 +0,0 @@
--- configure.orig Sun May 30 05:47:49 2004
+++ configure Sat Jul 23 18:09:22 2005
@@ -19999,7 +19999,7 @@
# This 'test' call uses non-standard syntax and will fail on most
# systems, but it's just informational so any warning can be ignored.
-if test "$LIBUSB_VER" \< "0.1.7"; then
+if test "$LIBUSB_VER" \< "0.1.10"; then
{ echo "$as_me:$LINENO: WARNING:
*** You need at least version 0.1.7 of the libusb library for USB support
*** http://sourceforge.net/projects/libusb/

View File

@ -0,0 +1,17 @@
--- configure.in.orig 2009-04-08 01:37:33.000000000 +0400
+++ configure.in 2009-04-08 01:37:43.000000000 +0400
@@ -80,14 +80,6 @@
# This 'test' call uses non-standard syntax and will fail on most
# systems, but it's just informational so any warning can be ignored.
-if test "$LIBUSB_VER" \< "0.1.7"; then
- AC_MSG_WARN([
-*** You need at least version 0.1.7 of the libusb library for USB support
-*** http://sourceforge.net/projects/libusb/
-*** If you cannot find the appropriate version, try CVS
- ])
- exit 1
-fi
case "$usb_msg" in
yes*) AC_DEFINE(HAVE_USB,1,[Whether you have USB support enabled]);;

View File

@ -0,0 +1,10 @@
--- libmpio/Makefile.am.orig 2009-04-08 01:38:43.000000000 +0400
+++ libmpio/Makefile.am 2009-04-08 01:38:48.000000000 +0400
@@ -1,6 +1,6 @@
INCLUDES=@MPLIB_INCLUDE@
AM_CFLAGS=@MPLIB_CFLAGS@ @USB_CFLAGS@
-AM_LDFLAGS=-version-info 1:0:0 @USB_LIBS@
+AM_LDFLAGS=-version-info 1 @USB_LIBS@
lib_LTLIBRARIES=libmpio.la

View File

@ -1,11 +0,0 @@
--- mpiosh/Makefile.in.orig Mon May 31 09:19:32 2004
+++ mpiosh/Makefile.in Mon May 31 09:20:36 2004
@@ -116,7 +116,7 @@
KERNEL_INCLUDE = @KERNEL_INCLUDE@
LDFLAGS = @LDFLAGS@
LIBOBJS = @LIBOBJS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -liconv
LIBTOOL = @LIBTOOL@
LIBUSB_CONFIG = @LIBUSB_CONFIG@
LN_S = @LN_S@

View File

@ -0,0 +1,18 @@
--- mpiosh/Makefile.am.orig 2009-04-08 01:39:27.000000000 +0400
+++ mpiosh/Makefile.am 2009-04-08 01:39:41.000000000 +0400
@@ -12,7 +12,7 @@
AM_CFLAGS=-DSYSCONFDIR=\"@sysconfdir@\"
-mpiosh_LDADD=../libmpio/libmpio.la -lreadline -lncurses
+mpiosh_LDADD=../libmpio/libmpio.la -lreadline -lncurses -liconv
noinst_HEADERS = mpiosh.h \
callback.h \
@@ -20,4 +20,4 @@
command.h \
global.h \
cfgio.h \
- config.h
\ No newline at end of file
+ config.h

View File

@ -1,8 +1,6 @@
bin/mpiologo
bin/mpiosh
etc/mpio/mpioshrc
lib/libmpio.a
lib/libmpio.la
lib/libmpio.so
lib/libmpio.so.1
include/mpio/defs.h