- Update to 2.2.6 version.

An unpleasant bug was fixed when pkgdb could accidently remove some
  dependencies in +CONTENTS files. It's recomented to run pkgdb -L once
  after upgrade to fix dependencies list. See UPDATING file.

Reported and tested by:	Randy Pratt <bsd-unix_AT_earthlink.net>
This commit is contained in:
Sergey Matveychuk 2007-03-01 09:09:01 +00:00
parent 6da59fcb91
commit a48c576322
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=186244
7 changed files with 49 additions and 38 deletions

View File

@ -6,6 +6,21 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
20070301:
AFFECTS: users of ports-mgmt/portupgrade*
AUTHOR: sem@FreeBSD.org
Because of a bug in previous version, it's recomended you fill ALT_PKGDEP
section in pkgtools.conf file for portupgrade be aware of alternative
dependencies you use, and run pkgdb -L to restore dependencies that was
lost.
Example of ALT_PKGDEP section:
ALT_PKGDEP = {
'www/apache13' => 'www/apache13-modssl',
'print/ghostscript-afpl' => 'print/ghostscript-gnu',
}
20070227:
AFFECTS: users of net-im/jabber*
AUTHOR: martin@matuska.org

View File

@ -6,8 +6,7 @@
#
PORTNAME= portupgrade
PORTVERSION= 2.2.2
PORTREVISION= 4
PORTVERSION= 2.2.6
PORTEPOCH= 2
CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@ -91,5 +90,6 @@ post-install: install-ldconfig-file
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi
${MKDIR} ${PREFIX}/lib/compat/pkg
${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (pkgtools-2.2.2.tar.bz2) = c9e08616c474d776f301ada920735a66
SHA256 (pkgtools-2.2.2.tar.bz2) = ab5cd8904e69c03be0d37cf71b2d6271ccabed14bca673e5a34a7d21a1af5c02
SIZE (pkgtools-2.2.2.tar.bz2) = 111055
MD5 (pkgtools-2.2.6.tar.bz2) = eeecbe495083bb6851575714d8ae1f81
SHA256 (pkgtools-2.2.6.tar.bz2) = a4cc69fa0c7a9c43caabe3319b192437372895956320a6abbf5f9156f5d5f093
SIZE (pkgtools-2.2.6.tar.bz2) = 112379

View File

@ -0,0 +1,17 @@
Index: bin/pkgdb
===================================================================
RCS file: /cvsroot/portupgrade/pkgtools/bin/pkgdb,v
retrieving revision 1.9.2.6
retrieving revision 1.9.2.7
diff -u -r1.9.2.6 -r1.9.2.7
--- pkgdb 27 Feb 2007 11:30:31 -0000 1.9.2.6
+++ pkgdb 27 Feb 2007 17:58:46 -0000 1.9.2.7
@@ -700,7 +700,7 @@
hash = config_value(:ALT_PKGDEP) or return nil
if dep == ''
- dep = $pkgdb.deorigin(origin)
+ dep = $pkgdb.deorigin(origin).to_s
end
hash.each do |pat, alt|

View File

@ -1,22 +0,0 @@
--- lib/portsdb.rb.orig Sat Nov 11 22:59:24 2006
+++ lib/portsdb.rb Mon Feb 5 10:15:00 2007
@@ -56,7 +56,7 @@
"vietnamese" => "vi-",
}
- MY_PORT = 'sysutils/portupgrade'
+ MY_PORT = 'ports-mgmt/portupgrade'
LOCK_FILE = '/var/run/portsdb.lock'
@@ -387,8 +387,8 @@
end
def subdirs(dir)
- %x"fgrep -v bsd.port.subdir.mk #{dir}/Makefile |
- make -f - -V SUBDIR 2> /dev/null".split.select { |i|
+ %x"fgrep SUBDIR #{dir}/Makefile | sed -e 's/SUBDIR +=//'
+ 2> /dev/null".split.select { |i|
File.directory?(File.join(dir, i))
}.sort
end

View File

@ -1,11 +0,0 @@
--- bin/portupgrade.orig Thu Feb 1 15:42:15 2007
+++ bin/portupgrade Thu Feb 1 15:42:22 2007
@@ -1594,7 +1594,7 @@
end
if $sudo && Process.euid != 0
- dep_cmdargs = cmdargs.dup << 'fetch-depends' << 'build-depends' << 'lib-depends' << 'misc-depends'
+ dep_cmdargs = cmdargs.dup << 'fetch-depends' << 'build-depends' << 'lib-depends'
if not system(shelljoin(*dep_cmdargs) + ' DEPENDS_TARGET="-n nonexistent_target" >/dev/null 2>&1')
script!(logfile, *dep_cmdargs) or

View File

@ -0,0 +1,12 @@
-----------------------------------------------------------------------
NOTE: If you upgrade, it's recomended to run pkgdb -L to restore lost
dependencies.
Fill ALT_PKGDEP section in pkgtools.conf file for portupgrade
be aware of alternative dependencies you use.
E.g.
ALT_PKGDEP = {
'www/apache13' => 'www/apache13-modssl',
'print/ghostscript-afpl' => 'print/ghostscript-gnu',
}
-----------------------------------------------------------------------