Fix build on non-clang systems.[0]

Switch to shared LICENSE defintions.

Chase USE_GNOME changes.

PR:		231528 [0]
Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl> [0]
Sponsored by:	DARPA, AFRL
This commit is contained in:
Brooks Davis 2018-10-02 20:12:26 +00:00
parent 393a1c00f3
commit a4484f91e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=481132
2 changed files with 15 additions and 6 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= llvm
DISTVERSION= 4.0.1
PORTREVISION= 9
PORTREVISION= 10
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/${PRE_}releases/${LLVM_RELEASE}/${RCDIR}
PKGNAMESUFFIX= ${LLVM_SUFFIX}
@ -12,10 +12,7 @@ DISTFILES= ${PORTNAME}-${DISTVERSION}.src${EXTRACT_SUFX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= LLVM and Clang
LICENSE= LLVM
LICENSE_NAME= LLVM Release License
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
.include "${.CURDIR}/../llvm-devel/Makefile.LICENSE"
LLVM_RELEASE= ${DISTVERSION:C/rc.*//}
LLVM_MAJOR= ${LLVM_RELEASE:C/\.[0-9]$//}
@ -94,7 +91,8 @@ LLD_EXTRA_PATCHES= ${PATCHDIR}/lld
LLDB_BUILD_DEPENDS= swig3.0:devel/swig30
LLDB_DESC= Install lldb, the LLVM debugger
LLDB_DISTFILES= lldb-${DISTVERSION}.src${EXTRACT_SUFX}
LLDB_EXTRA_PATCHES= ${PATCHDIR}/lldb-patch-tools_lldb_source_Host_common_FileSpec.cpp
LLDB_EXTRA_PATCHES= ${PATCHDIR}/lldb-patch-tools_lldb_source_Host_common_FileSpec.cpp \
${PATCHDIR}/lldb-patch-tools_lldb_include_lldb_Utility_TaskPool.h
LLDB_IMPLIES= CLANG
LLDB_VARS= _USES_PYTHON=python:2.7
OPENMP_DESC= Install libomp, the LLVM OpenMP runtime library
@ -225,6 +223,7 @@ CLANG_PATTERN= (c-index-test|clang|scan-|Reporter.py|ScanView.py|scanview.css|so
SHEBANG_FILES+= tools/clang/tools/scan-view/bin/scan-view \
tools/clang/tools/clang-format/git-clang-format \
tools/clang/tools/clang-format/clang-format-diff.py
USES+= gnome
.endif
.if ${PORT_OPTIONS:MCOMPILER_RT}

View File

@ -0,0 +1,10 @@
--- tools/lldb/include/lldb/Utility/TaskPool.h.orig 2018-09-20 19:31:12 UTC
+++ tools/lldb/include/lldb/Utility/TaskPool.h
@@ -33,6 +33,7 @@
#include <queue>
#include <thread>
#include <vector>
+#include <functional>
// Global TaskPool class for running tasks in parallel on a set of worker thread
// created the first