Add ruby-opengl, OpenGL/GLU/GLUT interface modules for Ruby.
This commit is contained in:
parent
e7a038828e
commit
a407b4fe8c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31924
@ -147,6 +147,7 @@
|
||||
SUBDIR += quickpics
|
||||
SUBDIR += qvplay
|
||||
SUBDIR += rayshade
|
||||
SUBDIR += ruby-opengl
|
||||
SUBDIR += sane
|
||||
SUBDIR += sced
|
||||
SUBDIR += scwm-icons
|
||||
|
48
graphics/ruby-opengl/Makefile
Normal file
48
graphics/ruby-opengl/Makefile
Normal file
@ -0,0 +1,48 @@
|
||||
# New ports collection makefile for: Ruby/OpenGL
|
||||
# Date created: 24 Aug 2000
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= opengl
|
||||
PORTVERSION= 0.31
|
||||
CATEGORIES= graphics ruby
|
||||
MASTER_SITES= http://www2.giganet.net/~yoshi/
|
||||
PKGNAMEPREFIX= ruby-
|
||||
DISTNAME= rbogl
|
||||
EXTRACT_SUFX= .tgz
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= knu@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
|
||||
RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
|
||||
|
||||
USE_MESA= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/oglmodule
|
||||
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
|
||||
|
||||
INSTALL_TARGET= site-install
|
||||
|
||||
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
|
||||
|
||||
RUBY?= ${LOCALBASE}/bin/ruby
|
||||
RUBY_VER?= 1.4
|
||||
RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC}; \
|
||||
${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/examples/ruby/opengl
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${PREFIX}/share/examples/ruby/opengl/
|
||||
${MKDIR} ${PREFIX}/share/doc/ruby/opengl/ja
|
||||
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/ruby/opengl/
|
||||
${INSTALL_DATA} ${WRKSRC}/README.EUC ${PREFIX}/share/doc/ruby/opengl/ja/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/ruby-opengl/distinfo
Normal file
1
graphics/ruby-opengl/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (ruby/rbogl.tgz) = b5a063733ea63236038e3ed8e98a93a4
|
56
graphics/ruby-opengl/files/patch-aa
Normal file
56
graphics/ruby-opengl/files/patch-aa
Normal file
@ -0,0 +1,56 @@
|
||||
--- extconf.rb.orig Wed Feb 16 01:31:59 2000
|
||||
+++ extconf.rb Thu Aug 24 21:18:28 2000
|
||||
@@ -26,8 +26,8 @@
|
||||
glu_libname = "glu32"
|
||||
glut_libname = "glut"
|
||||
else
|
||||
- $CFLAGS="-I/usr/local/include -I. -I/usr/X11R6/include"
|
||||
- $LDFLAGS="-L/usr/local/lib -L/usr/X11R6/lib"
|
||||
+ dir_config("x11")
|
||||
+ dir_config("ruby")
|
||||
$libs = append_library($libs, "Xmu")
|
||||
$libs = append_library($libs, "X11")
|
||||
gl_libname = "GL"
|
||||
@@ -47,7 +47,7 @@
|
||||
}
|
||||
}
|
||||
File.unlink("Makefile")
|
||||
- modules = modules + "opengl.#{CONFIG[\"DLEXT\"]}"
|
||||
+ modules = modules + "opengl.#{CONFIG['DLEXT']}"
|
||||
ogl_flg = true
|
||||
else
|
||||
p "can't create OpenGL module!"
|
||||
@@ -67,7 +67,7 @@
|
||||
}
|
||||
}
|
||||
File.unlink("Makefile")
|
||||
- modules = "glut.#{CONFIG[\"DLEXT\"]} " + modules
|
||||
+ modules = "glut.#{CONFIG['DLEXT']} " + modules
|
||||
glut_flg = true
|
||||
end
|
||||
|
||||
@@ -76,11 +76,11 @@
|
||||
SHELL = /bin/sh
|
||||
all: #{modules}
|
||||
|
||||
-opengl.#{CONFIG[\"DLEXT\"]}: rbogl.c ogl.c glu.c rbogl.h
|
||||
+opengl.#{CONFIG['DLEXT']}: rbogl.c ogl.c glu.c rbogl.h
|
||||
@echo Now Making opengl extend module
|
||||
@$(MAKE) -f Makefile.ogl
|
||||
|
||||
-glut.#{CONFIG[\"DLEXT\"]}: glut.c
|
||||
+glut.#{CONFIG['DLEXT']}: glut.c
|
||||
@echo Now Making glut extend module
|
||||
@$(MAKE) -f Makefile.glut
|
||||
|
||||
@@ -94,6 +94,10 @@
|
||||
install: #{modules}
|
||||
#{"\t@$(MAKE) -f Makefile.ogl install" if (ogl_flg)}
|
||||
#{"\t@$(MAKE) -f Makefile.glut install" if (glut_flg)}
|
||||
+
|
||||
+site-install: #{modules}
|
||||
+#{"\t@$(MAKE) -f Makefile.ogl site-install" if (ogl_flg)}
|
||||
+#{"\t@$(MAKE) -f Makefile.glut site-install" if (glut_flg)}
|
||||
MAKEFILE
|
||||
}
|
||||
|
1
graphics/ruby-opengl/pkg-comment
Normal file
1
graphics/ruby-opengl/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
OpenGL/GLU/GLUT interface modules for Ruby
|
4
graphics/ruby-opengl/pkg-descr
Normal file
4
graphics/ruby-opengl/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
This is OpenGL/GLU/GLUT interface modules for Ruby.
|
||||
|
||||
Author: Yoshiyuki Kusano <yoshi@giganet.net>
|
||||
WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=OpenGL+Interface
|
56
graphics/ruby-opengl/pkg-plist
Normal file
56
graphics/ruby-opengl/pkg-plist
Normal file
@ -0,0 +1,56 @@
|
||||
lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/glut.so
|
||||
lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/opengl.so
|
||||
share/examples/ruby/opengl/aaindex.rb
|
||||
share/examples/ruby/opengl/aapoly.rb
|
||||
share/examples/ruby/opengl/aargb.rb
|
||||
share/examples/ruby/opengl/accanti.rb
|
||||
share/examples/ruby/opengl/accpersp.rb
|
||||
share/examples/ruby/opengl/alpha.rb
|
||||
share/examples/ruby/opengl/alpha3D.rb
|
||||
share/examples/ruby/opengl/bezcurve.rb
|
||||
share/examples/ruby/opengl/bezmesh.rb
|
||||
share/examples/ruby/opengl/checker.rb
|
||||
share/examples/ruby/opengl/clip.rb
|
||||
share/examples/ruby/opengl/colormat.rb
|
||||
share/examples/ruby/opengl/cube.rb
|
||||
share/examples/ruby/opengl/depthcue.rb
|
||||
share/examples/ruby/opengl/dof.rb
|
||||
share/examples/ruby/opengl/double.rb
|
||||
share/examples/ruby/opengl/drawf.rb
|
||||
share/examples/ruby/opengl/feedback.rb
|
||||
share/examples/ruby/opengl/fog.rb
|
||||
share/examples/ruby/opengl/font.rb
|
||||
share/examples/ruby/opengl/hello.rb
|
||||
share/examples/ruby/opengl/image.rb
|
||||
share/examples/ruby/opengl/jitter.rb
|
||||
share/examples/ruby/opengl/lines.rb
|
||||
share/examples/ruby/opengl/list.rb
|
||||
share/examples/ruby/opengl/material.rb
|
||||
share/examples/ruby/opengl/mipmap.rb
|
||||
share/examples/ruby/opengl/model.rb
|
||||
share/examples/ruby/opengl/movelight.rb
|
||||
share/examples/ruby/opengl/nurbs.rb
|
||||
share/examples/ruby/opengl/pickdepth.rb
|
||||
share/examples/ruby/opengl/plane.rb
|
||||
share/examples/ruby/opengl/planet.rb
|
||||
share/examples/ruby/opengl/quadric.rb
|
||||
share/examples/ruby/opengl/robot.rb
|
||||
share/examples/ruby/opengl/select.rb
|
||||
share/examples/ruby/opengl/smooth.rb
|
||||
share/examples/ruby/opengl/stencil.rb
|
||||
share/examples/ruby/opengl/stroke.rb
|
||||
share/examples/ruby/opengl/surface.rb
|
||||
share/examples/ruby/opengl/teaambient.rb
|
||||
share/examples/ruby/opengl/teapots.rb
|
||||
share/examples/ruby/opengl/tess.rb
|
||||
share/examples/ruby/opengl/test.rb
|
||||
share/examples/ruby/opengl/texbind.rb
|
||||
share/examples/ruby/opengl/texgen.rb
|
||||
share/examples/ruby/opengl/texturesurf.rb
|
||||
share/examples/ruby/opengl/varray.rb
|
||||
share/examples/ruby/opengl/wrap.rb
|
||||
@dirrm share/examples/ruby/opengl
|
||||
share/doc/ruby/opengl/ChangeLog
|
||||
share/doc/ruby/opengl/ja/README.EUC
|
||||
@dirrm share/doc/ruby/opengl/ja
|
||||
@dirrm share/doc/ruby/opengl
|
Loading…
Reference in New Issue
Block a user