biology/njplot: Revive and update to version 2.4
Approved by: AMDmi3 (mentor) Differential Revision: https://reviews.freebsd.org/D8518
This commit is contained in:
parent
bb94ef0d66
commit
a3fc357457
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=426241
1
MOVED
1
MOVED
@ -7966,7 +7966,6 @@ cad/slffea||2015-11-28|Has expired: Broken for more than 6 months
|
||||
audio/cripple||2015-11-28|Has expired: Broken for more than 6 months
|
||||
cad/geda-gattrib||2015-11-28|Has expired: Broken for more than 6 months
|
||||
cad/findhier||2015-11-28|Has expired: Broken for more than 6 months
|
||||
biology/njplot||2015-11-28|Has expired: Broken for more than 6 months
|
||||
audio/wmmp||2015-11-28|Has expired: Broken for more than 6 months
|
||||
x11/avant-window-navigator||2015-11-28|Has expired: Broken for more than 6 months
|
||||
cad/geda-netlist||2015-11-28|Has expired: Broken for more than 6 months
|
||||
|
@ -55,6 +55,7 @@
|
||||
SUBDIR += muscle
|
||||
SUBDIR += ncbi-blast+
|
||||
SUBDIR += ncbi-toolkit
|
||||
SUBDIR += njplot
|
||||
SUBDIR += p5-AcePerl
|
||||
SUBDIR += p5-Bio-ASN1-EntrezGene
|
||||
SUBDIR += p5-Bio-Das
|
||||
|
39
biology/njplot/Makefile
Normal file
39
biology/njplot/Makefile
Normal file
@ -0,0 +1,39 @@
|
||||
# Created by: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= njplot
|
||||
PORTVERSION= 2.4
|
||||
CATEGORIES= biology
|
||||
MASTER_SITES= ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/ \
|
||||
ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/
|
||||
|
||||
MAINTAINER= jrm@FreeBSD.org
|
||||
COMMENT= Phylogenetic tree drawing program
|
||||
|
||||
LICENSE= NONE
|
||||
|
||||
BUILD_DEPENDS= blastall:biology/ncbi-toolkit
|
||||
|
||||
MAKEFILE= makefile
|
||||
|
||||
USES= motif
|
||||
USE_XORG= x11 xmu xp xt
|
||||
|
||||
BINARIES= newicktops newicktotxt njplot unrooted
|
||||
PLIST_FILES= ${BINARIES:S|^|bin/|} man/man1/njplot.1.gz \
|
||||
man/man1/unrooted.1.gz ${DATADIR}/njplot.help
|
||||
PORTDOCS= njplot.html njplot.gif
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${BINARIES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/njplot.help ${STAGEDIR}${DATADIR}
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
biology/njplot/distinfo
Normal file
3
biology/njplot/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1479168824
|
||||
SHA256 (njplot-2.4.tar.gz) = e470f7583691da2ad36a7cda4269bf64807f77cb27fe1e16cbfefc45942469d3
|
||||
SIZE (njplot-2.4.tar.gz) = 83239
|
49
biology/njplot/files/patch-makefile
Normal file
49
biology/njplot/files/patch-makefile
Normal file
@ -0,0 +1,49 @@
|
||||
--- makefile.orig 2012-01-04 08:50:43 UTC
|
||||
+++ makefile
|
||||
@@ -1,5 +1,5 @@
|
||||
#uncomment and locally adapt next line to fix the full helpfile path name
|
||||
-HELPFILENAME = -DHELPFILENAME=\"/usr/share/njplot/njplot.help\"
|
||||
+HELPFILENAME = -DHELPFILENAME=\"${DATADIR}/njplot.help\"
|
||||
|
||||
#comment out next line and uncomment next 2 to use the PDFLib Lite library
|
||||
NO_PDF = -DNO_PDF
|
||||
@@ -7,27 +7,31 @@ NO_PDF = -DNO_PDF
|
||||
#PDFLIB = -L$(PDF) -lpdf
|
||||
|
||||
# c compiler and linker
|
||||
-CC = gcc
|
||||
+CC ?= cc
|
||||
|
||||
-# Vibrant top directory
|
||||
-VIBRANT = /usr/include/ncbi
|
||||
+NCBIINC = $(LOCALBASE)/include/ncbi
|
||||
+NCBILIB = $(LOCALBASE)/lib/ncbi
|
||||
|
||||
OBJECTS = njplot-vib.o
|
||||
OBJUNROOTED = unrooted-vib.o preptree.o
|
||||
|
||||
+CFLAGS = -c -DWIN_MOTIF -Dunix -I${LOCALBASE}/include -I$(NCBIINC) $(HELPFILENAME) $(NO_PDF) -Wimplicit-function-declaration
|
||||
|
||||
-CFLAGS = -c -DWIN_MOTIF -Dunix -I$(VIBRANT) $(HELPFILENAME) $(NO_PDF)
|
||||
-
|
||||
all: njplot unrooted newicktops newicktotxt
|
||||
|
||||
|
||||
njplot : $(OBJECTS)
|
||||
$(CC) -o njplot $(OBJECTS) \
|
||||
- -lvibrant -lncbi -lXm -lXt
|
||||
-
|
||||
+ -L$(NCBILIB) \
|
||||
+ -lvibrant -lncbi \
|
||||
+ $(MOTIFLIB) \
|
||||
+ -L$(LOCALBASE)/lib -lXmu -lXt -lX11 -lm
|
||||
+
|
||||
unrooted : $(OBJUNROOTED)
|
||||
$(CC) -o unrooted $(OBJUNROOTED) \
|
||||
- -lvibrant -lncbi -lXm -lXt
|
||||
+ -L$(NCBILIB) -lvibrant -lncbi \
|
||||
+ $(MOTIFLIB) \
|
||||
+ -L$(LOCALBASE)/lib -lXmu -lXt -lX11 -lm
|
||||
|
||||
newicktops: njplot-vib.c
|
||||
$(CC) -DNO_GUI -DNO_PDF -o $@ njplot-vib.c -lm
|
17
biology/njplot/pkg-descr
Normal file
17
biology/njplot/pkg-descr
Normal file
@ -0,0 +1,17 @@
|
||||
NJplot is a tree drawing program able to draw any phylogenetic tree expressed
|
||||
in the Newick phylogenetic tree format (e.g., the format used by the PHYLIP
|
||||
package). NJplot is especially convenient for rooting the unrooted trees
|
||||
obtained from parsimony, distance or maximum likelihood tree-building methods.
|
||||
|
||||
The package contains the following programs:
|
||||
njplot - draw phylogenetic trees and interactively modify them
|
||||
newicktops - non-interactive version rendering into a PostScript file
|
||||
newicktotxt - non-interactive version rendering into a text file
|
||||
unrooted - draw unrooted circular trees
|
||||
|
||||
If you use NJplot in a published work, please cite the following reference:
|
||||
|
||||
Perriere, G. and Gouy, M. (1996) WWW-Query: An on-line retrieval system for
|
||||
biological sequence banks. Biochimie, 78, 364-369.
|
||||
|
||||
WWW: http://pbil.univ-lyon1.fr/software/njplot.html
|
Loading…
Reference in New Issue
Block a user