- Unbreak parallel builds (-jX) by fixing make(1) syntax (still remains to

a certain degree a mess, though...); convert USE_GMAKE
- Remove prehistoric files/patch-aa, use MAKE_ARGS for that purpose
- Produce verbose build log when built on the cluster
- Convert to OptionsNG (DOCS, EXAMPLES)
- Tighten Makefile header and COMMENT while here

Reported by:	marino
Approved by:	miwi, bapt (portmgr, implicit)
This commit is contained in:
Alexey Dokuchaev 2013-08-21 08:42:48 +00:00
parent 3865d2c317
commit a3e6948e6a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=325097
2 changed files with 24 additions and 27 deletions

View File

@ -1,9 +1,5 @@
# New ports collection makefile for: TrickyIRC
# Date created: Jun 20th 1999
# Whom: troll
#
# Created by: Adam Strohl <troll@digitalspark.net>
# $FreeBSD$
#
PORTNAME= trickyirc
PORTVERSION= 1.1.0
@ -13,23 +9,40 @@ MASTER_SITES= http://www.leb.net/~troll/
DISTNAME= TrickyIRC-${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Allows client independent detaching and reattaching of IRC sessions
COMMENT= Client-independent detaching and reattaching of IRC sessions
USES= gmake
MAKEFILE= GNUmakefile
MAKE_ARGS= CC="${CC}" OPTCC_OPTS="${CFLAGS}"
WRKSRC= ${WRKDIR}/trickyirc
USE_GMAKE= YES
.if defined(BATCH) || defined(PACKAGE_BUILDING)
MAKE_ARGS+= VERBOSE=YES
.endif
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= *
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
# Use better make(1) syntax in attempt to fix parallel (-jX) builds; do not
# explicitly set MAKE, it's a builtin variable that make(1) must set itself
post-patch:
@${REINPLACE_CMD} -E \
's/cd (.+); gmake \$$@; cd \.\./$$(MAKE) -C \1 $$@/' \
${WRKSRC}/core/make/project.mk
@${REINPLACE_CMD} -e '/MAKE=/d' ${WRKSRC}/core/make/platforms.mk
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
@ ${MKDIR} ${EXAMPLESDIR}
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/config.sample ${EXAMPLESDIR}
.endif
@${STRIP_CMD} ${PREFIX}/bin/${PORTNAME}

View File

@ -1,16 +0,0 @@
--- core/make/platforms.mk.orig Sun Jul 4 07:46:04 1999
+++ core/make/platforms.mk Thu Jul 8 18:23:35 1999
@@ -2,10 +2,10 @@
#
ifeq (${OS},UNIX)
- CC= gcc
- MAKE= gmake
+ CC?= gcc
+ MAKE= ${GMAKE}
SHOWOFFCC_OPTS= -Wall
- OPTCC_OPTS= -O
+ OPTCC_OPTS= ${CFLAGS}
BASECC_OPTS= -c -DUNIX
BASELINK_OPTS= ${LIBRARYPATH}
MAKE_OPTS=