- Update to version 1.18.1
- Our gzip don't support --rsyncable flag, add patch to fix it
This commit is contained in:
parent
ba50b420f7
commit
a3692db463
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=389251
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dpkg
|
||||
PORTVERSION= 1.18.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.18.1
|
||||
CATEGORIES= archivers sysutils
|
||||
MASTER_SITES= DEBIAN_POOL
|
||||
DISTNAME= dpkg_${PORTVERSION}
|
||||
@ -29,7 +28,7 @@ SUB_FILES= pkg-install pkg-deinstall
|
||||
SUB_LIST+= DPKGDIR=${DPKGDIR}
|
||||
|
||||
CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --libdir=${PREFIX}/libexec \
|
||||
--program-transform-name="" --with-libintl-prefix=${LOCALBASE} \
|
||||
--with-libintl-prefix=${LOCALBASE} \
|
||||
--with-logdir=/var/log
|
||||
CONFIGURE_ENV+= PERL_LIBDIR="${PREFIX}/${SITE_PERL_REL}"
|
||||
|
||||
@ -39,10 +38,6 @@ OPTIONS_SUB= yes
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
NLS_USES= gettext
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} '/^LDFLAGS/ s|$$| -lmd|' \
|
||||
${WRKSRC}/lib/dpkg/Makefile.in
|
||||
|
||||
post-install:
|
||||
(cd ${STAGEDIR}${DPKGDIR} && ${MKDIR} available diversions \
|
||||
statoverride status)
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (dpkg_1.18.0.tar.xz) = 7b156fbeed5bbfb8aa546a18badb46e471b65fa00777ccd8d7e3bbce002f225a
|
||||
SIZE (dpkg_1.18.0.tar.xz) = 4330304
|
||||
SHA256 (dpkg_1.18.1.tar.xz) = cb26a97ca21c970cbe63a762125fe21f7437663badf6ce686589fe62650399da
|
||||
SIZE (dpkg_1.18.1.tar.xz) = 4340240
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- lib/compat/gettext.h.orig 2015-05-07 18:40:12 UTC
|
||||
--- lib/compat/gettext.h.orig 2015-05-03 14:52:33 UTC
|
||||
+++ lib/compat/gettext.h
|
||||
@@ -53,7 +53,6 @@
|
||||
<libintl.h>, which chokes if dcgettext is defined as a macro. So include
|
||||
|
11
archivers/dpkg/files/patch-scripts_Dpkg_Compression.pm
Normal file
11
archivers/dpkg/files/patch-scripts_Dpkg_Compression.pm
Normal file
@ -0,0 +1,11 @@
|
||||
--- scripts/Dpkg/Compression.pm.orig 2015-06-11 20:28:56 UTC
|
||||
+++ scripts/Dpkg/Compression.pm
|
||||
@@ -55,7 +55,7 @@ interact with the set of supported compr
|
||||
my $COMP = {
|
||||
gzip => {
|
||||
file_ext => 'gz',
|
||||
- comp_prog => [ 'gzip', '--no-name', '--rsyncable' ],
|
||||
+ comp_prog => [ 'gzip', '--no-name' ],
|
||||
decomp_prog => [ 'gunzip' ],
|
||||
default_level => 9,
|
||||
},
|
Loading…
Reference in New Issue
Block a user