- USE_LIBTOOL (no .la files installed)

- Add patch to preload libstdc++ (LD_PRELOAD no longer needed)
- use PLIST_FILES
- Bump PORTREVISION
This commit is contained in:
Max Khon 2004-02-04 21:31:02 +00:00
parent d8f4a98e24
commit a36824c8e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100001
4 changed files with 3 additions and 52 deletions

View File

@ -8,7 +8,7 @@
PKGNAMEPREFIX= xmms-
PORTNAME= arts_output
PORTVERSION= 0.6.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://havardk.xmms.org/plugins/arts_output/
@ -20,14 +20,9 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
USE_X_PREFIX= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
post-install:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
<${FILESDIR}/pkg-message.in >${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
PLIST_FILES= lib/xmms/Output/libarts.so
.include <bsd.port.mk>

View File

@ -1,25 +0,0 @@
--- ltmain.sh.orig Wed Aug 6 19:13:39 2003
+++ ltmain.sh Tue Nov 11 22:47:49 2003
@@ -1075,7 +1075,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -1084,6 +1084,13 @@
deplibs="$deplibs $arg"
continue
;;
+
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
-module)
module=yes

View File

@ -1,16 +0,0 @@
In order to use aRts plugin on FreeBSD you must to do the following:
1) Move xmms binary to xmms.bin:
cd %%PREFIX%%/bin && mv xmms xmms.bin
2) Write custom xmms script:
--- cut here ---
#!/bin/sh
LD_PRELOAD=/usr/lib/libstdc++.so exec %%PREFIX%%/bin/xmms.bin "$@"
--- cut here ---
and put it to %%PREFIX%%/bin
/fjoe

View File

@ -1,3 +0,0 @@
lib/xmms/Output/libarts.a
lib/xmms/Output/libarts.la
lib/xmms/Output/libarts.so