emulators/mame emulators/mess: update to 0.222
ChangeLog way to big to reproduce here: https://github.com/mamedev/mame/releases/download/mame0222/whatsnew_0222.txt While here * Add USES=localbase * Move multiple variables to their places PR: 246698 Submitted by: sdalu@sdalu.com
This commit is contained in:
parent
b1cad76f99
commit
a324337731
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=543711
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME?= mame
|
||||
PORTVERSION= 0.212
|
||||
PORTVERSION= 0.222
|
||||
CATEGORIES= emulators
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
@ -20,43 +20,45 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
|
||||
libpugixml.so:textproc/pugixml
|
||||
RUN_DEPENDS= liberation-fonts-ttf>=0:x11-fonts/liberation-fonts-ttf
|
||||
|
||||
USES= compiler:c++14-lang gl gmake jpeg pkgconfig \
|
||||
USES= compiler:c++14-lang gl gmake jpeg localbase pkgconfig \
|
||||
python:2.7,build qt:5 sdl shebangfix xorg
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= mamedev
|
||||
GH_PROJECT= mame # explicit (master port)
|
||||
GH_TAGNAME= mame${PORTVERSION:S/.//}
|
||||
|
||||
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES
|
||||
USE_GL= gl
|
||||
USE_QT= buildtools core gui qmake_build widgets
|
||||
USE_SDL= sdl2 ttf2
|
||||
USE_XORG= x11 xext xi xinerama xrender
|
||||
|
||||
SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
|
||||
src/devices/cpu/m6809/m6809make.py \
|
||||
src/devices/cpu/mcs96/mcs96make.py \
|
||||
src/devices/cpu/tms57002/tmsmake.py
|
||||
USE_XORG= x11 xext xi xinerama xrender
|
||||
USE_GL= gl
|
||||
USE_SDL= sdl2 ttf2
|
||||
USE_QT= buildtools core gui qmake_build widgets
|
||||
MTARGET?= mame
|
||||
MSUBTARGET?= mame
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
|
||||
MAKEFILE= makefile
|
||||
MAKE_ARGS= TARGETOS=freebsd VERBOSE=1 TOOLS=1 USE_SYSTEM_LIB_PUGIXML=1
|
||||
MAKE_ENV= NOWERROR=1 USE_NETWORK=1 \
|
||||
LD="${CXX}" PYTHON="${PYTHON_CMD}" \
|
||||
OPT_FLAGS="${CXXFLAGS}" GCC_LDFLAGS="${LDFLAGS}" \
|
||||
TARGET="${MTARGET}" SUBTARGET="${MSUBTARGET}" FULLNAME="mame" SDL_NETWORK="pcap"
|
||||
MAKE_ARGS= TARGETOS=freebsd VERBOSE=1 TOOLS=1 USE_SYSTEM_LIB_PUGIXML=1
|
||||
MAKEFILE= makefile
|
||||
GENIE= ${WRKSRC}/3rdparty/genie
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= ${MSUBTARGET}.ini
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
SUB_FILES= pkg-message target.ini
|
||||
SUB_LIST= MTARGET=${MTARGET} MSUBTARGET=${MSUBTARGET}
|
||||
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= ${MSUBTARGET}.ini
|
||||
|
||||
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES
|
||||
|
||||
DEBUG_MAKE_ENV= DEBUG=1
|
||||
|
||||
GENIE= ${WRKSRC}/3rdparty/genie
|
||||
MSUBTARGET?= mame
|
||||
MTARGET?= mame
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${ARCH} == amd64 || ${ARCH} == powerpc64
|
||||
@ -113,7 +115,7 @@ do-install:
|
||||
.endif
|
||||
.if ${MSUBTARGET:Mmess}
|
||||
(cd ${WRKSRC} && ${INSTALL_PROGRAM} castool chdman floptool imgtool jedutil \
|
||||
ldresample ldverify nltool nlwav pngcmp regrep romcmp split src2html \
|
||||
ldresample ldverify nltool nlwav pngcmp regrep romcmp split \
|
||||
srcclean unidasm \
|
||||
${STAGEDIR}${PREFIX}/libexec/mess)
|
||||
.endif
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1565317830
|
||||
SHA256 (mamedev-mame-0.212-mame0212_GH0.tar.gz) = 3d3599c49626b240e98b1433c0813e11e471846154e8d29261d345cc78fc9a21
|
||||
SIZE (mamedev-mame-0.212-mame0212_GH0.tar.gz) = 148502748
|
||||
TIMESTAMP = 1595439090
|
||||
SHA256 (mamedev-mame-0.222-mame0222_GH0.tar.gz) = 3380b86d1bc5bc09f5bb4099f3833b6fba924a8bd189aac4dab149afba799ce7
|
||||
SIZE (mamedev-mame-0.222-mame0222_GH0.tar.gz) = 184379953
|
||||
|
@ -1,29 +0,0 @@
|
||||
--- 3rdparty/bx/include/bx/inline/endian.inl.orig 2019-04-24 05:00:38 UTC
|
||||
+++ 3rdparty/bx/include/bx/inline/endian.inl
|
||||
@@ -46,7 +46,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template <typename Ty>
|
||||
- inline Ty toLittleEndian(const Ty _in)
|
||||
+ inline Ty toLittleEndian(Ty _in)
|
||||
{
|
||||
#if BX_CPU_ENDIAN_BIG
|
||||
return endianSwap(_in);
|
||||
@@ -56,7 +56,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template <typename Ty>
|
||||
- inline Ty toBigEndian(const Ty _in)
|
||||
+ inline Ty toBigEndian(Ty _in)
|
||||
{
|
||||
#if BX_CPU_ENDIAN_LITTLE
|
||||
return endianSwap(_in);
|
||||
@@ -66,7 +66,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template <typename Ty>
|
||||
- inline Ty toHostEndian(const Ty _in, bool _fromLittleEndian)
|
||||
+ inline Ty toHostEndian(Ty _in, bool _fromLittleEndian)
|
||||
{
|
||||
#if BX_CPU_ENDIAN_LITTLE
|
||||
return _fromLittleEndian ? _in : endianSwap(_in);
|
@ -1,76 +0,0 @@
|
||||
--- 3rdparty/bx/include/bx/inline/readerwriter.inl.orig 2019-04-24 05:00:38 UTC
|
||||
+++ 3rdparty/bx/include/bx/inline/readerwriter.inl
|
||||
@@ -273,7 +273,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template<typename Ty>
|
||||
- int32_t read(ReaderI* _reader, Ty& _value, Error* _err)
|
||||
+ inline int32_t read(ReaderI* _reader, Ty& _value, Error* _err)
|
||||
{
|
||||
BX_ERROR_SCOPE(_err);
|
||||
BX_STATIC_ASSERT(isTriviallyCopyable<Ty>() );
|
||||
@@ -281,7 +281,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template<typename Ty>
|
||||
- int32_t readHE(ReaderI* _reader, Ty& _value, bool _fromLittleEndian, Error* _err)
|
||||
+ inline int32_t readHE(ReaderI* _reader, Ty& _value, bool _fromLittleEndian, Error* _err)
|
||||
{
|
||||
BX_ERROR_SCOPE(_err);
|
||||
BX_STATIC_ASSERT(isTriviallyCopyable<Ty>() );
|
||||
@@ -329,7 +329,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template<typename Ty>
|
||||
- int32_t write(WriterI* _writer, const Ty& _value, Error* _err)
|
||||
+ inline int32_t write(WriterI* _writer, const Ty& _value, Error* _err)
|
||||
{
|
||||
BX_ERROR_SCOPE(_err);
|
||||
BX_STATIC_ASSERT(isTriviallyCopyable<Ty>() );
|
||||
@@ -337,7 +337,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template<typename Ty>
|
||||
- int32_t writeLE(WriterI* _writer, const Ty& _value, Error* _err)
|
||||
+ inline int32_t writeLE(WriterI* _writer, const Ty& _value, Error* _err)
|
||||
{
|
||||
BX_ERROR_SCOPE(_err);
|
||||
BX_STATIC_ASSERT(isTriviallyCopyable<Ty>() );
|
||||
@@ -346,8 +346,14 @@ namespace bx
|
||||
return result;
|
||||
}
|
||||
|
||||
+ template<>
|
||||
+ inline int32_t writeLE(WriterI* _writer, const float& _value, Error* _err)
|
||||
+ {
|
||||
+ return writeLE(_writer, floatToBits(_value), _err);
|
||||
+ }
|
||||
+
|
||||
template<typename Ty>
|
||||
- int32_t writeBE(WriterI* _writer, const Ty& _value, Error* _err)
|
||||
+ inline int32_t writeBE(WriterI* _writer, const Ty& _value, Error* _err)
|
||||
{
|
||||
BX_ERROR_SCOPE(_err);
|
||||
BX_STATIC_ASSERT(isTriviallyCopyable<Ty>() );
|
||||
@@ -356,6 +362,12 @@ namespace bx
|
||||
return result;
|
||||
}
|
||||
|
||||
+ template<>
|
||||
+ inline int32_t writeBE(WriterI* _writer, const float& _value, Error* _err)
|
||||
+ {
|
||||
+ return writeBE(_writer, floatToBits(_value), _err);
|
||||
+ }
|
||||
+
|
||||
inline int64_t skip(SeekerI* _seeker, int64_t _offset)
|
||||
{
|
||||
return _seeker->seek(_offset, Whence::Current);
|
||||
@@ -392,7 +404,7 @@ namespace bx
|
||||
}
|
||||
|
||||
template<typename Ty>
|
||||
- int32_t peek(ReaderSeekerI* _reader, Ty& _value, Error* _err)
|
||||
+ inline int32_t peek(ReaderSeekerI* _reader, Ty& _value, Error* _err)
|
||||
{
|
||||
BX_ERROR_SCOPE(_err);
|
||||
BX_STATIC_ASSERT(isTriviallyCopyable<Ty>() );
|
@ -1,39 +0,0 @@
|
||||
--- 3rdparty/bx/include/bx/platform.h.orig 2019-04-24 05:00:38 UTC
|
||||
+++ 3rdparty/bx/include/bx/platform.h
|
||||
@@ -35,6 +35,7 @@
|
||||
#define BX_CRT_MINGW 0
|
||||
#define BX_CRT_MSVC 0
|
||||
#define BX_CRT_NEWLIB 0
|
||||
+#define BX_CRT_BSD 0
|
||||
|
||||
#ifndef BX_CRT_MUSL
|
||||
# define BX_CRT_MUSL 0
|
||||
@@ -232,6 +233,9 @@
|
||||
# elif defined(__apple_build_version__) || defined(__ORBIS__) || defined(__EMSCRIPTEN__) || defined(__llvm__)
|
||||
# undef BX_CRT_LIBCXX
|
||||
# define BX_CRT_LIBCXX 1
|
||||
+# elif BX_PLATFORM_BSD
|
||||
+# undef BX_CRT_BSD
|
||||
+# define BX_CRT_BSD 1
|
||||
# endif //
|
||||
|
||||
# if !BX_CRT_BIONIC \
|
||||
@@ -240,7 +244,8 @@
|
||||
&& !BX_CRT_MINGW \
|
||||
&& !BX_CRT_MSVC \
|
||||
&& !BX_CRT_MUSL \
|
||||
- && !BX_CRT_NEWLIB
|
||||
+ && !BX_CRT_NEWLIB \
|
||||
+ && !BX_CRT_BSD
|
||||
# undef BX_CRT_NONE
|
||||
# define BX_CRT_NONE 1
|
||||
# endif // BX_CRT_*
|
||||
@@ -371,6 +376,8 @@
|
||||
# define BX_CRT_NAME "Newlib"
|
||||
#elif BX_CRT_MUSL
|
||||
# define BX_CRT_NAME "musl libc"
|
||||
+#elif BX_CRT_BSD
|
||||
+# define BX_CRT_NAME "BSD"
|
||||
#elif BX_CRT_NONE
|
||||
# define BX_CRT_NAME "None"
|
||||
#else
|
@ -1,10 +0,0 @@
|
||||
--- 3rdparty/bx/include/bx/readerwriter.h.orig 2019-04-24 05:00:38 UTC
|
||||
+++ 3rdparty/bx/include/bx/readerwriter.h
|
||||
@@ -10,6 +10,7 @@
|
||||
#include "endian.h"
|
||||
#include "error.h"
|
||||
#include "filepath.h"
|
||||
+#include "math.h"
|
||||
#include "string.h"
|
||||
#include "uint32_t.h"
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- 3rdparty/bx/src/mutex.cpp.orig 2019-04-24 05:00:38 UTC
|
||||
+++ 3rdparty/bx/src/mutex.cpp
|
||||
@@ -16,6 +16,7 @@
|
||||
|| BX_PLATFORM_IOS \
|
||||
|| BX_PLATFORM_OSX \
|
||||
|| BX_PLATFORM_PS4 \
|
||||
+ || BX_PLATFORM_BSD \
|
||||
|| BX_PLATFORM_RPI
|
||||
# include <pthread.h>
|
||||
#elif BX_PLATFORM_WINDOWS \
|
@ -1,10 +0,0 @@
|
||||
--- 3rdparty/bx/src/thread.cpp.orig 2019-04-24 05:00:38 UTC
|
||||
+++ 3rdparty/bx/src/thread.cpp
|
||||
@@ -15,6 +15,7 @@
|
||||
|| BX_PLATFORM_IOS \
|
||||
|| BX_PLATFORM_OSX \
|
||||
|| BX_PLATFORM_PS4 \
|
||||
+ || BX_PLATFORM_BSD \
|
||||
|| BX_PLATFORM_RPI
|
||||
# include <pthread.h>
|
||||
# if defined(__FreeBSD__)
|
@ -1,34 +0,0 @@
|
||||
--- 3rdparty/bx/tests/readerwriter_test.cpp.orig 2019-07-24 09:54:15 UTC
|
||||
+++ 3rdparty/bx/tests/readerwriter_test.cpp
|
||||
@@ -0,0 +1,31 @@
|
||||
+/*
|
||||
+ * Copyright 2010-2019 Branimir Karadzic. All rights reserved.
|
||||
+ * License: https://github.com/bkaradzic/bx#license-bsd-2-clause
|
||||
+ */
|
||||
+
|
||||
+#include "test.h"
|
||||
+#include <bx/readerwriter.h>
|
||||
+
|
||||
+TEST_CASE("writeLE", "")
|
||||
+{
|
||||
+ bx::SizerWriter writer;
|
||||
+
|
||||
+ bx::Error err;
|
||||
+
|
||||
+ int32_t total = bx::writeLE(&writer, 1.0f, &err);
|
||||
+
|
||||
+ REQUIRE(err.isOk() );
|
||||
+ REQUIRE(total == 4);
|
||||
+}
|
||||
+
|
||||
+TEST_CASE("writeBE", "")
|
||||
+{
|
||||
+ bx::SizerWriter writer;
|
||||
+
|
||||
+ bx::Error err;
|
||||
+
|
||||
+ int32_t total = bx::writeBE(&writer, 1.0f, &err);
|
||||
+
|
||||
+ REQUIRE(err.isOk() );
|
||||
+ REQUIRE(total == 4);
|
||||
+}
|
@ -1,11 +0,0 @@
|
||||
--- 3rdparty/genie/src/host/scripts.c.orig 2019-08-02 19:05:18 UTC
|
||||
+++ 3rdparty/genie/src/host/scripts.c
|
||||
@@ -220,7 +220,7 @@ const char* builtin_scripts[] = {
|
||||
/* actions/make/make_cpp.lua */
|
||||
"premake.make.cpp = { }\npremake.make.override = { }\npremake.make.makefile_ignore = false\nlocal cpp = premake.make.cpp\nlocal make = premake.make\nfunction premake.make_cpp(prj)\nlocal cc = premake.gettool(prj)\nlocal platforms = premake.filterplatforms(prj.solution, cc.platforms, \"Native\")\npremake.gmake_cpp_header(prj, cc, platforms)\nfor _, platform in ipairs(platforms) do\nfor cfg in premake.eachconfig(prj, platform) do\npremake.gmake_cpp_config(prj, cfg, cc)\nend\nend\ntable.sort(prj.allfiles)\nlocal objdirs = {}\nlocal additionalobjdirs = {}\nfor _, file in ipairs(prj.allfiles) do\nif path.issourcefile(file) then\nobjdirs[_MAKE.esc(path.getdirectory(path.trimdots(file)))] = 1\nend\nend\nfor _, custombuildtask in ipairs(prj.custombuildtask or {}) do\nfor _, buildtask in ipairs(custombuildtask or {}) do\nadditionalobjdirs[_MAKE.esc(path.getdirectory(path.getrelative(prj.location,buildtask[2])))] = 1\nend\nend\n_p('OBJDIRS := \\\\')\n_p('\\t$(OBJDIR) \\\\')\nfor dir, _ in iter.sortByKeys(objdirs) do\n_p("
|
||||
"'\\t$(OBJDIR)/%s \\\\', dir)\nend\nfor dir, _ in iter.sortByKeys(additionalobjdirs) do\n_p('\\t%s \\\\', dir)\nend\n_p('')\n_p('RESOURCES := \\\\')\nfor _, file in ipairs(prj.allfiles) do\nif path.isresourcefile(file) then\n_p('\\t$(OBJDIR)/%s.res \\\\', _MAKE.esc(path.getbasename(file)))\nend\nend\n_p('')\n_p('.PHONY: clean prebuild prelink')\n_p('')\nif os.is(\"MacOSX\") and prj.kind == \"WindowedApp\" then\n_p('all: $(OBJDIRS) $(TARGETDIR) prebuild prelink $(TARGET) $(dir $(TARGETDIR))PkgInfo $(dir $(TARGETDIR))Info.plist')\nelse\n_p('all: $(OBJDIRS) $(TARGETDIR) prebuild prelink $(TARGET)')\nend\n_p('\\t@:')\n_p('')\nif (prj.kind == \"StaticLib\" and prj.options.ArchiveSplit) then\n_p('define max_args')\n_p('\\t$(eval _args:=)')\n_p('\\t$(foreach obj,$3,$(eval _args+=$(obj))$(if $(word $2,$(_args)),$1$(_args)$(EOL)$(eval _args:=)))')\n_p('\\t$(if $(_args),$1$(_args))')\n_p('endef')\n_p('')\n_p('define EOL')\n_p('')\n_p('')\n_p('endef')\n_p('')\nend\n_p('$(TARGET): $(GCH) $(OBJECTS) $(LDDEPS) $(EXTERNAL_LIB"
|
||||
- "S) $(RESOURCES) | $(TARGETDIR) $(OBJDIRS)')\nif prj.kind == \"StaticLib\" then\nif prj.msgarchiving then\n_p('\\t@echo ' .. prj.msgarchiving)\nelse\n_p('\\t@echo Archiving %s', prj.name)\nend\nif (not prj.archivesplit_size) then\nprj.archivesplit_size=200\nend\nif (not prj.options.ArchiveSplit) then\n_p('ifeq (posix,$(SHELLTYPE))')\n_p('\\t$(SILENT) rm -f $(TARGET)')\n_p('else')\n_p('\\t$(SILENT) if exist $(subst /,\\\\\\\\,$(TARGET)) del $(subst /,\\\\\\\\,$(TARGET))')\n_p('endif')\n_p('\\t$(SILENT) $(LINKCMD) $(OBJECTS)' .. (os.is(\"MacOSX\") and \" 2>&1 > /dev/null | sed -e '/.o) has no symbols$$/d'\" or \"\"))\nelse\n_p('\\t$(call RM,$(TARGET))')\n_p('\\t@$(call max_args,$(LINKCMD),'.. prj.archivesplit_size ..',$(OBJECTS))' .. (os.is(\"MacOSX\") and \" 2>&1 > /dev/null | sed -e '/.o) has no symbols$$/d'\" or \"\"))\n_p('\\t$(SILENT) $(LINKCMD_NDX)')\nend\nelse\nif prj.msglinking then\n_p('\\t@echo ' .. prj.msglinking)\nelse\n_p('\\t@echo Linking %s', prj.name)\nend\n_p('\\t$(SILENT) $(LINKCMD)')\nend\n_p("
|
||||
+ "S) $(RESOURCES) | $(TARGETDIR) $(OBJDIRS)')\nif prj.kind == \"StaticLib\" then\nif prj.msgarchiving then\n_p('\\t@echo ' .. prj.msgarchiving)\nelse\n_p('\\t@echo Archiving %s', prj.name)\nend\nif (not prj.archivesplit_size) then\nprj.archivesplit_size=200\nend\nif (not prj.options.ArchiveSplit) then\n_p('ifeq (posix,$(SHELLTYPE))')\n_p('\\t$(SILENT) rm -f $(TARGET)')\n_p('else')\n_p('\\t$(SILENT) if exist $(subst /,\\\\\\\\,$(TARGET)) del $(subst /,\\\\\\\\,$(TARGET))')\n_p('endif')\n_p('\\t$(SILENT) $(LINKCMD) $(OBJECTS)' .. (os.is(\"MacOSX\") and \" 2>&1 > /dev/null | sed -e '/.o) has no symbols$$/d'\" or \"\"))\nelse\n_p('\\t$(call RM,$(TARGET))')\n_p('\\t@$(call max_args,$(LINKCMD) ,'.. prj.archivesplit_size ..',$(OBJECTS))' .. (os.is(\"MacOSX\") and \" 2>&1 > /dev/null | sed -e '/.o) has no symbols$$/d'\" or \"\"))\n_p('\\t$(SILENT) $(LINKCMD_NDX)')\nend\nelse\nif prj.msglinking then\n_p('\\t@echo ' .. prj.msglinking)\nelse\n_p('\\t@echo Linking %s', prj.name)\nend\n_p('\\t$(SILENT) $(LINKCMD)')\nend\n_p("
|
||||
"'\\t$(POSTBUILDCMDS)')\n_p('')\n_p('$(TARGETDIR):')\npremake.make_mkdirrule(\"$(TARGETDIR)\")\n_p('$(OBJDIRS):')\nif (not prj.solution.messageskip) or (not table.contains(prj.solution.messageskip, \"SkipCreatingMessage\")) then\n_p('\\t@echo Creating $(@)')\nend\n_p('\\t-$(call MKDIR,$@)')\n_p('')\nif os.is(\"MacOSX\") and prj.kind == \"WindowedApp\" then\n_p('$(dir $(TARGETDIR))PkgInfo:')\n_p('$(dir $(TARGETDIR))Info.plist:')\n_p('')\nend\n_p('clean:')\nif (not prj.solution.messageskip) or (not table.contains(prj.solution.messageskip, \"SkipCleaningMessage\")) then\n_p('\\t@echo Cleaning %s', prj.name)\nend\n_p('ifeq (posix,$(SHELLTYPE))')\n_p('\\t$(SILENT) rm -f $(TARGET)')\n_p('\\t$(SILENT) rm -rf $(OBJDIR)')\n_p('else')\n_p('\\t$(SILENT) if exist $(subst /,\\\\\\\\,$(TARGET)) del $(subst /,\\\\\\\\,$(TARGET))')\n_p('\\t$(SILENT) if exist $(subst /,\\\\\\\\,$(OBJDIR)) rmdir /s /q $(subst /,\\\\\\\\,$(OBJDIR))')\n_p('endif')\n_p('')\n_p('prebuild:')\n_p('\\t$(PREBUILDCMDS)')\n_p('')\n_p('prelink:')\n_p('\\t"
|
||||
"$(PRELINKCMDS)')\n_p('')\ncpp.pchrules(prj)\ncpp.fileRules(prj, cc)\ncpp.dependencyRules(prj)\nfor _, custombuildtask in ipairs(prj.custombuildtask or {}) do\nfor _, buildtask in ipairs(custombuildtask or {}) do\nlocal deps = string.format(\"%s \",path.getrelative(prj.location,buildtask[1]))\nfor _, depdata in ipairs(buildtask[3] or {}) do\ndeps = deps .. string.format(\"%s \",path.getrelative(prj.location,depdata))\nend\n_p('%s: %s | $(TARGETDIR) $(OBJDIRS)'\n,path.getrelative(prj.location,buildtask[2])\n, deps\n)\nfor _, cmdline in ipairs(buildtask[4] or {}) do\nlocal cmd = cmdline\nlocal num = 1\nfor _, depdata in ipairs(buildtask[3] or {}) do\ncmd = string.gsub(cmd,\"%$%(\" .. num ..\"%)\", string.format(\"%s \",path.getrelative(prj.location,depdata)))\nnum = num + 1\nend\ncmd = string.gsub(cmd, \"%$%(<%)\", \"$<\")\ncmd = string.gsub(cmd, \"%$%(@%)\", \"$@\")\n_p('\\t$(SILENT) %s',cmd)\nend\n_p('')\nend\nend\n_p('-include $(OBJECTS:%%.o=%%.d)')\n_p('ifneq (,$(PCH))')\n_p(' -include $(OBJDIR)/$(notdir $("
|
||||
"PCH)).d')\n_p(' -include $(OBJDIR)/$(notdir $(PCH))_objc.d')\n_p('endif')\nend\nfunction premake.gmake_cpp_header(prj, cc, platforms)\n_p('# %s project makefile autogenerated by GENie', premake.action.current().shortname)\n_p('ifndef config')\n_p(' config=%s', _MAKE.esc(premake.getconfigname(prj.solution.configurations[1], platforms[1], true)))\n_p('endif')\n_p('')\n_p('ifndef verbose')\n_p(' SILENT = @')\n_p('endif')\n_p('')\n_p('SHELLTYPE := msdos')\n_p('ifeq (,$(ComSpec)$(COMSPEC))')\n_p(' SHELLTYPE := posix')\n_p('endif')\n_p('ifeq (/bin,$(findstring /bin,$(SHELL)))')\n_p(' SHELLTYPE := posix')\n_p('endif')\n_p('ifeq (/bin,$(findstring /bin,$(MAKESHELL)))')\n_p(' SHELLTYPE := posix')\n_p('endif')\n_p('')\n_p('ifeq (posix,$(SHELLTYPE))')\n_p(' MKDIR = $(SILENT) mkdir -p \"$(1)\"')\n_p(' COPY = $(SILENT) cp -fR \"$(1)\" \"$(2)\"')\n_p(' RM = $(SILENT) rm -f \"$(1)\"')\n_p('else')\n_p(' MKDIR = $(SILENT) mkdir \"$(subst /,\\\\\\\\,$(1))\" 2> nul || exit 0')\n_p(' COPY = $(SILENT) copy /Y \"$(s"
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user