science/py-pymol: Update 2.4.0 -> 2.5.0-97
This commit is contained in:
parent
d4bf27c2e0
commit
a2b852ee70
@ -1,7 +1,7 @@
|
||||
PORTNAME= pymol
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.4.0
|
||||
PORTREVISION= 7
|
||||
DISTVERSION= 2.5.0-97
|
||||
DISTVERSIONSUFFIX= -gd24468af
|
||||
CATEGORIES= science biology python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
@ -25,23 +25,25 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>0:devel/py-msgpack@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}Pmw>0:x11-toolkits/py-Pmw@${PY_FLAVOR} \
|
||||
${PYNUMPY}
|
||||
|
||||
USES= compiler:c++11-lang gl gnome python:3.5+ shebangfix tar:bz2
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= schrodinger
|
||||
GH_PROJECT= ${PORTNAME}-open-source
|
||||
USES= compiler:c++11-lang gl gnome python:3.5+ tar:bz2
|
||||
USE_GL= gl glew glu glut
|
||||
USE_GNOME= libxml2
|
||||
USE_PYTHON= distutils concurrent # autoplist is broken: https://github.com/schrodinger/pymol-open-source/issues/99
|
||||
SHEBANG_FILES= test/show test/run test/cyg
|
||||
|
||||
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}chempy # https://github.com/schrodinger/pymol-open-source/issues/100
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= schrodinger
|
||||
GH_PROJECT= ${PORTNAME}-open-source
|
||||
|
||||
OPTIONS_SINGLE= GUI
|
||||
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}chempy # chempy port is unrelated, see https://github.com/schrodinger/pymol-open-source/issues/100
|
||||
|
||||
CXXFLAGS+= -DMSGPACK_NO_BOOST # in line with MSGPACK_USE_BOOST=OFF in devel/msgpack-cxx
|
||||
|
||||
OPTIONS_SINGLE= GUI
|
||||
OPTIONS_SINGLE_GUI= QT5 TK
|
||||
OPTIONS_DEFAULT= QT5
|
||||
|
||||
QT5_USES= pyqt:5
|
||||
QT5_USE= PYQT=pyqt5:run
|
||||
QT5_USES= pyqt:5
|
||||
QT5_USE= PYQT=pyqt5:run
|
||||
|
||||
post-patch-TK-on:
|
||||
@${REINPLACE_CMD} -e ' \
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1590042797
|
||||
SHA256 (schrodinger-pymol-open-source-v2.4.0_GH0.tar.gz) = 5ede4ce2e8f53713c5ee64f5905b2d29bf01e4391da7e536ce8909d6b9116581
|
||||
SIZE (schrodinger-pymol-open-source-v2.4.0_GH0.tar.gz) = 10552539
|
||||
TIMESTAMP = 1669581024
|
||||
SHA256 (schrodinger-pymol-open-source-v2.5.0-97-gd24468af_GH0.tar.gz) = 801e8e71a02c56c07aacd241044e397586a435a4435b74845d779d9846c994af
|
||||
SIZE (schrodinger-pymol-open-source-v2.5.0-97-gd24468af_GH0.tar.gz) = 10495556
|
||||
|
20
science/py-pymol/files/patch-layer0_MemoryUsage.cpp
Normal file
20
science/py-pymol/files/patch-layer0_MemoryUsage.cpp
Normal file
@ -0,0 +1,20 @@
|
||||
--- layer0/MemoryUsage.cpp.orig 2022-11-27 20:14:03 UTC
|
||||
+++ layer0/MemoryUsage.cpp
|
||||
@@ -51,6 +51,8 @@ size_t memory_usage()
|
||||
GetProcessMemoryInfo(hProcess.get(), &pmc, sizeof(pmc));
|
||||
}
|
||||
return pmc.WorkingSetSize;
|
||||
+#elif defined(__FreeBSD__)
|
||||
+ return 0; // TODO implement memory_usage()
|
||||
#else
|
||||
#error "platform not handled"
|
||||
#endif
|
||||
@@ -92,6 +94,8 @@ size_t memory_available()
|
||||
statex.dwLength = sizeof(statex);
|
||||
GlobalMemoryStatusEx(&statex);
|
||||
return statex.ullAvailPhys;
|
||||
+#elif defined(__FreeBSD__)
|
||||
+ return 0; // TODO: implement memory_available()
|
||||
#else
|
||||
#error "platform not handled"
|
||||
#endif
|
@ -1,20 +0,0 @@
|
||||
--- modules/pymol/Qt/__init__.py.orig 2019-02-11 14:08:10 UTC
|
||||
+++ modules/pymol/Qt/__init__.py
|
||||
@@ -29,7 +29,7 @@ if not PYQT_NAME:
|
||||
if DEBUG:
|
||||
print('import PyQt5 failed')
|
||||
|
||||
-if not PYQT_NAME:
|
||||
+if False:
|
||||
try:
|
||||
from PySide2 import QtGui, QtCore, QtOpenGL, QtWidgets
|
||||
PYQT_NAME = 'PySide2'
|
||||
@@ -46,7 +46,7 @@ if not PYQT_NAME:
|
||||
if DEBUG:
|
||||
print('import PyQt4 failed')
|
||||
|
||||
-if not PYQT_NAME:
|
||||
+if False:
|
||||
try:
|
||||
from PySide import QtGui, QtCore, QtOpenGL
|
||||
PYQT_NAME = 'PySide'
|
@ -1,6 +1,6 @@
|
||||
--- setup.py.orig 2019-02-12 06:00:47 UTC
|
||||
--- setup.py.orig 2021-05-10 18:38:37 UTC
|
||||
+++ setup.py
|
||||
@@ -52,6 +52,8 @@ try:
|
||||
@@ -53,6 +53,8 @@ try:
|
||||
"shared library; no: disable fast MMTF load support")
|
||||
parser.add_argument('--help-distutils', action="store_true",
|
||||
help="show help for distutils options and exit")
|
||||
@ -8,4 +8,13 @@
|
||||
+ help="single-version-externally-managed")
|
||||
parser.add_argument('--testing', action="store_true",
|
||||
help="Build C-level tests")
|
||||
options, sys.argv[1:] = parser.parse_known_args(namespace=options)
|
||||
parser.add_argument('--openvr', dest='openvr', action='store_true')
|
||||
@@ -282,7 +284,7 @@ if DEBUG and not WIN:
|
||||
libs = ["png", "freetype"]
|
||||
lib_dirs = []
|
||||
ext_comp_args = [
|
||||
- "-Werror=return-type",
|
||||
+ #"-Werror=return-type",
|
||||
"-Wunused-variable",
|
||||
"-Wno-switch",
|
||||
"-Wno-narrowing",
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user