* Updated to 0.9.3
* Cleanup Makefile * Regenerated patch for portlint Changes: https://github.com/neutrinolabs/xrdp/releases/tag/v0.9.3Changes: https://github.com/neutrinolabs/xrdp/releases/tag/v0.9.3 PR: 220820 Submitted by: Koichiro IWAO (maintainer) Reviewed by: lifanov (mentor) Approved by: lifanov (mentor) MFH: 2017Q3 Differential Revision: https://reviews.freebsd.org/D11956
This commit is contained in:
parent
d3cfebc9c9
commit
a2b665648b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=447713
@ -2,9 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xrdp
|
||||
PORTVERSION= 0.9.1
|
||||
PORTVERSION= 0.9.3
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
PKGNAMESUFFIX= -devel
|
||||
@ -28,9 +27,9 @@ USE_LDCONFIG= ${PREFIX}/lib/xrdp
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= neutrinolabs
|
||||
GH_PROJECT= xrdp librfxcodec:librfxcodec libpainter:libpainter
|
||||
GH_TAGNAME= v0.1.0:librfxcodec v0.1.0:libpainter
|
||||
GH_TAGNAME= v0.1.2:librfxcodec v0.1.1:libpainter
|
||||
|
||||
CONFIGURE_ARGS= --localstatedir=/var \
|
||||
CONFIGURE_ARGS= --localstatedir=/var --enable-strict-locations \
|
||||
--with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig \
|
||||
--enable-jpeg --enable-pixman --enable-rfxcodec --enable-painter
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -L${OPENSSLLIB} -lssl
|
||||
@ -49,6 +48,7 @@ OPUS_DESC= Enable Opus for audio redirection
|
||||
IPV6_CONFIGURE_ENABLE= ipv6
|
||||
DEBUG_CONFIGURE_ENABLE= xrdpdebug
|
||||
FUSE_CONFIGURE_ENABLE= fuse
|
||||
FUSE_USES= fuse
|
||||
MP3LAME_CONFIGURE_ENABLE= mp3lame
|
||||
MP3LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
|
||||
OPUS_CONFIGURE_ENABLE= opus
|
||||
@ -58,12 +58,6 @@ OPUS_LIB_DEPENDS= libopus.so:audio/opus
|
||||
PULSE_VERSION= ${MAKE} -C ${PORTSDIR}/audio/pulseaudio -VPORTVERSION
|
||||
PULSE_WRKSRC= ${MAKE} -C ${PORTSDIR}/audio/pulseaudio -VWRKSRC
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MFUSE}
|
||||
USES+= fuse
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
# librfxcodec is provided as git submodule
|
||||
@${CP} -r ${WRKSRC_librfxcodec}/ ${WRKSRC}/librfxcodec/
|
||||
@ -100,7 +94,7 @@ post-stage:
|
||||
@${RM} ${STAGEDIR}${PREFIX}/etc/xrdp/rsakeys.ini
|
||||
@${RM} ${STAGEDIR}${PREFIX}/etc/xrdp/cert.pem
|
||||
@${RM} ${STAGEDIR}${PREFIX}/etc/xrdp/key.pem
|
||||
.for f in sesman.ini startwm.sh xrdp.ini xrdp_keyboard.ini
|
||||
.for f in sesman.ini startwm.sh reconnectwm.sh xrdp.ini xrdp_keyboard.ini
|
||||
@${MV} ${STAGEDIR}${PREFIX}/etc/xrdp/$f ${STAGEDIR}${PREFIX}/etc/xrdp/$f.sample
|
||||
.endfor
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
TIMESTAMP = 1482726509
|
||||
SHA256 (xrdp/neutrinolabs-xrdp-v0.9.1_GH0.tar.gz) = 9bfafb0277b07e8242bfdbede2928423d28c5714efb0c226118759fab06c42ab
|
||||
SIZE (xrdp/neutrinolabs-xrdp-v0.9.1_GH0.tar.gz) = 1885192
|
||||
SHA256 (xrdp/neutrinolabs-librfxcodec-v0.1.0_GH0.tar.gz) = b05c1812e2daef373bf5e647bc86ee11f136adbe7ea999b5109180f406071f0a
|
||||
SIZE (xrdp/neutrinolabs-librfxcodec-v0.1.0_GH0.tar.gz) = 38590
|
||||
SHA256 (xrdp/neutrinolabs-libpainter-v0.1.0_GH0.tar.gz) = 9fd2a3a85ba4f3e311cea34e9824bd38f3673e60951906c06744cf6b8f73397a
|
||||
SIZE (xrdp/neutrinolabs-libpainter-v0.1.0_GH0.tar.gz) = 9859
|
||||
TIMESTAMP = 1500361123
|
||||
SHA256 (xrdp/neutrinolabs-xrdp-v0.9.3_GH0.tar.gz) = 36f096d013b2cf09324cc1bf9c27caadc733001f2bcbe24e67f93233260afe5b
|
||||
SIZE (xrdp/neutrinolabs-xrdp-v0.9.3_GH0.tar.gz) = 1866654
|
||||
SHA256 (xrdp/neutrinolabs-librfxcodec-v0.1.2_GH0.tar.gz) = f4aa7f4247a42f6f5e49fc56eb70589a1d26cae7c8d5d4e32f75200d5c473a42
|
||||
SIZE (xrdp/neutrinolabs-librfxcodec-v0.1.2_GH0.tar.gz) = 46139
|
||||
SHA256 (xrdp/neutrinolabs-libpainter-v0.1.1_GH0.tar.gz) = 6caee8444fbd72677ac5e125c7ac99490688474975451668e751a9d9187ee5e6
|
||||
SIZE (xrdp/neutrinolabs-libpainter-v0.1.1_GH0.tar.gz) = 13929
|
||||
|
@ -1,22 +1,40 @@
|
||||
diff --git configure.ac configure.ac
|
||||
index 5c73168a..abbf4135 100644
|
||||
--- configure.ac
|
||||
--- configure.ac.orig 2017-07-14 12:22:02 UTC
|
||||
+++ configure.ac
|
||||
@@ -138,8 +138,15 @@ AC_CHECK_FUNC(dlopen, [],
|
||||
@@ -152,11 +152,35 @@ AC_CHECK_FUNC(dlopen, [],
|
||||
AC_SUBST(DLOPEN_LIBS)
|
||||
|
||||
|
||||
# checking for openssl
|
||||
-PKG_CHECK_MODULES([OPENSSL], [openssl >= 0], [],
|
||||
- [AC_MSG_ERROR([please install libssl-dev or openssl-devel])])
|
||||
-PKG_CHECK_MODULES([OPENSSL], [openssl >= 0.9.8], [],
|
||||
+if test "x$freebsd" = "xyes"; then
|
||||
+ # FreeBSD base doesn't supply "*.pc"
|
||||
+ AC_CHECK_HEADER([openssl/rc4.h], [],
|
||||
+ [AC_MSG_ERROR([please install libssl-dev or openssl-devel])],
|
||||
+ [#include <stdlib.h>])
|
||||
+ # FreeBSD may have two OpenSSL, base and port however
|
||||
+ # base OpenSSL doesn.t have openssl.pc file.
|
||||
+ PKG_CHECK_MODULES(
|
||||
+ [OPENSSL],
|
||||
+ [openssl >= 0],
|
||||
+ [freebsd_openssl=port],
|
||||
+ [
|
||||
+ AC_CHECK_HEADER(
|
||||
+ [openssl/rc4.h],
|
||||
+ [freebsd_openssl=base],
|
||||
+ [AC_MSG_ERROR([please install libssl-dev or openssl-devel])],
|
||||
+ [#include <stdlib.h>])
|
||||
+ ]
|
||||
+ )
|
||||
+
|
||||
+ if test "x$freebsd_openssl" = "xport"; then
|
||||
+ OPENSSL_BIN=`$PKG_CONFIG --variable=exec_prefix openssl`/bin
|
||||
+ elif test "x$freebsd_openssl" = "xbase"; then
|
||||
+ OPENSSL_BIN=/usr/bin
|
||||
+ fi
|
||||
+else
|
||||
+ # OpenSSL detection for other OS
|
||||
+ PKG_CHECK_MODULES([OPENSSL], [openssl >= 0], [],
|
||||
+ [AC_MSG_ERROR([please install libssl-dev or openssl-devel])])
|
||||
[AC_MSG_ERROR([please install libssl-dev or openssl-devel])])
|
||||
+ OPENSSL_BIN=`$PKG_CONFIG --variable=exec_prefix openssl`/bin
|
||||
+fi
|
||||
|
||||
|
||||
# look for openssl binary
|
||||
-OPENSSL_BIN=`$PKG_CONFIG --variable=exec_prefix openssl`/bin
|
||||
AC_PATH_PROGS([OPENSSL], [openssl], [:], [$OPENSSL_BIN:$PATH])
|
||||
|
||||
# checking for pam variation
|
||||
# Linux-PAM is used in Linux systems
|
||||
|
@ -1,8 +1,6 @@
|
||||
diff --git sesman/sesman.ini sesman/sesman.ini
|
||||
index 674665e9..45929d6d 100644
|
||||
--- sesman/sesman.ini
|
||||
--- sesman/sesman.ini.orig 2017-07-14 12:22:02 UTC
|
||||
+++ sesman/sesman.ini
|
||||
@@ -84,8 +84,8 @@ param=xrdp/xorg.conf
|
||||
@@ -77,8 +77,8 @@ param=xrdp/xorg.conf
|
||||
param=-noreset
|
||||
param=-nolisten
|
||||
param=tcp
|
||||
@ -10,6 +8,6 @@ index 674665e9..45929d6d 100644
|
||||
-param=.xorgxrdp.%s.log
|
||||
+#param=-logfile
|
||||
+#param=.xorgxrdp.%s.log
|
||||
|
||||
|
||||
[Chansrv]
|
||||
; drive redirection, defaults to xrdp_client if not set
|
||||
|
@ -1,34 +0,0 @@
|
||||
--- xrdp/xrdp.ini.orig 2016-12-22 17:04:29 UTC
|
||||
+++ xrdp/xrdp.ini
|
||||
@@ -147,24 +147,24 @@ tcutils=true
|
||||
; Session types
|
||||
;
|
||||
|
||||
-[X11rdp]
|
||||
-name=X11rdp
|
||||
+[Xorg]
|
||||
+name=Xorg
|
||||
lib=libxup.so
|
||||
username=ask
|
||||
password=ask
|
||||
ip=127.0.0.1
|
||||
port=-1
|
||||
-xserverbpp=24
|
||||
-code=10
|
||||
+code=20
|
||||
|
||||
-[Xorg]
|
||||
-name=Xorg
|
||||
+[X11rdp]
|
||||
+name=X11rdp
|
||||
lib=libxup.so
|
||||
username=ask
|
||||
password=ask
|
||||
ip=127.0.0.1
|
||||
port=-1
|
||||
-code=20
|
||||
+xserverbpp=24
|
||||
+code=10
|
||||
|
||||
[Xvnc]
|
||||
name=Xvnc
|
@ -3,7 +3,6 @@ bin/xrdp-genkeymap
|
||||
bin/xrdp-keygen
|
||||
bin/xrdp-sesadmin
|
||||
bin/xrdp-sesrun
|
||||
bin/rfxcodectest
|
||||
lib/libpainter.a
|
||||
lib/libpainter.so
|
||||
lib/libpainter.so.0
|
||||
@ -19,6 +18,7 @@ include/rfxcodec_encode.h
|
||||
include/xrdp_client_info.h
|
||||
include/xrdp_constants.h
|
||||
include/xrdp_rail.h
|
||||
include/xrdp_sockets.h
|
||||
lib/pulse-%%PULSE_VERSION%%/modules/module-xrdp-sink.so
|
||||
lib/pulse-%%PULSE_VERSION%%/modules/module-xrdp-source.so
|
||||
libdata/pkgconfig/libpainter.pc
|
||||
@ -30,28 +30,18 @@ lib/xrdp/libcommon.so.0
|
||||
lib/xrdp/libcommon.so.0.0.0
|
||||
lib/xrdp/libmc.a
|
||||
lib/xrdp/libmc.so
|
||||
lib/xrdp/libmc.so.0
|
||||
lib/xrdp/libmc.so.0.0.0
|
||||
lib/xrdp/librdp.a
|
||||
lib/xrdp/librdp.so
|
||||
lib/xrdp/librdp.so.0
|
||||
lib/xrdp/librdp.so.0.0.0
|
||||
lib/xrdp/libscp.a
|
||||
lib/xrdp/libscp.so
|
||||
lib/xrdp/libscp.so.0
|
||||
lib/xrdp/libscp.so.0.0.0
|
||||
lib/xrdp/libvnc.a
|
||||
lib/xrdp/libvnc.so
|
||||
lib/xrdp/libvnc.so.0
|
||||
lib/xrdp/libvnc.so.0.0.0
|
||||
lib/xrdp/libxrdp.a
|
||||
lib/xrdp/libxrdp.so
|
||||
lib/xrdp/libxrdp.so.0
|
||||
lib/xrdp/libxrdp.so.0.0.0
|
||||
lib/xrdp/libxup.a
|
||||
lib/xrdp/libxup.so
|
||||
lib/xrdp/libxup.so.0
|
||||
lib/xrdp/libxup.so.0.0.0
|
||||
lib/xrdp/libxrdpapi.so
|
||||
lib/xrdp/libxrdpapi.a
|
||||
lib/xrdp/libxrdpapi.so.0
|
||||
@ -80,10 +70,12 @@ etc/rc.d/xrdp
|
||||
%%ETCDIR%%/pulse/default.pa
|
||||
@postunexec if cmp -s %D/etc/xrdp/sesman.ini.sample %D/etc/xrdp/sesman.ini; then rm -f %D/etc/xrdp/sesman.ini; fi
|
||||
@postunexec if cmp -s %D/etc/xrdp/startwm.sh.sample %D/etc/xrdp/startwm.sh; then rm -f %D/etc/xrdp/startwm.sh; fi
|
||||
@postunexec if cmp -s %D/etc/xrdp/reconnectwm.sh.sample %D/etc/xrdp/reconnectwm.sh; then rm -f %D/etc/xrdp/reconnectwm.sh; fi
|
||||
@postunexec if cmp -s %D/etc/xrdp/xrdp.ini.sample %D/etc/xrdp/xrdp.ini; then rm -f %D/etc/xrdp/xrdp.ini; fi
|
||||
@postunexec if cmp -s %D/etc/xrdp/xrdp_keyboard.ini.sample %D/etc/xrdp/xrdp_keyboard.ini; then rm -f %D/etc/xrdp/xrdp_keyboard.ini; fi
|
||||
@sample %%ETCDIR%%/sesman.ini.sample
|
||||
@sample %%ETCDIR%%/startwm.sh.sample
|
||||
@sample %%ETCDIR%%/reconnectwm.sh.sample
|
||||
@sample %%ETCDIR%%/xrdp.ini.sample
|
||||
@sample %%ETCDIR%%/xrdp_keyboard.ini.sample
|
||||
man/man1/xrdp-dis.1.gz
|
||||
@ -96,11 +88,9 @@ man/man8/xrdp-keygen.8.gz
|
||||
man/man8/xrdp-sesadmin.8.gz
|
||||
man/man8/xrdp-sesman.8.gz
|
||||
man/man8/xrdp-sesrun.8.gz
|
||||
man/man8/xrdp-sessvc.8.gz
|
||||
sbin/xrdp
|
||||
sbin/xrdp-chansrv
|
||||
sbin/xrdp-sesman
|
||||
sbin/xrdp-sessvc
|
||||
%%DATADIR%%/ad24b.bmp
|
||||
%%DATADIR%%/ad256.bmp
|
||||
%%DATADIR%%/cursor0.cur
|
||||
|
Loading…
Reference in New Issue
Block a user