- Fix build with FreeBSD 5.X
PR: 113966 Submitted by: Alex Samorukov <samm@os2.kiev.ua> (maintainer)
This commit is contained in:
parent
300f5b86ad
commit
a29062c6d6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194167
13
mail/spamd/files/patch-makefile
Normal file
13
mail/spamd/files/patch-makefile
Normal file
@ -0,0 +1,13 @@
|
||||
--- spamlogd/Makefile.old Mon Apr 2 01:33:46 2007
|
||||
+++ spamlogd/Makefile Sat Jun 23 15:29:03 2007
|
||||
@@ -4,6 +4,10 @@
|
||||
SRCS= spamlogd.c sync.c
|
||||
MAN= spamlogd.8
|
||||
|
||||
+.if ${OSVERSION} < 601000
|
||||
+SRCS+= ../spamd/strtonum.c
|
||||
+.endif
|
||||
+
|
||||
CFLAGS+= -Wall -Wstrict-prototypes -I${.CURDIR}/../spamd
|
||||
LDADD+= -lpcap -lcrypto -lmd
|
||||
DPADD+= ${LIBPCAP} ${LIBMD}
|
15
mail/spamd/files/patch-spamlogd
Normal file
15
mail/spamd/files/patch-spamlogd
Normal file
@ -0,0 +1,15 @@
|
||||
--- spamlogd/spamlogd.c.orig Sat Jun 23 15:28:14 2007
|
||||
+++ spamlogd/spamlogd.c Sat Jun 23 15:28:27 2007
|
||||
@@ -158,10 +158,12 @@
|
||||
|
||||
pcap_freecode(&bpfp);
|
||||
|
||||
+#ifdef BIOLOCK
|
||||
if (ioctl(pcap_fileno(hpcap), BIOCLOCK) < 0) {
|
||||
logmsg(LOG_ERR, "BIOCLOCK: %s", strerror(errno));
|
||||
return (-1);
|
||||
}
|
||||
+#endif
|
||||
|
||||
return (0);
|
||||
}
|
Loading…
Reference in New Issue
Block a user