- Upadate biology/mopac to version 1.15

- Bump affected ports
- Switch ports to new mastersite, add LICENSE
- Reformat ports pkg descriptions

PR:		194493
Submitted by:	tkato432@yahoo.com
This commit is contained in:
Pawel Pekala 2014-12-16 22:10:23 +00:00
parent dc255badc8
commit a28c9784b3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=374828
11 changed files with 233 additions and 227 deletions

View File

@ -3,35 +3,32 @@
PORTNAME= mopac
PORTVERSION= 7.${MOPAC_SUBVERSION}
PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= biology
MASTER_SITES= SF/${PORTNAME}7/${PORTNAME}7/${PORTNAME}7-1.00
DISTNAME= ${PORTNAME}7-${MOPAC_SUBVERSION}
MASTER_SITES= http://bioinformatics.org/ghemical/download/%SUBDIR%/
MASTER_SITE_SUBDIR= release20111012 current
DISTNAME= mopac7-${MOPAC_SUBVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Semi-empirical (MNDO, etc.) molecular orbital calculation
LIB_DEPENDS= libf2c.so:${PORTSDIR}/lang/f2c
LICENSE= GPLv2 # (or later)
USES= gmake libtool
USE_AUTOTOOLS= aclocal automake autoconf libtoolize
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy
USES= fortran gmake libtool pathfix
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MOPAC_SUBVERSION= 1.11
PORTEXAMPLES= *
OPTIONS_DEFINE= EXAMPLES
MOPAC_SUBVERSION= 1.15
post-patch:
@${REINPLACE_CMD} -e '/pkgconfig/s|$$(libdir)|$$(prefix)/libdata|g' \
${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e '/usage/s|run_||g' \
-e 's|./src/mopac7|${PREFIX}/libexec/mopac7|g' \
${WRKSRC}/run_${PORTNAME}7
@ -39,10 +36,9 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/run_${PORTNAME}7 \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}7
${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/${PORTNAME}7 \
${INSTALL_PROGRAM} ${WRKSRC}/fortran/.libs/${PORTNAME}7 \
${STAGEDIR}${PREFIX}/libexec/${PORTNAME}7
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/test
${INSTALL_DATA} ${WRKSRC}/tests/*.dat ${STAGEDIR}${EXAMPLESDIR}/test
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmopac7.so.0
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (mopac7-1.11.tar.gz) = 56dd55fc7e00e74095200b67aed1e9f0d06daa5b71dccdf944b5de5830d31921
SIZE (mopac7-1.11.tar.gz) = 1157353
SHA256 (mopac7-1.15.tar.gz) = 6d7ac5d78522db70f7794fd816cea32829cfa9e93774202fe80ba5a54375fbaa
SIZE (mopac7-1.15.tar.gz) = 764547

View File

@ -1,8 +0,0 @@
--- libmopac7.pc.in~ 2003-12-19 22:14:28.000000000 +0900
+++ libmopac7.pc.in 2008-08-23 07:09:51.000000000 +0900
@@ -4,4 +4,4 @@
Name: libmopac7
Description: A library for semi-empirical QM calculations.
Version: @VERSION@
-Libs: -L${libdir} -lmopac7
+Libs: -L${libdir} -lmopac7 -lf2c

View File

@ -1,12 +0,0 @@
--- src/Makefile.am.orig 2005-08-22 20:06:45.000000000 +0900
+++ src/Makefile.am 2009-12-17 03:23:46.000000000 +0900
@@ -42,7 +42,8 @@
if HAVE_F2C
noinst_PROGRAMS = mopac7
mopac7_SOURCES = mopac7app.c
-mopac7_LDFLAGS = -lmopac7 -lf2c -lm
+mopac7_LDADD = libmopac7.la
+mopac7_LDFLAGS = -lf2c -lm
else
# the executable is not built!
# so nothing here...

View File

@ -1,4 +1,4 @@
MOPAC7, semi-empirical (MNDO, AM1, PM3, MINDO/3)
quantum-chemical calculation written by James J. P. Stewart and co-workers.
MOPAC7, semi-empirical (MNDO, AM1, PM3, MINDO/3) quantum-chemical
calculation written by James J. P. Stewart and co-workers.
WWW: http://sourceforge.net/projects/mopac7/
WWW: http://bioinformatics.org/ghemical/

View File

@ -2,7 +2,7 @@ bin/mopac7
include/mopac7/libmopac7.h
lib/libmopac7.a
lib/libmopac7.so
lib/libmopac7.so.0
lib/libmopac7.so.0.0.0
lib/libmopac7.so.1
lib/libmopac7.so.1.0.13
libdata/pkgconfig/libmopac7.pc
libexec/mopac7

View File

@ -3,40 +3,37 @@
PORTNAME= ghemical
PORTVERSION= 3.0.0
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= science
MASTER_SITES= http://bioinformatics.org/ghemical/download/release20111012/ \
http://bioinformatics.org/ghemical/download/current
MASTER_SITES= http://bioinformatics.org/ghemical/download/%SUBDIR%/
MASTER_SITE_SUBDIR= release20111012 current
MAINTAINER= ports@FreeBSD.org
COMMENT= Ghemical is a computational chemistry software package
COMMENT= Computational chemistry software package
BUILD_DEPENDS= f2c:${PORTSDIR}/lang/f2c \
obabel:${PORTSDIR}/science/openbabel \
ld:${PORTSDIR}/devel/binutils
RUN_DEPENDS= f2c:${PORTSDIR}/lang/f2c
LIB_DEPENDS= libmpqc.so:${PORTSDIR}/science/mpqc \
libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext \
LICENSE= GPLv2 # (or later)
LIB_DEPENDS= libmopac7.so:${PORTSDIR}/biology/mopac \
libghemical.so:${PORTSDIR}/science/libghemical \
liboglappth.so:${PORTSDIR}/science/liboglappth \
libmopac7.so:${PORTSDIR}/biology/mopac
libmpqc.so:${PORTSDIR}/science/mpqc \
libopenbabel.so:${PORTSDIR}/science/openbabel \
libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
USES= fortran gettext gmake pkgconfig
USE_GNOME= glib20 gtk20 libglade2
USE_GL= glut
USES= fortran gettext gmake pathfix pkgconfig
USE_GNOME= gtk20 libglade2
USE_GL= glu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gamess --enable-mpqc --enable-openbabel --enable-gtk \
--enable-threads --enable-mopac7
CONFIGURE_ARGS= --enable-gtk --enable-threads --enable-openbabel
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= GHEMICAL_VERSION="${PORTVERSION}"
CPPFLAGS= -I${LOCALBASE}/include
MAKE_ENV= PKG_CONFIG=${LOCALBASE}/pkg-config
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
post-patch:
@${REINPLACE_CMD} -e \
's|"mozilla "|"xdg-open "|' ${WRKSRC}/src/gtk_app.cpp
.include <bsd.port.mk>

View File

@ -0,0 +1,33 @@
--- src/project.h.orig
+++ src/project.h
@@ -122,6 +122,14 @@
graphical user interface.
*/
+class project;
+
+bool ReadGPR_OLD(project &, istream &, bool, bool = false); ///< this is for the very old version.
+bool ReadGPR_v100(project &, istream &, bool, bool = false); ///< this is for the version 1.00.
+bool ReadGPR_v110(project &, istream &, bool, bool = false); ///< this is for the version 1.10.
+/// This is an input function for the v1.11 ghemical file format.
+bool ReadGPR(project &, istream &, bool, bool = false);
+
class project :
public custom_transformer_client,
public model
@@ -207,11 +215,11 @@
// methods for file I/O : ReadGPR and WriteGPR are friend functions so that it would be easier to "borrow" them elsewhere...
// ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- friend bool ReadGPR_OLD(project &, istream &, bool, bool = false); ///< this is for the very old version.
- friend bool ReadGPR_v100(project &, istream &, bool, bool = false); ///< this is for the version 1.00.
- friend bool ReadGPR_v110(project &, istream &, bool, bool = false); ///< this is for the version 1.10.
+ friend bool ReadGPR_OLD(project &, istream &, bool, bool); ///< this is for the very old version.
+ friend bool ReadGPR_v100(project &, istream &, bool, bool); ///< this is for the version 1.00.
+ friend bool ReadGPR_v110(project &, istream &, bool, bool); ///< this is for the version 1.10.
/// This is an input function for the v1.11 ghemical file format.
- friend bool ReadGPR(project &, istream &, bool, bool = false);
+ friend bool ReadGPR(project &, istream &, bool, bool);
friend void WriteGPR_v100(project &, ostream &); ///< this is for the version 1.00.
/// This is an output function for the v1.11 ghemical file format.

View File

@ -1,8 +1,8 @@
Ghemical is a computational chemistry software package,
Ghemical relies on external code to provide the quantum-mechanical calculations.
Semi-empirical methods MNDO, MINDO/3, AM1 and PM3 come from the MOPAC7 package,
and are included in the source distribution. The
MPQC package (GNU GPL) is used to provide ab initio methods.
Ghemical relies on external code to provide the quantum-mechanical
calculations. Semi-empirical methods MNDO, MINDO/3, AM1 and PM3 come
from the MOPAC7 package, and are included in the source distribution.
The MPQC package (GNU GPL) is used to provide ab initio methods.
WWW: http://www.uku.fi/~thassine/projects/ghemical/
WWW: http://bioinformatics.org/ghemical/

View File

@ -1,153 +1,153 @@
bin/ghemical
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/2atoms_unbonded.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_ci.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_menu.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_note.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_w_h.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_wo_h.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/add_hydrogens.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/add_hydrogens_select.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/change_bond_dialog.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/ci_plane.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/clipping1.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/clipping2.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane1.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane2.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane_optimized.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane_unoptimized.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/enlevdiag.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion1.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion2.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion3.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion4.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_mm.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_qm.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_select.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_select_obj.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/formula.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/formula_select.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/geometry_op_dialog.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/geometry_optimization_select.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/labels_menu.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/mainmenu.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/maintools.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/md_dialog.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/modal.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/ribbon.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/notebook.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/optimized_ethane.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/remove_hydrogens.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/sequence_builder.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/setup1.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/setup2.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/setup_select.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/toplevel.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/traj_dialog.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_01.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_02.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_03.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_04.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_05.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_06.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_07.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_08.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_09.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_10.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_11.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/images/window.png
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/documentation.css
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/MD.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/MD_viewer.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/aa_table.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/add_hydrogens.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/conf_search_tools.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/energy_vs_torsion.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/filetypes.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/formula.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/geometry_optimization.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/import_types.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/index.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/introduction.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/labels.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/measure.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/perspective.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/references.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/ribbon.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/sequence_builder.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/setup_dialog.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/using_mm.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/using_qm.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/using_sf.html
share/ghemical/%%GHEMICAL_VERSION%%/user-docs/visualization.html
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_hydride_shift/products.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_hydride_shift/reactants.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_hydride_shift/ts.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_methide_shift/products.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_methide_shift/reactants.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_methide_shift/ts.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/cycloaddition_Diels-Alder/products.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/cycloaddition_Diels-Alder/reactants.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/cycloaddition_Diels-Alder/ts.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/E2-reaction/products.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/E2-reaction/reactants.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/E2-reaction/ts.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/sigmatropic_rearrangement_Cope/products.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/sigmatropic_rearrangement_Cope/reactants.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/sigmatropic_rearrangement_Cope/ts.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/SN2-reaction/products.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/SN2-reaction/reactants.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/SN2-reaction/ts.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/tautomeric_shift_keto_enol/products.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/tautomeric_shift_keto_enol/reactants.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/transition_state_search/tautomeric_shift_keto_enol/ts.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/2-chlorobutane.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/3-phenylpropanal.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/PeriodicTable.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/acetylsalicylic_acid.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/alpha-pinene.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/bromobenzene.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/camphor.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/cinnamaldehyde.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/cis-2-pentene.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/cyclohexane.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/dna_AGTC.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/naphtalene.gpr
share/ghemical/%%GHEMICAL_VERSION%%/examples/rna_aguc.gpr
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_file_export_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_file_import_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_geomopt_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_moldyn_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_progress_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_setup_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_stereo_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/glade/gtk_trajview_dialog.glade
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/angle.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/bondtype.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/bond.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/chain.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/clipping.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/dihedral.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/distance.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/draw.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/element.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/erase.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/invert.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/measure.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/molecule.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/orbit_xy.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/orbit_z.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/residue.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/rotate_xy.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/rotate_z.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/select.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/setup.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/transl_xy.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/transl_z.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/zoom.xpm
share/ghemical/%%GHEMICAL_VERSION%%/pixmaps/ghemical.png
%%NLS%%share/locale/de/LC_MESSAGES/ghemical.mo
%%NLS%%share/locale/fi/LC_MESSAGES/ghemical.mo
%%NLS%%share/locale/mk/LC_MESSAGES/ghemical.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/ghemical.mo
%%NLS%%share/locale/ru/LC_MESSAGES/ghemical.mo
%%NLS%%share/locale/sq/LC_MESSAGES/ghemical.mo
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/2-chlorobutane.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/3-phenylpropanal.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/PeriodicTable.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/acetylsalicylic_acid.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/alpha-pinene.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/bromobenzene.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/camphor.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/cinnamaldehyde.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/cis-2-pentene.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/cyclohexane.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/dna_AGTC.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/naphtalene.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/rna_aguc.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/E2-reaction/products.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/E2-reaction/reactants.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/E2-reaction/ts.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/SN2-reaction/products.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/SN2-reaction/reactants.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/SN2-reaction/ts.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_hydride_shift/products.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_hydride_shift/reactants.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_hydride_shift/ts.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_methide_shift/products.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_methide_shift/reactants.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/carbocation_rearrangement_methide_shift/ts.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/cycloaddition_Diels-Alder/products.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/cycloaddition_Diels-Alder/reactants.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/cycloaddition_Diels-Alder/ts.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/sigmatropic_rearrangement_Cope/products.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/sigmatropic_rearrangement_Cope/reactants.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/sigmatropic_rearrangement_Cope/ts.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/tautomeric_shift_keto_enol/products.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/tautomeric_shift_keto_enol/reactants.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/examples/transition_state_search/tautomeric_shift_keto_enol/ts.gpr
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_file_export_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_file_import_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_geomopt_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_moldyn_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_progress_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_setup_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_stereo_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/glade/gtk_trajview_dialog.glade
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/angle.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/bond.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/bondtype.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/chain.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/clipping.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/dihedral.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/distance.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/draw.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/element.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/erase.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/ghemical.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/invert.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/measure.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/molecule.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/orbit_xy.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/orbit_z.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/residue.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/rotate_xy.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/rotate_z.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/select.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/setup.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/transl_xy.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/transl_z.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/pixmaps/zoom.xpm
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/MD.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/MD_viewer.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/aa_table.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/add_hydrogens.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/conf_search_tools.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/documentation.css
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/energy_vs_torsion.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/filetypes.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/formula.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/geometry_optimization.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/2atoms_unbonded.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_ci.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_menu.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_note.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_w_h.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/aa_builder_wo_h.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/add_hydrogens.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/add_hydrogens_select.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/change_bond_dialog.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/ci_plane.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/clipping1.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/clipping2.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane1.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane2.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane_optimized.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/cyclohexane_unoptimized.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion1.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion2.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion3.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/energy_vs_torsion4.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/enlevdiag.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_mm.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_qm.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_select.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/esp-plane_select_obj.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/formula.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/formula_select.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/geometry_op_dialog.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/geometry_optimization_select.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/labels_menu.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/mainmenu.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/maintools.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/md_dialog.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/modal.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/notebook.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/optimized_ethane.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/remove_hydrogens.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/ribbon.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/sequence_builder.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/setup1.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/setup2.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/setup_select.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/toplevel.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/traj_dialog.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_01.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_02.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_03.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_04.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_05.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_06.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_07.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_08.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_09.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_10.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/using_mm_11.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/images/window.png
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/import_types.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/index.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/introduction.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/labels.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/measure.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/perspective.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/references.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/ribbon.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/sequence_builder.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/setup_dialog.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/using_mm.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/using_qm.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/using_sf.html
%%DATADIR%%/%%GHEMICAL_VERSION%%/user-docs/visualization.html
share/locale/de/LC_MESSAGES/ghemical.mo
share/locale/fi/LC_MESSAGES/ghemical.mo
share/locale/mk/LC_MESSAGES/ghemical.mo
share/locale/pt_BR/LC_MESSAGES/ghemical.mo
share/locale/ru/LC_MESSAGES/ghemical.mo
share/locale/sq/LC_MESSAGES/ghemical.mo

View File

@ -6,7 +6,7 @@ PORTVERSION= 3.0.0
PORTREVISION= 6
CATEGORIES= science
MASTER_SITES= http://bioinformatics.org/ghemical/download/release20111012/ \
http://bioinformatics.org/ghemical/download/current
http://bioinformatics.org/ghemical/download/current/
MAINTAINER= ports@FreeBSD.org
COMMENT= Support libraries of science/ghemical port
@ -14,17 +14,17 @@ COMMENT= Support libraries of science/ghemical port
BUILD_DEPENDS= obabel:${PORTSDIR}/science/openbabel \
intltool-update:${PORTSDIR}/textproc/intltool \
ld:${PORTSDIR}/devel/binutils
LIB_DEPENDS+= libmpqc.so:${PORTSDIR}/science/mpqc \
LIB_DEPENDS= libmpqc.so:${PORTSDIR}/science/mpqc \
libf2c.so:${PORTSDIR}/lang/f2c
USES= fortran gettext gmake pathfix pkgconfig libtool
USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS+= --enable-mpqc
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib -lSCbasis -lSCcints -lSCclass \
LDFLAGS+= -L${LOCALBASE}/lib -lSCbasis -lSCcints -lSCclass \
-lSCcontainer -lSCdft -lSCgroup -lSCintv3 -lSCisosurf \
-lSCkeyval -lSCmbpt -lSCmbptr12 -lSCmisc -lSCmolecule \
-lSCoint3 -lSCoptimize -lSCoptions -lSCpsi -lSCref \