- New port: emulators/mupen64-tr64

A graphics plugin for Mupen64 emulator
This commit is contained in:
Jose Alonso Cardenas Marquez 2007-10-09 07:43:55 +00:00
parent ed85212bd6
commit a221de9abb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=201147
4 changed files with 67 additions and 0 deletions

View File

@ -101,6 +101,7 @@
SUBDIR += mupen64-sdlinput
SUBDIR += mupen64-softgfx
SUBDIR += mupen64-sound
SUBDIR += mupen64-tr64
SUBDIR += nonpareil
SUBDIR += o2em
SUBDIR += ods2reader

View File

@ -0,0 +1,24 @@
# New ports collection makefile for: mupen64-tr64
# Date created: 2007-10-09
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
#
# $FreeBSD$
#
PORTVERSION= 0.7.8
PKGNAMESUFFIX= -tr64
COMMENT= Tr64 graphics plugin for Mupen64
USE_SDL= sdl
USE_GL= yes
FIXFILES= display.c sdlgl.c
PLUGIN_NAME= tr64gl
MASTERDIR= ${.CURDIR}/../mupen64-base
OPTIONS= #
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,3 @@
MD5 (mupen64/tr64_ogl_gtk2-0.7.8.tar.bz2) = 2e1a65dead4b11d023756e0a2a4478d5
SHA256 (mupen64/tr64_ogl_gtk2-0.7.8.tar.bz2) = cdc69be9adb3df8cd2a92f7df388930ec11b6d6dceef2aab0e831521346e8bc2
SIZE (mupen64/tr64_ogl_gtk2-0.7.8.tar.bz2) = 165504

View File

@ -0,0 +1,39 @@
--- Makefile.orig 2005-08-26 14:11:28.000000000 -0500
+++ Makefile 2007-10-09 01:55:17.000000000 -0500
@@ -1,26 +1,26 @@
ifneq ("$(shell grep GTK2 config.h)","\#define GTK2_SUPPORT 1")
-GTK_FLAGS = `gtk-config --cflags`
-GTK_LIBS = `gtk-config --libs`
+GTK_FLAGS = `${GTK_CONFIG} --cflags`
+GTK_LIBS = `${GTK_CONFIG} --libs`
else
GTK_FLAGS = `pkg-config gtk+-2.0 --cflags` -D_GTK2
GTK_LIBS = `pkg-config gtk+-2.0 --libs`
endif
-CC = gcc
-CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer
-LD = gcc
-LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib `sdl-config --libs`
+CC ?= gcc
+CFLAGS += -DUSE_GTK `${SDL_CONFIG} --cflags` $(GTK_FLAGS) -ffast-math -funroll-loops -fomit-frame-pointer
+LD = ${CXX}
+LDFLAGS = -lGL -lGLU -L${LOCALBAASE}/lib `${SDL_CONFIG} --libs`
OBJECTS = 3dmath.o autodet.o combine1.o debug.o display.o driver.o lighting.o rdp.o rdp_gl.o render.o sdlgl.o texture.o
-all: tr64gl.so instruction
+all: plugins/tr64gl.so instruction
-tr64gl.so: $(OBJECTS)
+plugins/tr64gl.so: $(OBJECTS)
+ mkdir -p plugins
$(LD) -shared -Wl,-Bsymbolic $(GTK_LIBS) $(LDFLAGS) -o $@ $(OBJECTS)
- strip --strip-all $@
instruction:
- $(warning please copy tr64gl.so in plugins/ folder of the emulator)
+ $(warning please copy plugins/tr64gl.so in plugins/ folder of the emulator)
.o: .c
$(CC) $(CFLAGS) -o $@ $<