- Updated to 1.3.3.3

- Added AUDACIOUS and BEEP_MEDIA_PLAYER as OPTIONS

Approved by:	alexbl (mentor, implicit)
This commit is contained in:
Nicola Vitale 2007-01-29 22:11:53 +00:00
parent 76f6f309ca
commit a1eac59660
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=183654
5 changed files with 98 additions and 43 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= tunapie
PORTVERSION= 1.3.2
PORTVERSION= 1.3.3.3
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,8 +15,7 @@ MAINTAINER= nivit@FreeBSD.org
COMMENT= Tuner for streaming internet radio and TV
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
streamripper:${PORTSDIR}/audio/streamripper \
xmms:${PORTSDIR}/multimedia/xmms
streamripper:${PORTSDIR}/audio/streamripper
NO_BUILD= yes
USE_PYTHON= yes
@ -24,7 +23,9 @@ USE_WX= 2.6
WX_COMPS= python:run
OPTIONS= ADULT "non-censored TV listings" off \
XINE "use xine instead of mplayer" off
XINE "use xine instead of mplayer as default" off \
AUDACIOUS "use audacious instead of xmms as default" off \
BEEP_MEDIA_PLAYER "use beep-media-player instead of xmms as default" off
MAN1= tunapie.1
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
@ -34,12 +35,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME:C/-rc4-3$/_rc4/}
FIND_FILES= -type f -and \( -name "install.sh" -or -name "*.py" \)
post-patch:
cd ${WRKSRC} && ${FIND} . ${FIND_FILES} -exec ${REINPLACE_CMD} \
@cd ${WRKSRC} && ${FIND} . ${FIND_FILES} -exec ${REINPLACE_CMD} \
-e 's|%%DATADIR%%|${DATADIR}|g'\
-e 's|%%DESKTOPDIR%%|${DESKTOPDIR}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%MANPREFIX%%|${MANPREFIX}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%AUDIOPLAYER%%|${AUDIOPLAYER}|g' \
-e 's|%%VIDEOPLAYER%%|${VIDEOPLAYER}|g' \
-e 's|%%X11BASE%%|${X11BASE}|g' {} ";"
@ -54,6 +56,7 @@ do-install:
ADULT_TVLIST= --adult
.endif
# default VIDEOPLAYER
.if defined(WITH_XINE)
RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
VIDEOPLAYER= ${X11BASE}/bin/xine
@ -62,4 +65,16 @@ RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
VIDEOPLAYER= ${LOCALBASE}/bin/mplayer
.endif
# default AUDIOPLAYER
.if defined(WITH_AUDACIOUS)
RUN_DEPENDS+= audacious:${PORTSDIR}/multimedia/audacious
AUDIOPLAYER= ${LOCALBASE}/bin/audacious
.elifdef(WITH_BEEP_MEDIA_PLAYER)
RUN_DEPENDS+= beep-media-player:${PORTSDIR}/multimedia/beep-media-player
AUDIOPLAYER= ${LOCALBASE}/bin/beep-media-player
.else
RUN_DEPENDS+= xmms:${PORTSDIR}/multimedia/xmms
AUDIOPLAYER= ${X11BASE}/bin/xmms
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (tunapie-1.3.2.tar.gz) = 3242913695ca406dc9461f091372837b
SHA256 (tunapie-1.3.2.tar.gz) = 97468e7be0b84133928a5fb9b3a4d2287c01540682aafc243a910aed68512998
SIZE (tunapie-1.3.2.tar.gz) = 39407
MD5 (tunapie-1.3.3.3.tar.gz) = e5123980d2162157ae6ed1cfef79175e
SHA256 (tunapie-1.3.3.3.tar.gz) = 7eb34a8e35408390abd943a704b5cfeb19d8c18543b26703adbdb3f0ec4bc8f8
SIZE (tunapie-1.3.3.3.tar.gz) = 39920

View File

@ -1,6 +1,6 @@
--- src/TunerFrame1.py Thu Dec 21 00:40:08 2006
+++ src/TunerFrame1.py.port Fri Dec 22 23:05:45 2006
@@ -129,7 +129,7 @@
--- src/TunerFrame1.py Wed Jan 10 00:41:00 2007
+++ src/TunerFrame1.py.port Mon Jan 29 11:32:44 2007
@@ -130,7 +130,7 @@
self.SetBackgroundColour(wx.Colour(246, 246, 246))
self.SetBackgroundStyle(wx.BG_STYLE_SYSTEM)
self.SetThemeEnabled(True)
@ -9,18 +9,29 @@
self.SetFont(wx.Font(10, wx.SWISS, wx.NORMAL, wx.NORMAL, False,u'Sans'))
self.SetAutoLayout(True)
self.SetMinSize(wx.Size(770, 410))
@@ -564,10 +564,10 @@
for name in self.favname:
self.favorites.Append(name)
self.name=[]
- self.mediaplayer='/usr/bin/xmms'
- self.videoplayer='/usr/bin/totem'
- self.term='/usr/bin/x-terminal-emulator'
- self.ripper='/usr/bin/streamripper -t -u winamp2 -o never'
+ self.mediaplayer='%%X11BASE%%/bin/xmms'
+ self.videoplayer='%%VIDEOPLAYER%%'
+ self.term='%%X11BASE%%/bin/xterm'
+ self.ripper='%%LOCALBASE%%/bin/streamripper -t -u winamp2 -o never'
self.rdir=self.home+'/.tunapie/streamripper'
@@ -568,9 +568,13 @@
self.shoutice=1 #0 is icecast server 1 is shoutcast
self.maxd=100
self.newsize=8
+ self.mediaplayer='%%AUDIOPLAYER%%'
+ self.videoplayer='%%VIDEOPLAYER%%'
+ self.term='%%X11BASE%%/bin/xterm'
+ self.ripper='%%LOCALBASE%%/bin/streamripper -t -u winamp2 -o never'
self.mediaplayer,self.videoplayer,self.term,self.ripper,self.rdir,\
- self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home, self.rdir,\
- self.shoutice,self.maxd,self.newsize)
+ self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home,self.mediaplayer,\
+ self.videoplayer,self.term,self.ripper,self.rdir,self.shoutice,self.maxd,self.newsize)
missing_players=[]
if (commands.getoutput("which "+self.mediaplayer))=="":
if commands.getoutput("which audacious"):
@@ -1224,7 +1228,8 @@
finally:
dlg.Destroy()
self.mediaplayer,self.videoplayer,self.term,self.ripper,self.rdir,\
- self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home,self.rdir,self.shoutice,self.maxd,self.newsize)
+ self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home,self.mediaplayer,
+ self.videoplayer,self.term,self.ripper,self.rdir,self.shoutice,self.maxd,self.newsize)
self.setfontsize()
self.download()
self.OnRadioradioRadiobutton(1)

View File

@ -1,36 +1,36 @@
--- src/TunerPrefs.py Wed Jul 26 23:26:38 2006
+++ src/TunerPrefs.py.port Sat Jul 29 07:02:36 2006
@@ -77,7 +77,7 @@
--- src/TunerPrefs.py Wed Jan 10 00:41:00 2007
+++ src/TunerPrefs.py.port Sun Jan 28 21:58:34 2007
@@ -94,7 +94,7 @@
self.audiopath = wx.TextCtrl(id=wxID_PREFERENCESAUDIOPATH,
name='audiopath', parent=self, pos=wx.Point(168, 16),
- size=wx.Size(200, 22), style=0, value='/usr/bin/xmms')
+ size=wx.Size(200, 22), style=0, value='%%X11BASE%%/bin/xmms')
name='audiopath', parent=self, pos=wx.Point(144, 16),
- size=wx.Size(224, 22), style=0, value='/usr/bin/xmms')
+ size=wx.Size(224, 22), style=0, value='%%AUDIOPLAYER%%')
self.audiopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.audiopath.SetBackgroundColour(wx.Colour(255, 253, 239))
@@ -86,7 +86,7 @@
@@ -103,7 +103,7 @@
self.videopath = wx.TextCtrl(id=wxID_PREFERENCESVIDEOPATH,
name='videopath', parent=self, pos=wx.Point(168, 48),
- size=wx.Size(200, 22), style=0, value='/usr/bin/mplayer')
+ size=wx.Size(200, 22), style=0, value='%%VIDEOPLAYER%%')
name='videopath', parent=self, pos=wx.Point(144, 48),
- size=wx.Size(216, 22), style=0, value='/usr/bin/mplayer')
+ size=wx.Size(216, 22), style=0, value='%%VIDEOPLAYER%%')
self.videopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.videopath.SetBackgroundColour(wx.Colour(255, 253, 239))
@@ -115,7 +115,7 @@
@@ -131,7 +131,7 @@
self.termpath = wx.TextCtrl(id=wxID_PREFERENCESTERMPATH,
name='termpath', parent=self, pos=wx.Point(168, 80),
size=wx.Size(200, 22), style=0,
name='termpath', parent=self, pos=wx.Point(144, 80),
size=wx.Size(224, 22), style=0,
- value='/usr/bin/x-terminal-emulator')
+ value='%%X11BASE%%/bin/xterm')
self.termpath.SetFont(wx.Font(7, wx.SWISS, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.termpath.SetBackgroundColour(wx.Colour(255, 253, 239))
@@ -124,7 +124,7 @@
@@ -140,7 +140,7 @@
self.rippath = wx.TextCtrl(id=wxID_PREFERENCESRIPPATH, name='rippath',
parent=self, pos=wx.Point(168, 112), size=wx.Size(200, 22),
parent=self, pos=wx.Point(144, 112), size=wx.Size(224, 22),
- style=0, value='/usr/bin/streamripper')
+ style=0, value='%%LOCALBASE%%/bin/streamripper')
self.rippath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,

View File

@ -1,7 +1,36 @@
--- src/tuner.py Sat Sep 30 01:02:41 2006
+++ src/tuner.py.port Wed Oct 18 14:19:58 2006
@@ -298,7 +298,7 @@
return process
--- src/tuner.py Wed Jan 10 00:41:00 2007
+++ src/tuner.py.port Mon Jan 29 11:29:36 2007
@@ -266,26 +266,27 @@
preffile.write("max streams to display="+str(int(maxd))+'\n')
preffile.write("font size="+str(int(fontsize))+'\n')
-def readprefs(home,rdir,shoutice,maxd,fontsize):
+def readprefs(home,media,video,term,rip,rdir,shoutice,maxd,fontsize):
try: preffile=open(home+'/.tunapie/prefs','r')
except IOError:
- return "","","","",rdir,shoutice,maxd,fontsize
+ return media,video,term,rip,rdir,shoutice,maxd,fontsize
preferences=preffile.read().split('\n')
- returnvals=[]
+ returnvals={'audioplayer':media,'videoplayer':video,'xterm':term,\
+ 'streamripper':rip,'ripdirectory':rdir,'icecast(0)/shoutcast(1)':shoutice,\
+ 'max streams to display':maxd,'font size':fontsize}
for i in preferences:
- try:returnvals.append(i.split("=")[1])
- except IndexError: pass
- if len(returnvals)<8:
- return media,video,term,rip,rdir,shoutice,maxd,fontsize
- return(returnvals[0],returnvals[1],returnvals[2],returnvals[3],\
- returnvals[4],returnvals[5],returnvals[6], returnvals[7])
+ try:returnvals[i.split("=")[0]]=i.split("=")[1]
+ except (IndexError,KeyError): pass
+ return(returnvals['audioplayer'],returnvals['videoplayer'],returnvals['xterm'],\
+ returnvals['streamripper'],returnvals['ripdirectory'],returnvals['icecast(0)/shoutcast(1)'],\
+ returnvals['max streams to display'], returnvals['font size'])
def recordselection(terminal,args):
player=popen2.Popen4(terminal+' '+args)
return player.pid
def adultset():
- try: adultconfig=open('/etc/tunapie.config')