math/rapid: Fix build on FreeBSD 12, clean up license info, remove dead mirror

Approved by:    jrm (mentor)
Differential Revision:  https://reviews.freebsd.org/D15460
This commit is contained in:
Jason W. Bacon 2018-05-19 14:09:01 +00:00
parent 3b76348806
commit a1acd6996c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=470408
8 changed files with 83 additions and 18 deletions

View File

@ -3,21 +3,24 @@
PORTNAME= rapid
PORTVERSION= 2.01
CATEGORIES= math science graphics
MASTER_SITES= http://www.cs.sunysb.edu/~algorith/implement/RAPID/distrib/ \
http://www.neuro.mcw.edu/Ports/distfiles/
MASTER_SITES= http://www.cs.sunysb.edu/~algorith/implement/RAPID/distrib/
DISTNAME= RAPID_v2_01
MAINTAINER= jwb@FreeBSD.org
COMMENT= Robust and Accurate Polygon Interference Detection
RESTRICTED= For any commercial purpose, you must request a license from http://www.cs.unc.edu/~geom/OBB/OBBT.html
LICENSE= UNKNOWN
LICENSE_NAME= unknown
LICENSE_TEXT= For any commercial purpose, you must request a license from \
http://www.cs.unc.edu/~geom/OBB/OBBT.html
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell no-pkg-mirror \
auto-accept
SUB_FILES= pkg-message
ALL_TARGET=
MAKE_JOBS_UNSAFE= yes
MAKE_ENV+= V=1
MAKE_ENV+= V=1
.include <bsd.port.pre.mk>

View File

@ -1,5 +1,5 @@
--- Makefile.orig 1997-07-03 18:54:09.000000000 +0200
+++ Makefile 2015-05-29 23:02:09.707278000 +0200
--- Makefile.orig 1997-07-03 16:54:09 UTC
+++ Makefile
@@ -1,5 +1,5 @@
-CC = CC -O

View File

@ -0,0 +1,11 @@
--- RAPID.C.orig 2018-05-16 10:56:45 UTC
+++ RAPID.C
@@ -40,7 +40,7 @@
#include "RAPID_version.H"
-static char rapidtag_data[] = "RAPIDTAG file: "__FILE__" date: "__DATE__" time: "__TIME__;
+static char rapidtag_data[] = "RAPIDTAG file: " __FILE__ " date: " __DATE__ " time: " __TIME__;
// to silence the compiler's complaints about unreferenced identifiers.
static void r1(char *f){ r1(f); r1(rapidtag_data); r1(rapid_version);}

View File

@ -0,0 +1,22 @@
--- build.C.orig 1997-07-03 16:54:10 UTC
+++ build.C
@@ -41,7 +41,7 @@
#include "RAPID_version.H"
-static char rapidtag_data[] = "RAPIDTAG file: "__FILE__" date: "__DATE__" time: "__TIME__;
+static char rapidtag_data[] = "RAPIDTAG file: " __FILE__ " date: " __DATE__ " time: " __TIME__;
// to silence the compiler's complaints about unreferenced identifiers.
static void r1(char *f){ r1(f); r1(rapidtag_data); r1(rapid_version);}
@@ -419,8 +419,8 @@ box::split_recurse(int *t, int n)
// see where it lies with respect to axdmp.
mean_from_moment(c, RAPID_moment[in]);
- if (((pR[0][0]*c[0] + pR[1][0]*c[1] + pR[2][0]*c[2]) < axdmp)
- && ((n!=2)) || ((n==2) && (i==0)))
+ if ( (( (pR[0][0]*c[0] + pR[1][0]*c[1] + pR[2][0]*c[2]) < axdmp)
+ && (n!=2)) || ((n==2) && (i==0)) )
{
// accumulate first and second order moments for group 1
accum_moment(M1, RAPID_moment[in]);

View File

@ -0,0 +1,11 @@
--- collide.C.orig 2018-05-16 10:58:09 UTC
+++ collide.C
@@ -42,7 +42,7 @@
#include "RAPID_version.H"
-static char rapidtag_data[] = "RAPIDTAG file: "__FILE__" date: "__DATE__" time: "__TIME__;
+static char rapidtag_data[] = "RAPIDTAG file: " __FILE__ " date: " __DATE__ " time: " __TIME__;
// to silence the compiler's complaints about unreferenced identifiers.
static void r1(char *f){ r1(f); r1(rapidtag_data); r1(rapid_version);}

View File

@ -0,0 +1,22 @@
--- overlap.C.orig 2018-05-16 10:58:45 UTC
+++ overlap.C
@@ -41,7 +41,7 @@
#include "RAPID_version.H"
-static char rapidtag_data[] = "RAPIDTAG file: "__FILE__" date: "__DATE__" time: "__TIME__;
+static char rapidtag_data[] = "RAPIDTAG file: " __FILE__ " date: " __DATE__ " time: " __TIME__;
// to silence the compiler's complaints about unreferenced identifiers.
static void r1(char *f){ r1(f); r1(rapidtag_data); r1(rapid_version);}
@@ -221,8 +221,8 @@ models.
int
obb_disjoint(double B[3][3], double T[3], double a[3], double b[3])
{
- register double t, s;
- register int r;
+ double t, s;
+ int r;
double Bf[3][3];
const double reps = 1e-6;

View File

@ -1,5 +1,5 @@
--- ./sample_client.C.orig 2014-02-21 11:34:06.215654443 +0100
+++ ./sample_client.C 2014-02-21 11:34:17.068652509 +0100
--- sample_client.C.orig 1997-07-03 16:54:09 UTC
+++ sample_client.C
@@ -42,7 +42,7 @@
#define LISTS 0

View File

@ -1,16 +1,12 @@
RAPID is a robust and accurate polygon interference detection library
for large environments composed of unstructured models.
WWW: http://www.cs.unc.edu/~geom/OBB/OBBT.html
RAPID is a robust and accurate polygon interference detection library for
large environments composed of unstructured models.
**************************************************************************
The RAPID code is offered "as is" and is free for non-commercial use.
To use RAPID for any commercial purpose, you must request a license from
http://www.cs.unc.edu/~geom/OBB/OBBT.html
Redistribution of RAPID code in any form is strictly prohibited.
To use RAPID for any commercial purpose, you must request a license.
**************************************************************************
WWW: http://www.cs.unc.edu/~geom/OBB/OBBT.html