Add support for Russian characters.
Submitted by: Oleg Dashevskii <od@iclub.nsu.ru>
This commit is contained in:
parent
52bcb3880c
commit
a19eea0561
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41465
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= aterm
|
||||
PORTVERSION= 0.4.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://download.sourceforge.net/aterm/
|
||||
|
||||
|
@ -1,6 +1,28 @@
|
||||
--- src/command.c.orig Tue Oct 17 13:10:04 2000
|
||||
+++ src/command.c Tue Oct 17 13:10:26 2000
|
||||
@@ -528,7 +528,7 @@
|
||||
--- src/command.c.orig Sun May 28 03:46:35 2000
|
||||
+++ src/command.c Mon Apr 16 11:34:38 2001
|
||||
@@ -67,12 +67,18 @@
|
||||
#ifndef NO_XLOCALE
|
||||
# if (XtSpecificationRelease < 6)
|
||||
# define NO_XLOCALE
|
||||
-# else
|
||||
-# define X_LOCALE
|
||||
-# include <X11/Xlocale.h>
|
||||
# endif
|
||||
#endif /* NO_XLOCALE */
|
||||
|
||||
+#ifndef NO_XSETLOCALE
|
||||
+# define X_LOCALE
|
||||
+# include <X11/Xlocale.h>
|
||||
+#else
|
||||
+# ifndef NO_SETLOCALE
|
||||
+# include <locale.h>
|
||||
+# endif
|
||||
+#endif /* NO_XLOCALE */
|
||||
+
|
||||
#ifdef TTY_GID_SUPPORT
|
||||
# include <grp.h>
|
||||
#endif
|
||||
@@ -528,7 +534,7 @@
|
||||
ttydev = tty_name;
|
||||
|
||||
# define PTYCHAR1 "pqrstuvwxyz"
|
||||
@ -9,3 +31,12 @@
|
||||
for (c1 = PTYCHAR1; *c1; c1++) {
|
||||
ptydev[len - 2] = ttydev[len - 2] = *c1;
|
||||
for (c2 = PTYCHAR2; *c2; c2++) {
|
||||
@@ -1206,7 +1212,7 @@
|
||||
|
||||
Input_Context = NULL;
|
||||
|
||||
-# ifndef NO_SETLOCALE
|
||||
+# if !defined(NO_SETLOCALE) || !defined(NO_XSETLOCALE)
|
||||
setlocale(LC_CTYPE, ""); /* XXX: should we do this? */
|
||||
# endif
|
||||
if (rs_inputMethod == NULL || !*rs_inputMethod) {
|
||||
|
95
x11/aterm/files/patch-ab
Normal file
95
x11/aterm/files/patch-ab
Normal file
@ -0,0 +1,95 @@
|
||||
--- configure.orig Mon May 29 04:58:49 2000
|
||||
+++ configure Mon Apr 16 11:27:07 2001
|
||||
@@ -4575,8 +4575,9 @@
|
||||
|
||||
SAVETHELIBS=$LIBS
|
||||
LIBS="$LIBS $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11"
|
||||
+CFLAGS="$CFLAGS $X_CFLAGS"
|
||||
echo $ac_n "checking for working Xlocale""... $ac_c" 1>&6
|
||||
-echo "configure:4580: checking for working Xlocale" >&5
|
||||
+echo "configure:4581: checking for working Xlocale" >&5
|
||||
if eval "test \"`echo '$''{'rxvt_cv_func_xlocale'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
@@ -4584,7 +4585,7 @@
|
||||
echo "configure: warning: Define/undefine NO_XLOCALE in config.h manually" 1>&2
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
-#line 4588 "configure"
|
||||
+#line 4589 "configure"
|
||||
#include "confdefs.h"
|
||||
#define X_LOCALE 1
|
||||
#include <X11/Xlocale.h>
|
||||
@@ -4596,7 +4597,7 @@
|
||||
else
|
||||
exit (1);}
|
||||
EOF
|
||||
-if { (eval echo configure:4600: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
||||
+if { (eval echo configure:4601: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
||||
then
|
||||
rxvt_cv_func_xlocale=yes
|
||||
else
|
||||
@@ -4620,12 +4621,12 @@
|
||||
LIBS=$SAVETHELIBS
|
||||
|
||||
echo $ac_n "checking for working setlocale""... $ac_c" 1>&6
|
||||
-echo "configure:4624: checking for working setlocale" >&5
|
||||
+echo "configure:4625: checking for working setlocale" >&5
|
||||
if eval "test \"`echo '$''{'rxvt_cv_func_xsetlocale'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
-#line 4629 "configure"
|
||||
+#line 4630 "configure"
|
||||
#include "confdefs.h"
|
||||
#define X_LOCALE 1
|
||||
#include <X11/Xlocale.h>
|
||||
@@ -4633,7 +4634,7 @@
|
||||
setlocale(LC_CTYPE, "");
|
||||
; return 0; }
|
||||
EOF
|
||||
-if { (eval echo configure:4637: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+if { (eval echo configure:4638: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
rm -rf conftest*
|
||||
rxvt_cv_func_xsetlocale=yes
|
||||
else
|
||||
@@ -4647,6 +4648,39 @@
|
||||
|
||||
echo "$ac_t""$rxvt_cv_func_xsetlocale" 1>&6
|
||||
if test "${rxvt_cv_func_xsetlocale}" = no; then
|
||||
+ cat >> confdefs.h <<\EOF
|
||||
+#define NO_XSETLOCALE 1
|
||||
+EOF
|
||||
+
|
||||
+fi
|
||||
+
|
||||
+echo $ac_n "checking for working plain setlocale""... $ac_c" 1>&6
|
||||
+echo "configure:4659: checking for working plain setlocale" >&5
|
||||
+if eval "test \"`echo '$''{'rxvt_cv_func_setlocale'+set}'`\" = set"; then
|
||||
+ echo $ac_n "(cached) $ac_c" 1>&6
|
||||
+else
|
||||
+ cat > conftest.$ac_ext <<EOF
|
||||
+#line 4664 "configure"
|
||||
+#include "confdefs.h"
|
||||
+#include <locale.h>
|
||||
+int main() {
|
||||
+setlocale(LC_CTYPE, "");
|
||||
+; return 0; }
|
||||
+EOF
|
||||
+if { (eval echo configure:4671: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+ rm -rf conftest*
|
||||
+ rxvt_cv_func_setlocale=yes
|
||||
+else
|
||||
+ echo "configure: failed program was:" >&5
|
||||
+ cat conftest.$ac_ext >&5
|
||||
+ rm -rf conftest*
|
||||
+ rxvt_cv_func_setlocale=no
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+fi
|
||||
+
|
||||
+echo "$ac_t""$rxvt_cv_func_setlocale" 1>&6
|
||||
+if test x${rxvt_cv_func_setlocale} = xno; then
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define NO_SETLOCALE 1
|
||||
EOF
|
12
x11/aterm/files/patch-ac
Normal file
12
x11/aterm/files/patch-ac
Normal file
@ -0,0 +1,12 @@
|
||||
--- autoconf/acconfig.h.orig Mon May 22 02:56:13 2000
|
||||
+++ autoconf/acconfig.h Mon Apr 16 11:27:07 2001
|
||||
@@ -39,6 +39,9 @@
|
||||
#undef NO_XLOCALE
|
||||
|
||||
/* Define is setlocale (defined to Xsetlocale) doesn't work */
|
||||
+#undef NO_XSETLOCALE
|
||||
+
|
||||
+/* Define is plain setlocale doesn't work */
|
||||
#undef NO_SETLOCALE
|
||||
|
||||
/* Define if you want Menubar support */
|
12
x11/aterm/files/patch-ad
Normal file
12
x11/aterm/files/patch-ad
Normal file
@ -0,0 +1,12 @@
|
||||
--- autoconf/config.h.in.orig Mon May 22 02:56:13 2000
|
||||
+++ autoconf/config.h.in Mon Apr 16 11:27:07 2001
|
||||
@@ -84,6 +84,9 @@
|
||||
#undef NO_XLOCALE
|
||||
|
||||
/* Define is setlocale (defined to Xsetlocale) doesn't work */
|
||||
+#undef NO_XSETLOCALE
|
||||
+
|
||||
+/* Define is plain setlocale doesn't work */
|
||||
#undef NO_SETLOCALE
|
||||
|
||||
/* Define if you want Menubar support */
|
25
x11/aterm/files/patch-ae
Normal file
25
x11/aterm/files/patch-ae
Normal file
@ -0,0 +1,25 @@
|
||||
--- autoconf/configure.in.orig Mon May 29 04:58:49 2000
|
||||
+++ autoconf/configure.in Mon Apr 16 11:27:07 2001
|
||||
@@ -632,6 +632,7 @@
|
||||
dnl# this is a really hack test for some basic Xlocale stuff
|
||||
SAVETHELIBS=$LIBS
|
||||
LIBS="$LIBS $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11"
|
||||
+CFLAGS="$CFLAGS $X_CFLAGS"
|
||||
AC_CACHE_CHECK(for working Xlocale, rxvt_cv_func_xlocale,
|
||||
[AC_TRY_RUN([#define X_LOCALE 1
|
||||
#include <X11/Xlocale.h>
|
||||
@@ -655,6 +656,14 @@
|
||||
[setlocale(LC_CTYPE, "");],
|
||||
rxvt_cv_func_xsetlocale=yes, rxvt_cv_func_xsetlocale=no)])
|
||||
if test "${rxvt_cv_func_xsetlocale}" = no; then
|
||||
+ AC_DEFINE(NO_XSETLOCALE)
|
||||
+fi
|
||||
+
|
||||
+AC_CACHE_CHECK(for working plain setlocale, rxvt_cv_func_setlocale,
|
||||
+[AC_TRY_LINK([#include <locale.h>],
|
||||
+ [setlocale(LC_CTYPE, "");],
|
||||
+ rxvt_cv_func_setlocale=yes, rxvt_cv_func_setlocale=no)])
|
||||
+if test x${rxvt_cv_func_setlocale} = xno; then
|
||||
AC_DEFINE(NO_SETLOCALE)
|
||||
fi
|
||||
|
11
x11/aterm/files/patch-af
Normal file
11
x11/aterm/files/patch-af
Normal file
@ -0,0 +1,11 @@
|
||||
--- scripts/random_colors.orig Tue May 16 03:10:57 2000
|
||||
+++ scripts/random_colors Mon Apr 16 11:27:07 2001
|
||||
@@ -6,7 +6,7 @@
|
||||
# folks like it - so here it is
|
||||
|
||||
CLRCODE=`expr $RANDOM % 6`
|
||||
-ATRMPATH=$DESTDIR/usr/local/bin
|
||||
+ATRMPATH=$DESTDIR/usr/X11R6/bin
|
||||
|
||||
{ [ "$CLRCODE" -eq "0" ] && CLRNAME="-tint blue -fg yellow -bg black" } ||
|
||||
{ [ "$CLRCODE" -eq "1" ] && CLRNAME="-tint red -fg white -bg black" } ||
|
Loading…
Reference in New Issue
Block a user