- Add entry about viewcvs->viewvc
- Fix last entry. s|ports/sysutils/e17-module|sysutils/e17-module| [1]

Pointy hat to:	itectu [1]

* devel/viewcvs

- Remove port

* net-mgmt/rancid

- Change to devel/viewvc in pkg-message
This commit is contained in:
Marcus Alves Grando 2006-07-26 19:44:32 +00:00
parent adabe2c467
commit a19aaded4a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168836
11 changed files with 4 additions and 284 deletions

3
MOVED
View File

@ -2424,4 +2424,5 @@ net/tethereal-lite|net/tshark-lite|2006-07-17|Project name has changed
games/quake3-q3base|games/q3base|2006-07-22|the "quake3-" prefix is used by modifications and the like, not engines
lang/fpc-demo||2006-07-24|Removed because it's not necessary anymore
www/horde-php5||2006-07-24|Removed: this port is redundant now that php5 is the default
ports/sysutils/e17-module-devian|ports/x11/e17-module-devian|2006-07-26|Move e17-module-devian from sysutils to x11
sysutils/e17-module-devian|x11/e17-module-devian|2006-07-26|Move e17-module-devian from sysutils to x11
devel/viewcvs|devel/viewvc|2006-07-26|Project name has changed

View File

@ -1878,7 +1878,6 @@
SUBDIR += valgrind-snapshot
SUBDIR += varconf
SUBDIR += vb2c
SUBDIR += viewcvs
SUBDIR += viewvc
SUBDIR += vstr
SUBDIR += vtcl

View File

@ -1,30 +0,0 @@
# New ports collection makefile for: viewcvs
# Date created: Sun 02 Jul 2000
# Whom: will
#
# $FreeBSD$
#
PORTNAME= viewcvs
PORTVERSION= 0.9.4
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mnag@FreeBSD.org
COMMENT= Python version of Zeller's cvsweb
USE_PYTHON= yes
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
INSTDIR?= ${PORTNAME}-${PORTVERSION}
PLIST_SUB= INSTDIR=${INSTDIR}
do-install:
@(cd ${WRKSRC} && INSTDIR=${PREFIX}/${INSTDIR} ${PYTHON_CMD} viewcvs-install)
post-install:
@ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/${INSTDIR}:g" ${MASTERDIR}/pkg-message >${PKGMESSAGE}
@ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (viewcvs-0.9.4.tar.gz) = a1a09922165f2e2fec08527cdd18b76f
SHA256 (viewcvs-0.9.4.tar.gz) = 8d7e86a231b7f8a45d1cba12db302fa76b85ed0a118cc6f0afc053ed176d095d
SIZE (viewcvs-0.9.4.tar.gz) = 140290

View File

@ -1,109 +0,0 @@
--- lib/viewcvs.py.orig Tue Jan 15 09:35:55 2002
+++ lib/viewcvs.py Sun Jan 9 13:35:45 2005
@@ -174,6 +174,10 @@
# parse the query params into a dictionary (and use defaults)
query_dict = default_settings.copy()
for name, values in cgi.parse().items():
+ # validate the parameter
+ _validate_param(name, values[0])
+
+ # if we're here, then the parameter is okay
query_dict[name] = values[0]
# set up query strings, prefixed by question marks and ampersands
@@ -229,6 +233,77 @@
self.taginfo = taginfo
+def _validate_param(name, value):
+ """Validate whether the given value is acceptable for the param name.
+
+ If the value is not allowed, then an error response is generated, and
+ this function throws an exception. Otherwise, it simply returns None.
+ """
+
+ try:
+ validator = _legal_params[name]
+ except KeyError:
+ error('An illegal parameter name ("%s") was passed.' % cgi.escape(name))
+
+ # is the validator a regex?
+ if hasattr(validator, 'match'):
+ if not validator.match(value):
+ error('An illegal value ("%s") was passed as a parameter.' %
+ cgi.escape(value))
+ return
+
+ # the validator must be a function
+ validator(value)
+
+def _validate_cvsroot(value):
+ if not cfg.general.cvs_roots.has_key(value):
+ error('The CVS root "%s" is unknown.' % cgi.escape(value))
+
+def _validate_regex(value):
+ # hmm. there isn't anything that we can do here.
+
+ ### we need to watch the flow of these parameters through the system
+ ### to ensure they don't hit the page unescaped. otherwise, these
+ ### parameters could constitute a CSS attack.
+ pass
+
+# obvious things here. note that we don't need uppercase for alpha.
+_re_validate_alpha = re.compile('^[a-z]+$')
+_re_validate_number = re.compile('^[0-9]+$')
+
+# when comparing two revs, we sometimes construct REV:SYMBOL, so ':' is needed
+_re_validate_revnum = re.compile('^[-_.a-zA-Z0-9:]+$')
+
+# it appears that RFC 2045 also says these chars are legal: !#$%&'*+^{|}~`
+# but woah... I'll just leave them out for now
+_re_validate_mimetype = re.compile('^[-_.a-zA-Z0-9/]+$')
+
+# the legal query parameters and their validation functions
+_legal_params = {
+ 'cvsroot' : _validate_cvsroot,
+ 'search' : _validate_regex,
+
+ 'hideattic' : _re_validate_number,
+ 'sortby' : _re_validate_alpha,
+ 'sortdir' : _re_validate_alpha,
+ 'logsort' : _re_validate_alpha,
+ 'diff_format' : _re_validate_alpha,
+ 'only_with_tag' : _re_validate_revnum,
+ 'dir_pagestart' : _re_validate_number,
+ 'log_pagestart' : _re_validate_number,
+ 'hidecvsroot' : _re_validate_number,
+ 'annotate' : _re_validate_revnum,
+ 'graph' : _re_validate_revnum,
+ 'makeimage' : _re_validate_number,
+ 'tarball' : _re_validate_number,
+ 'r1' : _re_validate_revnum,
+ 'tr1' : _re_validate_revnum,
+ 'r2' : _re_validate_revnum,
+ 'tr2' : _re_validate_revnum,
+ 'rev' : _re_validate_revnum,
+ 'content-type' : _re_validate_mimetype,
+ }
+
class LogEntry:
"Hold state for each revision entry in an 'rlog' output."
def __init__(self, rev, date, author, state, changed, log):
@@ -478,7 +553,7 @@
def markup_stream_enscript(lang, fp):
sys.stdout.flush()
enscript = popen.pipe_cmds([(os.path.normpath(os.path.join(cfg.options.enscript_path,'enscript')),
- '--color', '-W', 'html', '-E' + lang, '-o',
+ '--color', '--language=html', '-E' + lang, '-o',
'-', '-'),
('sed', '-n', '/^<PRE>$/,/<\\/PRE>$/p')])
@@ -494,7 +569,7 @@
except IOError, v:
print "<h3>Failure during use of an external program:</h3>"
print "<pre>"
- print os.path.normpath(os.path.join(cfg.options.enscript_path,'enscript')) + " --color -W html -E"+lang+" -o - -"
+ print os.path.normpath(os.path.join(cfg.options.enscript_path,'enscript')) + " --color --language=html -E"+lang+" -o - -"
print "</pre>"
raise

View File

@ -1,49 +0,0 @@
--- viewcvs-install.orig Fri Dec 21 03:59:45 2001
+++ viewcvs-install Sun Aug 24 05:38:29 2003
@@ -51,7 +51,7 @@
""" % version
## installer defaults
-ROOT_DIR = "/usr/local/viewcvs-" + version
+ROOT_DIR = os.environ['INSTDIR']
## list of files for installation
@@ -65,11 +65,11 @@
("cgi/query.cgi", "cgi/query.cgi", 0755, 1, 0, 0),
("standalone.py", "standalone.py", 0755, 1, 0, 0),
- ("cgi/viewcvs.conf.dist", "viewcvs.conf", 0644, 1,
+ ("cgi/viewcvs.conf.dist", "viewcvs.conf.dist", 0644, 1,
"""Note: If you are upgrading from viewcvs-0.7 or earlier:
The section [text] has been removed from viewcvs.conf. The functionality
went into the new files in subdirectory templates.""", 0),
- ("cgi/cvsgraph.conf.dist", "cvsgraph.conf", 0644, 0, 1, 0),
+ ("cgi/cvsgraph.conf.dist", "cvsgraph.conf.dist", 0644, 0, 1, 0),
("lib/PyFontify.py", "lib/PyFontify.py", 0644, 0, 0, 1),
("lib/blame.py", "lib/blame.py", 0644, 0, 0, 1),
@@ -192,7 +192,7 @@
if type(prompt_replace) == type(""):
print prompt_replace
while 1:
- temp = raw_input("\n File %s\n exists and is different from source file.\n DO YOU WANT TO,\n overwrite [o]\n do not overwrite [d]\n view differences [v]: " % (dest_path))
+ temp = 'o'
print
temp = string.lower(temp[0])
@@ -245,10 +245,10 @@
print INFO_TEXT
## get the install path
- temp = raw_input("Installation Path [%s]: " % ROOT_DIR)
- temp = string.strip(temp)
- if len(temp):
- ROOT_DIR = temp
+ #temp = raw_input("Installation Path [%s]: " % ROOT_DIR)
+ #temp = string.strip(temp)
+ #if len(temp):
+ # ROOT_DIR = temp
## install the files
print

View File

@ -1,11 +0,0 @@
ViewCVS was inspired by cvsweb (Zeller's version). ViewCVS
can browse directories, change logs, and specific revisions
of files. It can display diffs between versions and show
selections of files based on tags or branches. In addition,
ViewCVS has "annotation" or "blame" support, and the
beginnings of Bonsai-like query facilities.
WWW: http://viewcvs.sourceforge.net/
Author: Greg Stein <gstein@lyra.org>
- Will <andrews@technologist.com>

View File

@ -1,12 +0,0 @@
If you would like to set up ViewCVS in a usable manner, all
you need to do is modify the configuration file, located at
%%INSTDIR%%/viewcvs.conf, to note where your
CVSROOT is, and then copy the actual CGI (located at
%%INSTDIR%%/cgi/viewcvs.cgi) to your cgi-bin.
Please notice that configuration files are installed as
".dist" and must be copied to their actual names prior to
be edited, e.g.:
$ cd %%INSTDIR%%
$ cp viewcvs.conf.dist viewcvs.conf
$ cp cvsgraph.conf.dist cvsgraph.conf
It's up to yo to check the ".dist" files after upgrades.

View File

@ -1,66 +0,0 @@
%%INSTDIR%%/cgi/query.cgi
%%INSTDIR%%/cgi/viewcvs.cgi
%%INSTDIR%%/cvsdbadmin
%%INSTDIR%%/cvsgraph.conf.dist
%%INSTDIR%%/doc/help_dirview.html
%%INSTDIR%%/doc/help_log.html
%%INSTDIR%%/doc/help_logtable.html
%%INSTDIR%%/doc/help_query.html
%%INSTDIR%%/doc/help_rootview.html
%%INSTDIR%%/doc/images/chalk.jpg
%%INSTDIR%%/doc/images/cvsgraph_16x16.png
%%INSTDIR%%/doc/images/cvsgraph_32x32.png
%%INSTDIR%%/doc/images/logo.png
%%INSTDIR%%/lib/PyFontify.py
%%INSTDIR%%/lib/PyFontify.pyc
%%INSTDIR%%/lib/accept.py
%%INSTDIR%%/lib/accept.pyc
%%INSTDIR%%/lib/apache_icons.py
%%INSTDIR%%/lib/apache_icons.pyc
%%INSTDIR%%/lib/blame.py
%%INSTDIR%%/lib/blame.pyc
%%INSTDIR%%/lib/compat.py
%%INSTDIR%%/lib/compat.pyc
%%INSTDIR%%/lib/config.py
%%INSTDIR%%/lib/config.pyc
%%INSTDIR%%/lib/cvsdb.py
%%INSTDIR%%/lib/cvsdb.pyc
%%INSTDIR%%/lib/dbi.py
%%INSTDIR%%/lib/dbi.pyc
%%INSTDIR%%/lib/debug.py
%%INSTDIR%%/lib/debug.pyc
%%INSTDIR%%/lib/ezt.py
%%INSTDIR%%/lib/ezt.pyc
%%INSTDIR%%/lib/popen.py
%%INSTDIR%%/lib/popen.pyc
%%INSTDIR%%/lib/py2html.py
%%INSTDIR%%/lib/py2html.pyc
%%INSTDIR%%/lib/query.py
%%INSTDIR%%/lib/query.pyc
%%INSTDIR%%/lib/rcsparse.py
%%INSTDIR%%/lib/rcsparse.pyc
%%INSTDIR%%/lib/rlog.py
%%INSTDIR%%/lib/rlog.pyc
%%INSTDIR%%/lib/viewcvs.py
%%INSTDIR%%/lib/viewcvs.pyc
%%INSTDIR%%/loginfo-handler
%%INSTDIR%%/make-database
%%INSTDIR%%/standalone.py
%%INSTDIR%%/templates/annotate.ezt
%%INSTDIR%%/templates/diff.ezt
%%INSTDIR%%/templates/dir_alternate.ezt
%%INSTDIR%%/templates/directory.ezt
%%INSTDIR%%/templates/footer.ezt
%%INSTDIR%%/templates/graph.ezt
%%INSTDIR%%/templates/header.ezt
%%INSTDIR%%/templates/log.ezt
%%INSTDIR%%/templates/log_table.ezt
%%INSTDIR%%/templates/markup.ezt
%%INSTDIR%%/templates/query.ezt
%%INSTDIR%%/viewcvs.conf.dist
@dirrm %%INSTDIR%%/templates
@dirrm %%INSTDIR%%/lib
@dirrm %%INSTDIR%%/doc/images
@dirrm %%INSTDIR%%/doc
@dirrm %%INSTDIR%%/cgi
@dirrm %%INSTDIR%%

View File

@ -5,7 +5,7 @@ If you are upgrading from the previous version of rancid look at
%%INSTDIR%%/share/rancid/UPGRADING.
If you would like to set up Rancid to be browseable from Web,
you need to install devel/cvsweb or devel/viewcvs.
you need to install devel/cvsweb or devel/viewvc.
For rancid looking-glass copy the actual CGIs (located at
%%INSTDIR%%/libexec/rancid/{lg.cgi lgform.cgi}) to your cgi-bin.

View File

@ -5,7 +5,7 @@ If you are upgrading from the previous version of rancid look at
%%INSTDIR%%/share/rancid/UPGRADING.
If you would like to set up Rancid to be browseable from Web,
you need to install devel/cvsweb or devel/viewcvs.
you need to install devel/cvsweb or devel/viewvc.
For rancid looking-glass copy the actual CGIs (located at
%%INSTDIR%%/libexec/rancid/{lg.cgi lgform.cgi}) to your cgi-bin.