- Update to Nagios 3.4.1.
PR: ports/168197 Submitted by: Jarrod Sayers <jarrod@downtools.com.au> (maintainer)
This commit is contained in:
parent
aaaa2a9891
commit
a184e8c330
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=297118
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= nagios
|
||||
PORTVERSION= 3.3.1
|
||||
PORTVERSION= 3.4.1
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-3.x/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (nagios-3.3.1.tar.gz) = c4e39cd31a8a9ee814df848fd933b8611465f749b48432672aef4ae5849d9652
|
||||
SIZE (nagios-3.3.1.tar.gz) = 1714630
|
||||
SHA256 (nagios-3.4.1.tar.gz) = a5c693f9af22410cc17d6da9c0df9bd65c47d787de3f937b5ccbda934131f8c8
|
||||
SIZE (nagios-3.4.1.tar.gz) = 1782817
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- html/Makefile.in.orig 2011-07-25 03:23:52.000000000 +0930
|
||||
+++ html/Makefile.in 2011-08-20 19:32:21.000000000 +0930
|
||||
@@ -33,52 +33,52 @@
|
||||
--- html/Makefile.in.orig 2012-02-14 07:10:42.000000000 +1030
|
||||
+++ html/Makefile.in 2012-05-21 21:34:09.000000000 +0930
|
||||
@@ -34,55 +34,55 @@
|
||||
devclean: distclean
|
||||
|
||||
install:
|
||||
@ -10,6 +10,7 @@
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/contexthelp
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/docs
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/docs/images
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/js
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/images
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/images/logos
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/includes
|
||||
@ -24,6 +25,7 @@
|
||||
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/contexthelp
|
||||
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/docs
|
||||
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/docs/images
|
||||
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/js
|
||||
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/images
|
||||
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/images/logos
|
||||
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/includes
|
||||
@ -48,6 +50,9 @@
|
||||
for file in contexthelp/*.html; \
|
||||
- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/contexthelp; done
|
||||
+ do $(INSTALL) -m 644 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/contexthelp; done
|
||||
for file in js/*.js; \
|
||||
- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/js; done
|
||||
+ do $(INSTALL) -m 644 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/js; done
|
||||
# for file in docs/*.html; \
|
||||
-# do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/docs; done
|
||||
+# do $(INSTALL) -m 644 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/docs; done
|
||||
@ -71,12 +76,11 @@
|
||||
+ do $(INSTALL) -m 644 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images/logos; done
|
||||
for file in includes/*.*; \
|
||||
- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes; done
|
||||
- for file in includes/rss/*; \
|
||||
- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss; done
|
||||
+ do $(INSTALL) -m 644 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes; done
|
||||
+ for file in includes/rss/*.*; \
|
||||
for file in includes/rss/*.*; \
|
||||
- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss; done
|
||||
+ do $(INSTALL) -m 644 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss; done
|
||||
for file in includes/rss/extlib/*; \
|
||||
for file in includes/rss/extlib/*.*; \
|
||||
- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss/extlib; done
|
||||
+ do $(INSTALL) -m 644 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss/extlib; done
|
||||
|
||||
|
@ -1,39 +1,38 @@
|
||||
--- html/main.php.orig 2011-07-26 12:46:26.000000000 +0930
|
||||
+++ html/main.php 2011-08-20 19:57:13.000000000 +0930
|
||||
@@ -36,36 +36,10 @@
|
||||
<div class="product">Nagios<sup><span style="font-size: small;">®</span></sup> Core<sup><span style="font-size: small;">™</span></sup></div>
|
||||
<div class="version">Version 3.3.1</div>
|
||||
<div class="releasedate">July 25, 2011</div>
|
||||
-<div class="checkforupdates"><a href="http://www.nagios.org/checkforupdates/?version=3.3.1&product=nagioscore" target="_blank">Check for updates</a></div>
|
||||
<!--<div class="whatsnew"><a href="http://go.nagios.com/nagioscore/whatsnew">Read what's new in Nagios Core 3</a></div>-->
|
||||
</div>
|
||||
|
||||
|
||||
-<div id="updateversioninfo">
|
||||
-<?php
|
||||
- $updateinfo=get_update_information();
|
||||
- //print_r($updateinfo);
|
||||
- //$updateinfo['update_checks_enabled']=false;
|
||||
- //$updateinfo['update_available']=true;
|
||||
- if($updateinfo['update_checks_enabled']==false && $this_version!=$updateinfo['update_version']){
|
||||
-?>
|
||||
- <div class="updatechecksdisabled">
|
||||
- <div class="warningmessage">Warning: Automatic Update Checks are Disabled!</div>
|
||||
- <div class="submessage">Disabling update checks presents a possible security risk. Visit <a href="http://www.nagios.org/" target="_blank">nagios.org</a> to check for updates manually or enable update checks in your Nagios config file.</a></div>
|
||||
- </div>
|
||||
-<?php
|
||||
- }
|
||||
- else if($updateinfo['update_available']==true){
|
||||
-?>
|
||||
- <div class="updateavailable">
|
||||
- <div class="updatemessage">A new version of Nagios Core is available!</div>
|
||||
- <div class="submessage">Visit <a href="http://www.nagios.org/download/" target="_blank">nagios.org</a> to download Nagios <?php echo $updateinfo['update_version'];?>.</div>
|
||||
- </div>
|
||||
-<?php
|
||||
- }
|
||||
-?>
|
||||
-</div>
|
||||
-
|
||||
<div id="splashboxes">
|
||||
<div id="splashbox1" class="splashbox">
|
||||
<h2>Get Started</h2>
|
||||
--- html/main.php.orig 2012-05-12 09:30:53.000000000 +0930
|
||||
+++ html/main.php 2012-05-21 21:37:23.000000000 +0930
|
||||
@@ -40,35 +40,10 @@
|
||||
<div class="product">Nagios<sup><span style="font-size: small;">®</span></sup> Core<sup><span style="font-size: small;">™</span></sup></div>
|
||||
<div class="version">Version 3.4.1</div>
|
||||
<div class="releasedate">May 11, 2012</div>
|
||||
-<div class="checkforupdates"><a href="http://www.nagios.org/checkforupdates/?version=3.4.1&product=nagioscore" target="_blank">Check for updates</a></div>
|
||||
<!--<div class="whatsnew"><a href="http://go.nagios.com/nagioscore/whatsnew">Read what's new in Nagios Core 3</a></div>-->
|
||||
</div>
|
||||
|
||||
|
||||
-<div id="updateversioninfo">
|
||||
-<?php
|
||||
- $updateinfo=get_update_information();
|
||||
- //print_r($updateinfo);
|
||||
- //$updateinfo['update_checks_enabled']=false;
|
||||
- //$updateinfo['update_available']=true;
|
||||
- if($updateinfo['update_checks_enabled']==false){
|
||||
-?>
|
||||
- <div class="updatechecksdisabled">
|
||||
- <div class="warningmessage">Warning: Automatic Update Checks are Disabled!</div>
|
||||
- <div class="submessage">Disabling update checks presents a possible security risk. Visit <a href="http://www.nagios.org/" target="_blank">nagios.org</a> to check for updates manually or enable update checks in your Nagios config file.</a></div>
|
||||
- </div>
|
||||
-<?php
|
||||
- }
|
||||
- else if($updateinfo['update_available']==true && $this_version!=$updateinfo['update_version']){
|
||||
-?>
|
||||
- <div class="updateavailable">
|
||||
- <div class="updatemessage">A new version of Nagios Core is available!</div>
|
||||
- <div class="submessage">Visit <a href="http://www.nagios.org/download/" target="_blank">nagios.org</a> to download Nagios <?php echo $updateinfo['update_version'];?>.</div>
|
||||
- </div>
|
||||
-<?php
|
||||
- }
|
||||
-?>
|
||||
-</div>
|
||||
|
||||
|
||||
|
||||
|
@ -97,12 +97,17 @@ etc/nagios/resource.cfg-sample
|
||||
%%NAGIOSWWWDIR%%/contexthelp/N5.html
|
||||
%%NAGIOSWWWDIR%%/contexthelp/N6.html
|
||||
%%NAGIOSWWWDIR%%/contexthelp/N7.html
|
||||
%%NAGIOSWWWDIR%%/images/Nagios-clearbg.png
|
||||
%%NAGIOSWWWDIR%%/images/NagiosEnterprises-whitebg-112x46.png
|
||||
%%NAGIOSWWWDIR%%/images/ack.gif
|
||||
%%NAGIOSWWWDIR%%/images/action-graph.gif
|
||||
%%NAGIOSWWWDIR%%/images/action-nagios.gif
|
||||
%%NAGIOSWWWDIR%%/images/action-orig.gif
|
||||
%%NAGIOSWWWDIR%%/images/action.gif
|
||||
%%NAGIOSWWWDIR%%/images/b_first2.png
|
||||
%%NAGIOSWWWDIR%%/images/b_last2.png
|
||||
%%NAGIOSWWWDIR%%/images/b_next2.png
|
||||
%%NAGIOSWWWDIR%%/images/b_prev2.png
|
||||
%%NAGIOSWWWDIR%%/images/command.png
|
||||
%%NAGIOSWWWDIR%%/images/comment.gif
|
||||
%%NAGIOSWWWDIR%%/images/contexthelp1.gif
|
||||
@ -349,10 +354,14 @@ etc/nagios/resource.cfg-sample
|
||||
%%NAGIOSWWWDIR%%/includes/rss/rss_fetch.inc
|
||||
%%NAGIOSWWWDIR%%/includes/rss/rss_parse.inc
|
||||
%%NAGIOSWWWDIR%%/includes/rss/rss_utils.inc
|
||||
%%NAGIOSWWWDIR%%/includes/jquery-1.7.1.min.js
|
||||
%%NAGIOSWWWDIR%%/includes/utils.inc.php
|
||||
%%NAGIOSWWWDIR%%/index.php
|
||||
%%NAGIOSWWWDIR%%/js/jquery-1.7.1.min.js
|
||||
%%NAGIOSWWWDIR%%/main.php
|
||||
%%NAGIOSWWWDIR%%/robots.txt
|
||||
%%NAGIOSWWWDIR%%/rss-corefeed.php
|
||||
%%NAGIOSWWWDIR%%/rss-newsfeed.php
|
||||
%%NAGIOSWWWDIR%%/side.php
|
||||
%%NAGIOSWWWDIR%%/stylesheets/avail.css
|
||||
%%NAGIOSWWWDIR%%/stylesheets/checksanity.css
|
||||
@ -382,6 +391,7 @@ etc/nagios/resource.cfg-sample
|
||||
@dirrm %%NAGIOSWWWDIR%%/includes/rss/extlib
|
||||
@dirrm %%NAGIOSWWWDIR%%/includes/rss
|
||||
@dirrm %%NAGIOSWWWDIR%%/includes
|
||||
@dirrm %%NAGIOSWWWDIR%%/js
|
||||
@dirrm %%NAGIOSWWWDIR%%/media
|
||||
@dirrm %%NAGIOSWWWDIR%%/ssi
|
||||
@dirrm %%NAGIOSWWWDIR%%/stylesheets
|
||||
|
Loading…
Reference in New Issue
Block a user