Upgrade to 0.8.16.
This commit is contained in:
parent
fc5e2794f0
commit
a17a3ee0b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10808
@ -1,12 +1,12 @@
|
||||
# New ports collection makefile for: icewm
|
||||
# Version required: 0.8.14
|
||||
# Version required: 0.8.16
|
||||
# Date created: 10 August 1997
|
||||
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
|
||||
#
|
||||
# $Id: Makefile,v 1.5 1998/04/04 14:31:27 vanilla Exp $
|
||||
# $Id: Makefile,v 1.6 1998/04/28 14:51:48 mph Exp $
|
||||
#
|
||||
|
||||
DISTNAME= icewm-0.8.14
|
||||
DISTNAME= icewm-0.8.16
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://ixtas.fri.uni-lj.si/%7Emarkom/icewm/
|
||||
EXTRACT_SUFX= .src.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
MD5 (icewm-0.8.14.src.tar.gz) = 975a30ed64279d7e8a31a2ac2a09e92a
|
||||
MD5 (icewm-0.8.16.src.tar.gz) = 869842bea85f43101d0d68420846b510
|
||||
|
@ -1,18 +1,29 @@
|
||||
--- src/Makefile.orig Fri Apr 3 17:12:54 1998
|
||||
+++ src/Makefile Fri Apr 3 17:14:33 1998
|
||||
@@ -1,8 +1,8 @@
|
||||
include ../VERSION
|
||||
|
||||
--- src/Makefile.orig Mon Apr 6 20:30:21 1998
|
||||
+++ src/Makefile Fri May 1 08:34:15 1998
|
||||
@@ -3,9 +3,9 @@
|
||||
# Linux
|
||||
CXX = g++
|
||||
LD = gcc
|
||||
-CXXOPTS = -pipe $(WARN)
|
||||
-INCSDIR = -I/usr/X11R6/include
|
||||
-LIBSDIR = -L/usr/X11R6/lib
|
||||
+CXXOPTS = $(CFLAGS) $(WARN)
|
||||
+INCSDIR = -I$(PREFIX)/include
|
||||
+LIBSDIR = -L$(PREFIX)/lib
|
||||
|
||||
# HPUX
|
||||
#INCSDIR = -I/usr/include/X11R5
|
||||
@@ -36,7 +36,7 @@
|
||||
#OPTIMIZE = -g
|
||||
#XPMINCDIR = -I../../include
|
||||
#XPMLIBDIR = -L../../lib
|
||||
@@ -34,7 +34,7 @@
|
||||
SHAPEDEF = -DSHAPE
|
||||
SHAPELIB = -lXext
|
||||
|
||||
-DEBUG = -DDEBUG
|
||||
+#DEBUG = -DDEBUG
|
||||
|
||||
# executable extenstion
|
||||
EXEEXT=
|
||||
@@ -48,7 +48,7 @@
|
||||
#OPTIMIZE = -g
|
||||
#OPTIMIZE = -O -g
|
||||
#OPTIMIZE = -O -g -pg
|
||||
-OPTIMIZE = -O
|
||||
|
@ -1,4 +1,7 @@
|
||||
bin/icewm
|
||||
lib/X11/icewm/menu
|
||||
lib/X11/icewm/preferences
|
||||
lib/X11/icewm/winoptions
|
||||
lib/X11/icewm/icons/app_16x16.xpm
|
||||
lib/X11/icewm/icons/app_32x32.xpm
|
||||
lib/X11/icewm/icons/bomb_16x16.xpm
|
||||
@ -38,8 +41,6 @@ lib/X11/icewm/ledclock/n9.xpm
|
||||
lib/X11/icewm/ledclock/p.xpm
|
||||
lib/X11/icewm/ledclock/slash.xpm
|
||||
lib/X11/icewm/ledclock/space.xpm
|
||||
lib/X11/icewm/menu
|
||||
lib/X11/icewm/preferences
|
||||
lib/X11/icewm/taskbar/bsd-daemon.xpm
|
||||
lib/X11/icewm/taskbar/linux.xpm
|
||||
lib/X11/icewm/taskbar/mail.xpm
|
||||
@ -183,7 +184,6 @@ lib/X11/icewm/themes/win95/default.theme
|
||||
lib/X11/icewm/themes/win95/maximize.xpm
|
||||
lib/X11/icewm/themes/win95/minimize.xpm
|
||||
lib/X11/icewm/themes/win95/restore.xpm
|
||||
lib/X11/icewm/winoptions
|
||||
@dirrm lib/X11/icewm/icons
|
||||
@dirrm lib/X11/icewm/ledclock
|
||||
@dirrm lib/X11/icewm/taskbar
|
||||
|
Loading…
Reference in New Issue
Block a user