Remove expired port:
2019-03-05 x11-toolkits/gtkextra2: Broken for more than 6 months
This commit is contained in:
parent
131121e39a
commit
a16f1503c2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495034
1
MOVED
1
MOVED
@ -11678,3 +11678,4 @@ textproc/elixir-ex_doc||2019-03-06|Has expired: Broken for more than 6 months
|
||||
x11/altyo||2019-03-06|Has expired: Broken for more than 6 months
|
||||
x11/pantheon-terminal||2019-03-06|Has expired: Broken for more than 6 months
|
||||
x11-wm/e-module-everything-websearch||2019-03-06|Has expired: Broken for more than 6 months
|
||||
x11-toolkits/gtkextra2||2019-03-08|Has expired: Broken for more than 6 months
|
||||
|
@ -43,7 +43,6 @@
|
||||
SUBDIR += gtkada
|
||||
SUBDIR += gtkada3
|
||||
SUBDIR += gtkdatabox
|
||||
SUBDIR += gtkextra2
|
||||
SUBDIR += gtkglarea2
|
||||
SUBDIR += gtkglext
|
||||
SUBDIR += gtkglextmm
|
||||
|
@ -1,45 +0,0 @@
|
||||
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gtkextra
|
||||
PORTVERSION= 2.1.2
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME:S/gtk/gtk+/}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Useful widget set complementary to GTK+ 2.0
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN= Does not build: libgtkextra-x11-2.0.so: undefined reference to `gtkextra_BOOLEAN__BOXED_BOXED'
|
||||
DEPRECATED= Broken for more than 6 months
|
||||
EXPIRATION_DATE= 2019-03-05
|
||||
|
||||
USES= gmake libtool pathfix pkgconfig
|
||||
USE_GNOME= gtk20
|
||||
GNU_CONFIGURE= yes
|
||||
USE_CSTD= gnu89
|
||||
USE_LDCONFIG= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/gtkextra2
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
|
||||
${WRKSRC}/gtkextra/gtkcharsel.c
|
||||
|
||||
post-install-DOCS-on:
|
||||
.for d in reference tutorial
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/${d}
|
||||
@(cd ${WRKSRC}/docs/${d} && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (gtk+extra-2.1.2.tar.gz) = bfc9603e2023ea071f2661ecc29e52c94b1beed6b69deae45b466df7f5b2ce55
|
||||
SIZE (gtk+extra-2.1.2.tar.gz) = 1274946
|
@ -1,16 +0,0 @@
|
||||
--- gtkextra/Makefile.in.orig 2016-02-14 18:23:03 UTC
|
||||
+++ gtkextra/Makefile.in
|
||||
@@ -1028,11 +1028,11 @@ uninstall-am: uninstall-gtkextraincludeH
|
||||
$(libgtkextra_x11_2_0_la_OBJECTS) $(libgtkextra_linux_fb_2_0_la_OBJECTS) $(libgtkextra_win32_2_0_la_OBJECTS): ${gtkextra_built_public_sources} ${gtkextra_built_private_headers}
|
||||
|
||||
$(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
|
||||
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
|
||||
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
|
||||
&& mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
|
||||
|| ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
$(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
|
||||
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
|
||||
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
|
||||
&& mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
|
||||
|| ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- gtkextra/gtkcolorcombo.c.orig 2004-09-16 17:48:05 UTC
|
||||
+++ gtkextra/gtkcolorcombo.c
|
||||
@@ -146,7 +146,7 @@ gtk_color_combo_class_init (GtkColorComb
|
||||
GTK_CLASS_TYPE(object_class),
|
||||
GTK_SIGNAL_OFFSET(GtkColorComboClass,
|
||||
changed),
|
||||
- gtkextra_VOID__INT_BOXED,
|
||||
+ gtkextra_VOID__BOXED_BOXED,
|
||||
GTK_TYPE_NONE,
|
||||
2, GTK_TYPE_INT, GDK_TYPE_COLOR);
|
||||
|
@ -1,27 +0,0 @@
|
||||
--- gtkextra/gtkitementry.c.orig 2010-03-13 05:49:00 UTC
|
||||
+++ gtkextra/gtkitementry.c
|
||||
@@ -131,7 +131,6 @@ static void gtk_entry_draw_curso
|
||||
static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
|
||||
gboolean include_preedit);
|
||||
static void gtk_entry_queue_draw (GtkEntry *entry);
|
||||
-static void gtk_entry_reset_im_context (GtkEntry *entry);
|
||||
static void gtk_entry_recompute (GtkEntry *entry);
|
||||
static void gtk_entry_get_cursor_locations (GtkEntry *entry,
|
||||
CursorType type,
|
||||
@@ -1755,16 +1754,6 @@ gtk_entry_queue_draw (GtkEntry *entry)
|
||||
}
|
||||
|
||||
static void
|
||||
-gtk_entry_reset_im_context (GtkEntry *entry)
|
||||
-{
|
||||
- if (entry->need_im_reset)
|
||||
- {
|
||||
- entry->need_im_reset = 0;
|
||||
- gtk_im_context_reset (entry->im_context);
|
||||
- }
|
||||
-}
|
||||
-
|
||||
-static void
|
||||
gtk_entry_get_cursor_locations (GtkEntry *entry,
|
||||
CursorType type,
|
||||
gint *strong_x,
|
@ -1,5 +0,0 @@
|
||||
GtkExtra is a useful set of widgets for creating GUI's for the X
|
||||
Window System using GTK+ 2.0. You can use it complementary to GTK+ 2.0
|
||||
and it is written in C.
|
||||
|
||||
WWW: http://gtkextra.sourceforge.net/
|
@ -1,53 +0,0 @@
|
||||
include/gtkextra-2.0/gtkextra/gtkbordercombo.h
|
||||
include/gtkextra-2.0/gtkextra/gtkcharsel.h
|
||||
include/gtkextra-2.0/gtkextra/gtkcheckitem.h
|
||||
include/gtkextra-2.0/gtkextra/gtkcolorcombo.h
|
||||
include/gtkextra-2.0/gtkextra/gtkcombobutton.h
|
||||
include/gtkextra-2.0/gtkextra/gtkdirtree.h
|
||||
include/gtkextra-2.0/gtkextra/gtkextra-marshal.h
|
||||
include/gtkextra-2.0/gtkextra/gtkextra.h
|
||||
include/gtkextra-2.0/gtkextra/gtkextrafeatures.h
|
||||
include/gtkextra-2.0/gtkextra/gtkextraicons.h
|
||||
include/gtkextra-2.0/gtkextra/gtkextratypebuiltins.h
|
||||
include/gtkextra-2.0/gtkextra/gtkfileicons.h
|
||||
include/gtkextra-2.0/gtkextra/gtkfilelist.h
|
||||
include/gtkextra-2.0/gtkextra/gtkfontcombo.h
|
||||
include/gtkextra-2.0/gtkextra/gtkiconfilesel.h
|
||||
include/gtkextra-2.0/gtkextra/gtkiconlist.h
|
||||
include/gtkextra-2.0/gtkextra/gtkitementry.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplot.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplot3d.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotarray.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotbar.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotbox.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotbubble.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcandle.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcanvas.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcanvasellipse.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcanvasline.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcanvaspixmap.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcanvasplot.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcanvasrectangle.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcanvastext.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotcsurface.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotdata.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotdt.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotflux.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotgdk.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotpc.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotpixmap.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotpolar.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotprint.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotps.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotsegment.h
|
||||
include/gtkextra-2.0/gtkextra/gtkplotsurface.h
|
||||
include/gtkextra-2.0/gtkextra/gtkpsfont.h
|
||||
include/gtkextra-2.0/gtkextra/gtksheet.h
|
||||
include/gtkextra-2.0/gtkextra/gtktogglecombo.h
|
||||
lib/libgtkextra-x11-2.0.a
|
||||
lib/libgtkextra-x11-2.0.so
|
||||
lib/libgtkextra-x11-2.0.so.1
|
||||
lib/libgtkextra-x11-2.0.so.1.0.1
|
||||
libdata/pkgconfig/gtkextra-2.0.pc
|
||||
%%PORTDOCS%%@dir %%DOCSDIR%%/reference
|
||||
%%PORTDOCS%%@dir %%DOCSDIR%%/tutorial
|
Loading…
Reference in New Issue
Block a user