- Add WITH_ESOUND option (enables game sound)

- The PR implemented the sound option as a new moon-buggy-esound port,
  which I converted to the WITH_ESOUND option (that sets PKGNAMESUFFIX) [1]

Submitted by:		Ralf Becker <ralf@akk.org> (maintainer)
Approved by:		maintainer timeout (12 days) [1]
PR:			ports/81667
This commit is contained in:
Simon Barner 2005-06-13 11:32:32 +00:00
parent b29e7ca107
commit a1556bb714
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=137397
3 changed files with 33 additions and 1 deletions

View File

@ -9,12 +9,22 @@ PORTNAME= moon-buggy
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://www.seehuhn.de/data/
.if defined (WITH_ESOUND)
PKGNAMESUFFIX= "-esound"
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
${PORTNAME}-sound-${PORTVERSION}${EXTRACT_SUFX}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.ac
.endif
MAINTAINER= ralf@akk.org
COMMENT= Drive a buggy across the moons surface
.if defined (WITH_ESOUND)
LIB_DEPENDS= esd:${PORTSDIR}/audio/esound:install
.endif
USE_AUTOCONF_VER= 259
CONFIGURE_ARGS= --prefix=${PREFIX} \
CONFIGURE_ARGS= --prefix=${PREFIX} \
--sharedstatedir=/var/games\
--with-setgid=games
@ -22,6 +32,15 @@ MAN6= moon-buggy.6
INFO= moon-buggy
PLIST_FILES= bin/moon-buggy
.if defined (WITH_ESOUND)
PLIST_FILES+= share/moon-buggy/jump.wav \
share/moon-buggy/laser.wav \
share/moon-buggy/crash.wav
PLIST_DIRS+= share/moon-buggy
pre-patch:
cd ${WRKSRC} && ${PATCH} -p1 < sound.patch
.endif
# make package will fail without doing this
post-install:

View File

@ -1,2 +1,4 @@
MD5 (moon-buggy-1.0.tar.gz) = 4da97ea40eca686f6f8b164d8b927e38
SIZE (moon-buggy-1.0.tar.gz) = 259734
MD5 (moon-buggy-sound-1.0.tar.gz) = ea3a5b7035cb86c1489e8a5c2c962702
SIZE (moon-buggy-sound-1.0.tar.gz) = 13252

View File

@ -0,0 +1,11 @@
--- configure.ac Mon May 30 13:36:12 2005
+++ configure.ac.orig Mon May 30 13:35:21 2005
@@ -67,7 +67,7 @@
AM_CONDITIONAL(short_getopt, test "x$ac_cv_func_getopt_long" != xyes)
-SOUND_DIR='$(datadir)/sounds/moon-buggy'
+SOUND_DIR='$(datadir)/moon-buggy'
AC_SUBST(SOUND_DIR)
AC_CONFIG_FILES([Makefile])