- unbreak with new gcc on -current ('using namespace std')
- CFLAGS/env police
- condense port's Makefile
- install additional shell script
- install documentation (honour NOPORTDOCS)

PR:		48464
Submitted by:	Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
Tested on:	-STABLE, -CURRENT
This commit is contained in:
Ernst de Haan 2003-03-03 21:36:44 +00:00
parent e1992c34cf
commit a127113f1b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76819
4 changed files with 52 additions and 8 deletions

View File

@ -13,15 +13,20 @@ MASTER_SITES= http://artho.com/jlint/ \
MAINTAINER= znerd@FreeBSD.org
PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
TARGET_DIR?= ${PREFIX}/bin
USE_REINPLACE= YES
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' ${WRKSRC}/jlint.sh
do-install:
${MKDIR} ${TARGET_DIR}
${CP} ${WRKSRC}/jlint ${TARGET_DIR}
${CP} ${WRKSRC}/antic ${TARGET_DIR}
${CHMOD} 755 ${TARGET_DIR}/jlint ${TARGET_DIR}/antic
${INSTALL_PROGRAM} ${WRKSRC}/jlint ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/antic ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/jlint.sh ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/manual.pdf ${WRKSRC}/manual.html ${DOCSDIR}
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,22 @@
--- Makefile.orig Wed Feb 19 17:20:06 2003
+++ Makefile Wed Feb 19 17:21:13 2003
@@ -3,8 +3,8 @@
# Makefile for Unix and GNU/Linux with gcc/g++ compiler
# Edit here:
-CC=gcc
-CPP=g++
+CC?=gcc
+CPP=$(CXX)
# Hints:
# if you use egcs-2.90.* version of GCC please add option -fno-exceptions
@@ -18,7 +18,7 @@
# Optimized version
-CFLAGS = -c -Wall -O2 -g -DSLIST
+CFLAGS += -c
# add -DHASH_TABLE for extra speed (may sometimes produce inconsistent results)
# Optimized version with switched off asserts

View File

@ -0,0 +1,13 @@
--- field_desc.hh.orig Wed Feb 19 17:20:15 2003
+++ field_desc.hh Wed Feb 19 17:22:10 2003
@@ -1,10 +1,7 @@
#ifndef FIELD_DESC_HH
#define FIELD_DESC_HH
-#ifdef VISUAL_CPP
using namespace std;
-#pragma warning (disable : 4786)
-#endif
#include "component_desc.hh"
#include "utf_string.hh"

View File

@ -1,2 +1,6 @@
%%T%%/jlint
%%T%%/antic
bin/jlint
bin/jlint.sh
bin/antic
%%PORTDOCS%%share/doc/jlint/manual.pdf
%%PORTDOCS%%share/doc/jlint/manual.html
%%PORTDOCS%%@dirrm share/doc/jlint