Fix building with libressl-devel and add missing dependency on libidn.

PR:		216785
Approved by:	jharris@widomaker.com (maintainer), swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D9672
This commit is contained in:
Matthew Rezny 2017-02-22 19:02:51 +00:00
parent 598dae77a2
commit a1013b3f2e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=434630
2 changed files with 15 additions and 2 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= lynx
PORTVERSION= 2.8.8.2
PORTREVISION= 5
PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= http://invisible-mirror.net/archives/lynx/tarballs/ \
@ -15,6 +15,8 @@ COMMENT= Non-graphical, text-based World-Wide Web client
LICENSE= GPLv2
LIB_DEPENDS= libidn.so:dns/libidn
CONFLICTS= lynx-2.8.[8-9]d*
USES= cpe ncurses shebangfix tar:bzip2
@ -59,7 +61,7 @@ SSL_USES= ssl
post-install-DOCS-on:
# Fix some stage symlinks
.for doc in COPYHEADER COPYING COPYHEADER.asc COPYING.asc
(cd ${STAGEDIR}${L_HELP} && ln -sf ../doc/lynx/${doc} .)
(cd ${STAGEDIR}${L_HELP} && ${LN} -sf ../doc/lynx/${doc} .)
.endfor
.include <bsd.port.pre.mk>

View File

@ -0,0 +1,11 @@
--- WWW/Library/Implementation/HTTP.c.orig 2017-02-09 21:20:27 UTC
+++ WWW/Library/Implementation/HTTP.c
@@ -721,7 +722,7 @@ static int HTLoadHTTP(const char *arg,
#elif SSLEAY_VERSION_NUMBER >= 0x0900
#ifndef USE_NSS_COMPAT_INCL
if (!try_tls) {
- handle->options |= SSL_OP_NO_TLSv1;
+ SSL_set_options(handle, SSL_OP_NO_TLSv1);
#if OPENSSL_VERSION_NUMBER >= 0x0090806fL && !defined(OPENSSL_NO_TLSEXT)
} else {
int ret = (int) SSL_set_tlsext_host_name(handle, ssl_host);