3D Vector-graphics Space Invaders clone for X

This commit is contained in:
Chris D. Faulhaber 2000-01-23 03:04:22 +00:00
parent 3aaa2f02d0
commit a0f8d175ea
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24966
7 changed files with 65 additions and 0 deletions

View File

@ -0,0 +1,22 @@
# New ports collection makefile for: xinv3d
# Version required: 1.1
# Date created: 21 January 2000
# Whom: Chris D. Faulhaber <jedgar@FreeBSD.org>
#
# $FreeBSD$
#
DISTNAME= xinv3d.1.1
PKGNAME= xinvaders3d-1.1
CATEGORIES= games
MASTER_SITES= http://www.fiu.edu/~dllopi01/
MAINTAINER= jedgar@FreeBSD.org
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/xinv3d
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xinv3d ${PREFIX}/bin
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (xinv3d.1.1.tar.gz) = d7807498116603d855f31cbd5ccd91ef

View File

@ -0,0 +1,25 @@
--- Makefile.orig Thu Jan 20 23:49:54 2000
+++ Makefile Fri Jan 21 23:20:08 2000
@@ -1,6 +1,6 @@
all: game
-CC = gcc
+CC?= gcc
XLIB = -L/usr/X11R6/lib -I/usr/X11R6/include
LIBS = -lm -lX11
OBJS = main.o game.o aliens.o player.o effects.o \
@@ -8,12 +8,12 @@
vec4x1.o mat4x4.o
DEPENDS =
#CFLAGS = -g -Wall -ansi
-CFLAGS = -ansi
+#CFLAGS = -ansi
#OPTIONS = -D_GNU_SOURCE -DGAME_LINUX_X11 -DGAME_DEBUG
OPTIONS= -DGAME_LINUX_X11
.c.o: $(DEPENDS)
- $(CC) -c $(CFLAGS) $(OPTIONS) $< -o $@
+ $(CC) -c $(CFLAGS) $(OPTIONS) $(XLIB) $< -o $@
game: $(OBJS) $(DEPENDS)
$(CC) -g -o xinv3d $(OBJS) $(XLIB) $(LIBS) $(OPTIONS)

View File

@ -0,0 +1,11 @@
--- vec4x1.c.orig Thu Jan 20 23:26:05 2000
+++ vec4x1.c Fri Jan 21 23:16:28 2000
@@ -160,7 +160,7 @@
{
float len;
- len = (float) sqrt ( (a[0] * a[0]) + (a[1] * a[1]) + (a[2] * a[2]) );
+ len = (float) sqrt ( (a[0] * a[0]) + (a[1] * a[1]) + (a[2] * a[2]) ) + 0.00001;
a[0] /= len;
a[1] /= len;

View File

@ -0,0 +1 @@
3D Vector-graphics Space Invaders clone for X

View File

@ -0,0 +1,4 @@
XInvaders 3D is a 3D Vector-graphics Space Invaders clone
for X.
WWW: http://www.fiu.edu/~dllopi01/xinv3d.htm

View File

@ -0,0 +1 @@
bin/xinv3d