- Update to 4.0

PR:		ports/74633
Submitted by:	rushani (maintainer)
This commit is contained in:
Pav Lucistnik 2004-12-04 23:56:24 +00:00
parent bc58fccd29
commit a0e5f7ed92
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=123150
3 changed files with 24 additions and 19 deletions

View File

@ -15,6 +15,11 @@
#
# Core funcionality:
#
# SCPONLY_DEFAULT_CHDIR=DIR
# default: undefined
# example: public_html
# define if you want to make users `cd' to this directory after authentication
#
# WITHOUT_SCPONLY_WILDCARDS
# default: undefined
# define if you want to disable wildcard processing.
@ -39,6 +44,10 @@
# default: undefined
# define if you want to enable rsync compatibility.
#
# WITH_SCPONLY_SVN
# default: undefined
# define if you want to enable subversion compatibility.
#
# WITH_SCPONLY_UNISON
# default: undefined
# define if you want to enable unison compatibility.
@ -53,7 +62,7 @@
# to be installed.
PORTNAME= scponly
PORTVERSION= 3.11
PORTVERSION= 4.0
PORTREVISION= 0
CATEGORIES= shells
MASTER_SITES= http://www.sublimation.org/scponly/
@ -69,6 +78,10 @@ PLIST_SUB+= SCPONLY_CHROOT="@comment "
.include <bsd.port.pre.mk>
.if defined(SCPONLY_DEFAULT_CHDIR) && !empty(SCPONLY_DEFAULT_CHDIR)
CONFIGURE_ARGS+=--with-default-chdir=${SCPONLY_DEFAULT_CHDIR}
.endif
.if defined(WITHOUT_SCPONLY_WILDCARDS)
CONFIGURE_ARGS+=--disable-wildcards
.endif
@ -91,11 +104,17 @@ CONFIGURE_ARGS+=--enable-chrooted-binary
.endif
.if defined(WITH_SCPONLY_RSYNC)
BUILD_DEPENDS= rsync:${PORTSDIR}/net/rsync
RUN_DEPENDS= ${BUILD_DEPENDS}
BUILD_DEPENDS+= rsync:${PORTSDIR}/net/rsync
RUN_DEPENDS+= ${BUILD_DEPENDS}
CONFIGURE_ARGS+=--enable-rsync-compat
.endif
.if defined(WITH_SCPONLY_SVN)
BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
RUN_DEPENDS+= ${BUILD_DEPENDS}
CONFIGURE_ARGS+=--enable-svn-compat
.endif
.if defined(WITH_SCPONLY_UNISON)
BUILD_DEPENDS+= unison:${PORTSDIR}/net/unison
RUN_DEPENDS+= ${BUILD_DEPENDS}

View File

@ -1,2 +1,2 @@
MD5 (scponly-3.11.tgz) = cdbbc570c2bf3cad33ecf66d0af41372
SIZE (scponly-3.11.tgz) = 83767
MD5 (scponly-4.0.tgz) = 1706732945996865ed0cccd440b64fc1
SIZE (scponly-4.0.tgz) = 85053

View File

@ -1,14 +0,0 @@
--- scponly.c.orig Mon Mar 22 14:30:38 2004
+++ scponly.c Sat Jul 17 19:43:04 2004
@@ -442,9 +442,9 @@
(-1 == asprintf( &env[0], "HOME=%s", homedir)))
{
syslog(LOG_ERR, "could not set HOME environment variable(%s))", logstamp());
- exit(EXIT_FAIL);
+ exit(EXIT_FAILURE);
}
- if (debug)
+ if (debuglevel)
syslog(LOG_DEBUG, "set HOME environment variable to %s (%s))", env[0], logstamp());
#endif