New port: science/py-gsd: GSD (General Simulation Data) file format for Python
This commit is contained in:
parent
864c3d97dd
commit
a0d8c948c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=469829
@ -169,6 +169,7 @@
|
||||
SUBDIR += py-cdo
|
||||
SUBDIR += py-coards
|
||||
SUBDIR += py-dlib
|
||||
SUBDIR += py-gsd
|
||||
SUBDIR += py-h5py
|
||||
SUBDIR += py-hcluster
|
||||
SUBDIR += py-mdp
|
||||
|
21
science/py-gsd/Makefile
Normal file
21
science/py-gsd/Makefile
Normal file
@ -0,0 +1,21 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gsd
|
||||
DISTVERSION= 1.5.2
|
||||
CATEGORIES= science python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= GSD (General Simulation Data) file format for Python
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYNUMPY}
|
||||
BUILD_DEPENDS= ${PYNUMPY}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
.include <bsd.port.mk>
|
3
science/py-gsd/distinfo
Normal file
3
science/py-gsd/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1526243034
|
||||
SHA256 (gsd-1.5.2.tar.gz) = 0ce73a9bc7b79968a2b96cc2b0934e2cbe11700adbd02b4b492fea1e3d4d51f4
|
||||
SIZE (gsd-1.5.2.tar.gz) = 198774
|
10
science/py-gsd/files/patch-gsd_gsd.c
Normal file
10
science/py-gsd/files/patch-gsd_gsd.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- gsd/gsd.c.orig 2018-05-13 20:11:47 UTC
|
||||
+++ gsd/gsd.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <stdio.h>
|
||||
#include <fcntl.h>
|
||||
#include <errno.h>
|
||||
+#include <sys/stat.h>
|
||||
|
||||
#include "gsd.h"
|
||||
|
22
science/py-gsd/pkg-descr
Normal file
22
science/py-gsd/pkg-descr
Normal file
@ -0,0 +1,22 @@
|
||||
A library to read and write GSD (General Simulation Data) file format.
|
||||
|
||||
The package also contains a python module that reads and writes hoomd
|
||||
schema gsd files with an easy to use syntax.
|
||||
|
||||
Features:
|
||||
* Efficiently store many frames of data from simulation runs.
|
||||
* High performance file read and write.
|
||||
* Support arbitrary chunks of data in each frame (position, orientation,
|
||||
type, etc...).
|
||||
* Append frames to an existing file with a monotonically increasing frame
|
||||
number.
|
||||
* Resilient to job kills.
|
||||
* Variable number of named chunks in each frame.
|
||||
* Variable size of chunks in each frame.
|
||||
* Each chunk identifies data type.
|
||||
* Common use cases: NxM arrays in double, float, int, char types.
|
||||
* Generic use case: binary blob of N bytes.
|
||||
* Easy to integrate into other tools with python, or a C API (< 1k lines).
|
||||
* Fast random access to frames.
|
||||
|
||||
WWW: https://bitbucket.org/glotzer/gsd
|
Loading…
Reference in New Issue
Block a user