Update to 1.1.4
Submitted by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
This commit is contained in:
parent
b9de798e03
commit
a04a779698
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62076
@ -6,14 +6,41 @@
|
||||
#
|
||||
|
||||
PORTNAME= gnet
|
||||
PORTVERSION= 1.1.0
|
||||
PORTVERSION= 1.1.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.gnetlibrary.org/src/
|
||||
|
||||
MAINTAINER= nakai@FreeBSD.org
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_GLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= gnet-config.1
|
||||
|
||||
post-patch:
|
||||
# fix pthreads detection
|
||||
@${REINPLACE_CMD} -E -e 's,-lpthread|-lc_r,${PTHREAD_LIBS},' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
# remove "release" information from lib name
|
||||
@${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
# don't install gnet-config script with odd name. We will install it ourselves
|
||||
@${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
# install gnet-config.1 man (not another name). Revise at EVERY port update
|
||||
@${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
|
||||
${WRKSRC}/doc/Makefile.in
|
||||
# install configincludedir correctly
|
||||
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
# install *.pc files in correct FreeBSD dir
|
||||
@${REINPLACE_CMD} -E -e \
|
||||
's|^(pkgconfigdir[ ]+=[ ]+)\$$\(libdir\)/(pkgconfig)|\1${PREFIX}/libdata/\2|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gnet-1.1.0.tar.gz) = ad7aef2f1de593e548134922472d3b98
|
||||
MD5 (gnet-1.1.4.tar.gz) = dbd03fc1bd34d611671a83564a225bb1
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/Makefile.in.orig Mon Feb 28 18:47:45 2000
|
||||
+++ src/Makefile.in Mon Feb 28 18:48:34 2000
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
lib_LTLIBRARIES = libgnet.la
|
||||
|
||||
-libgnet_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
|
||||
+libgnet_la_LDFLAGS = -version-info 0:0:0
|
||||
|
||||
|
||||
libgnet_la_SOURCES = gnet.c gnet-private.c inetaddr.c mcast.c tcp.c udp.c
|
@ -1,13 +0,0 @@
|
||||
--- configure.orig Tue Apr 11 15:56:56 2000
|
||||
+++ configure Thu Jun 15 13:51:43 2000
|
||||
@@ -2238,8 +2238,8 @@
|
||||
rm -f conf.glibtest
|
||||
|
||||
|
||||
-glib_cflags=`glib-config --cflags glib`
|
||||
-glib_libs=`glib-config --libs glib`
|
||||
+glib_cflags=`$GLIB_CONFIG --cflags glib`
|
||||
+glib_libs=`$GLIB_CONFIG --libs glib`
|
||||
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- Makefile.in 2000/11/25 13:34:07 1.1
|
||||
+++ Makefile.in 2000/11/25 13:34:59
|
||||
@@ -99,7 +99,7 @@
|
||||
m4datadir = $(datadir)/aclocal
|
||||
m4data_DATA = gnet.m4
|
||||
|
||||
-configincludedir = $(pkglibdir)/include
|
||||
+configincludedir = $(pkgincludedir)
|
||||
configinclude_DATA = gnetconfig.h
|
||||
|
||||
WEBPATH = $(HOME)/public_html/misc/gnet
|
@ -9,15 +9,18 @@ include/gnet/md5.h
|
||||
include/gnet/pack.h
|
||||
include/gnet/server.h
|
||||
include/gnet/sha.h
|
||||
include/gnet/socks.h
|
||||
include/gnet/tcp.h
|
||||
include/gnet/udp.h
|
||||
include/gnet/unix.h
|
||||
include/gnet/url.h
|
||||
lib/libgnet.a
|
||||
lib/libgnet.la
|
||||
lib/libgnet.so
|
||||
lib/libgnet.so.0
|
||||
lib/libgnet.so.1
|
||||
libdata/pkgconfig/gnet.pc
|
||||
share/aclocal/gnet.m4
|
||||
share/doc/libgnet1.1-dev/html/book1.html
|
||||
share/doc/libgnet1.1-dev/html/dnstest.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-conn.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-developers-tips.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-developers.html
|
||||
@ -31,18 +34,18 @@ share/doc/libgnet1.1-dev/html/gnet-overview.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-pack.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-server.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-sha.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-socks.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-tcp.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-udp.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-unix.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-url.html
|
||||
share/doc/libgnet1.1-dev/html/hfetch.html
|
||||
share/doc/libgnet1.1-dev/html/hostinfo.html
|
||||
share/doc/libgnet1.1-dev/html/index.html
|
||||
share/doc/libgnet1.1-dev/html/index.sgml
|
||||
share/doc/libgnet1.1-dev/html/jmtransfer.html
|
||||
share/doc/libgnet1.1-dev/html/libgnet-reference.html
|
||||
share/doc/libgnet1.1-dev/html/ljoust.html
|
||||
share/doc/libgnet1.1-dev/html/sdr.html
|
||||
share/doc/libgnet1.1-dev/html/tests.html
|
||||
@dirrm include/gnet
|
||||
@dirrm share/doc/libgnet1.1-dev/html
|
||||
@dirrm share/doc/libgnet1.1-dev
|
||||
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
|
||||
@dirrm include/gnet
|
||||
|
@ -6,14 +6,41 @@
|
||||
#
|
||||
|
||||
PORTNAME= gnet
|
||||
PORTVERSION= 1.1.0
|
||||
PORTVERSION= 1.1.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.gnetlibrary.org/src/
|
||||
|
||||
MAINTAINER= nakai@FreeBSD.org
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_GLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= gnet-config.1
|
||||
|
||||
post-patch:
|
||||
# fix pthreads detection
|
||||
@${REINPLACE_CMD} -E -e 's,-lpthread|-lc_r,${PTHREAD_LIBS},' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
# remove "release" information from lib name
|
||||
@${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
# don't install gnet-config script with odd name. We will install it ourselves
|
||||
@${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
# install gnet-config.1 man (not another name). Revise at EVERY port update
|
||||
@${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
|
||||
${WRKSRC}/doc/Makefile.in
|
||||
# install configincludedir correctly
|
||||
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
# install *.pc files in correct FreeBSD dir
|
||||
@${REINPLACE_CMD} -E -e \
|
||||
's|^(pkgconfigdir[ ]+=[ ]+)\$$\(libdir\)/(pkgconfig)|\1${PREFIX}/libdata/\2|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gnet-1.1.0.tar.gz) = ad7aef2f1de593e548134922472d3b98
|
||||
MD5 (gnet-1.1.4.tar.gz) = dbd03fc1bd34d611671a83564a225bb1
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/Makefile.in.orig Mon Feb 28 18:47:45 2000
|
||||
+++ src/Makefile.in Mon Feb 28 18:48:34 2000
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
lib_LTLIBRARIES = libgnet.la
|
||||
|
||||
-libgnet_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
|
||||
+libgnet_la_LDFLAGS = -version-info 0:0:0
|
||||
|
||||
|
||||
libgnet_la_SOURCES = gnet.c gnet-private.c inetaddr.c mcast.c tcp.c udp.c
|
@ -1,13 +0,0 @@
|
||||
--- configure.orig Tue Apr 11 15:56:56 2000
|
||||
+++ configure Thu Jun 15 13:51:43 2000
|
||||
@@ -2238,8 +2238,8 @@
|
||||
rm -f conf.glibtest
|
||||
|
||||
|
||||
-glib_cflags=`glib-config --cflags glib`
|
||||
-glib_libs=`glib-config --libs glib`
|
||||
+glib_cflags=`$GLIB_CONFIG --cflags glib`
|
||||
+glib_libs=`$GLIB_CONFIG --libs glib`
|
||||
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- Makefile.in 2000/11/25 13:34:07 1.1
|
||||
+++ Makefile.in 2000/11/25 13:34:59
|
||||
@@ -99,7 +99,7 @@
|
||||
m4datadir = $(datadir)/aclocal
|
||||
m4data_DATA = gnet.m4
|
||||
|
||||
-configincludedir = $(pkglibdir)/include
|
||||
+configincludedir = $(pkgincludedir)
|
||||
configinclude_DATA = gnetconfig.h
|
||||
|
||||
WEBPATH = $(HOME)/public_html/misc/gnet
|
@ -9,15 +9,18 @@ include/gnet/md5.h
|
||||
include/gnet/pack.h
|
||||
include/gnet/server.h
|
||||
include/gnet/sha.h
|
||||
include/gnet/socks.h
|
||||
include/gnet/tcp.h
|
||||
include/gnet/udp.h
|
||||
include/gnet/unix.h
|
||||
include/gnet/url.h
|
||||
lib/libgnet.a
|
||||
lib/libgnet.la
|
||||
lib/libgnet.so
|
||||
lib/libgnet.so.0
|
||||
lib/libgnet.so.1
|
||||
libdata/pkgconfig/gnet.pc
|
||||
share/aclocal/gnet.m4
|
||||
share/doc/libgnet1.1-dev/html/book1.html
|
||||
share/doc/libgnet1.1-dev/html/dnstest.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-conn.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-developers-tips.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-developers.html
|
||||
@ -31,18 +34,18 @@ share/doc/libgnet1.1-dev/html/gnet-overview.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-pack.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-server.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-sha.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-socks.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-tcp.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-udp.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-unix.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-url.html
|
||||
share/doc/libgnet1.1-dev/html/hfetch.html
|
||||
share/doc/libgnet1.1-dev/html/hostinfo.html
|
||||
share/doc/libgnet1.1-dev/html/index.html
|
||||
share/doc/libgnet1.1-dev/html/index.sgml
|
||||
share/doc/libgnet1.1-dev/html/jmtransfer.html
|
||||
share/doc/libgnet1.1-dev/html/libgnet-reference.html
|
||||
share/doc/libgnet1.1-dev/html/ljoust.html
|
||||
share/doc/libgnet1.1-dev/html/sdr.html
|
||||
share/doc/libgnet1.1-dev/html/tests.html
|
||||
@dirrm include/gnet
|
||||
@dirrm share/doc/libgnet1.1-dev/html
|
||||
@dirrm share/doc/libgnet1.1-dev
|
||||
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
|
||||
@dirrm include/gnet
|
||||
|
@ -6,14 +6,41 @@
|
||||
#
|
||||
|
||||
PORTNAME= gnet
|
||||
PORTVERSION= 1.1.0
|
||||
PORTVERSION= 1.1.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.gnetlibrary.org/src/
|
||||
|
||||
MAINTAINER= nakai@FreeBSD.org
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_GLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= gnet-config.1
|
||||
|
||||
post-patch:
|
||||
# fix pthreads detection
|
||||
@${REINPLACE_CMD} -E -e 's,-lpthread|-lc_r,${PTHREAD_LIBS},' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
# remove "release" information from lib name
|
||||
@${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
# don't install gnet-config script with odd name. We will install it ourselves
|
||||
@${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
# install gnet-config.1 man (not another name). Revise at EVERY port update
|
||||
@${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
|
||||
${WRKSRC}/doc/Makefile.in
|
||||
# install configincludedir correctly
|
||||
@${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
# install *.pc files in correct FreeBSD dir
|
||||
@${REINPLACE_CMD} -E -e \
|
||||
's|^(pkgconfigdir[ ]+=[ ]+)\$$\(libdir\)/(pkgconfig)|\1${PREFIX}/libdata/\2|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gnet-1.1.0.tar.gz) = ad7aef2f1de593e548134922472d3b98
|
||||
MD5 (gnet-1.1.4.tar.gz) = dbd03fc1bd34d611671a83564a225bb1
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/Makefile.in.orig Mon Feb 28 18:47:45 2000
|
||||
+++ src/Makefile.in Mon Feb 28 18:48:34 2000
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
lib_LTLIBRARIES = libgnet.la
|
||||
|
||||
-libgnet_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
|
||||
+libgnet_la_LDFLAGS = -version-info 0:0:0
|
||||
|
||||
|
||||
libgnet_la_SOURCES = gnet.c gnet-private.c inetaddr.c mcast.c tcp.c udp.c
|
@ -1,13 +0,0 @@
|
||||
--- configure.orig Tue Apr 11 15:56:56 2000
|
||||
+++ configure Thu Jun 15 13:51:43 2000
|
||||
@@ -2238,8 +2238,8 @@
|
||||
rm -f conf.glibtest
|
||||
|
||||
|
||||
-glib_cflags=`glib-config --cflags glib`
|
||||
-glib_libs=`glib-config --libs glib`
|
||||
+glib_cflags=`$GLIB_CONFIG --cflags glib`
|
||||
+glib_libs=`$GLIB_CONFIG --libs glib`
|
||||
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- Makefile.in 2000/11/25 13:34:07 1.1
|
||||
+++ Makefile.in 2000/11/25 13:34:59
|
||||
@@ -99,7 +99,7 @@
|
||||
m4datadir = $(datadir)/aclocal
|
||||
m4data_DATA = gnet.m4
|
||||
|
||||
-configincludedir = $(pkglibdir)/include
|
||||
+configincludedir = $(pkgincludedir)
|
||||
configinclude_DATA = gnetconfig.h
|
||||
|
||||
WEBPATH = $(HOME)/public_html/misc/gnet
|
@ -9,15 +9,18 @@ include/gnet/md5.h
|
||||
include/gnet/pack.h
|
||||
include/gnet/server.h
|
||||
include/gnet/sha.h
|
||||
include/gnet/socks.h
|
||||
include/gnet/tcp.h
|
||||
include/gnet/udp.h
|
||||
include/gnet/unix.h
|
||||
include/gnet/url.h
|
||||
lib/libgnet.a
|
||||
lib/libgnet.la
|
||||
lib/libgnet.so
|
||||
lib/libgnet.so.0
|
||||
lib/libgnet.so.1
|
||||
libdata/pkgconfig/gnet.pc
|
||||
share/aclocal/gnet.m4
|
||||
share/doc/libgnet1.1-dev/html/book1.html
|
||||
share/doc/libgnet1.1-dev/html/dnstest.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-conn.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-developers-tips.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-developers.html
|
||||
@ -31,18 +34,18 @@ share/doc/libgnet1.1-dev/html/gnet-overview.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-pack.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-server.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-sha.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-socks.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-tcp.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-udp.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-unix.html
|
||||
share/doc/libgnet1.1-dev/html/gnet-url.html
|
||||
share/doc/libgnet1.1-dev/html/hfetch.html
|
||||
share/doc/libgnet1.1-dev/html/hostinfo.html
|
||||
share/doc/libgnet1.1-dev/html/index.html
|
||||
share/doc/libgnet1.1-dev/html/index.sgml
|
||||
share/doc/libgnet1.1-dev/html/jmtransfer.html
|
||||
share/doc/libgnet1.1-dev/html/libgnet-reference.html
|
||||
share/doc/libgnet1.1-dev/html/ljoust.html
|
||||
share/doc/libgnet1.1-dev/html/sdr.html
|
||||
share/doc/libgnet1.1-dev/html/tests.html
|
||||
@dirrm include/gnet
|
||||
@dirrm share/doc/libgnet1.1-dev/html
|
||||
@dirrm share/doc/libgnet1.1-dev
|
||||
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
|
||||
@dirrm include/gnet
|
||||
|
Loading…
Reference in New Issue
Block a user