upgrade to 0.6.0

This commit is contained in:
Ying-Chieh Liao 2004-08-16 03:44:16 +00:00
parent 15b7d1eda5
commit a037a89b0e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116345
5 changed files with 59 additions and 7 deletions

View File

@ -7,29 +7,38 @@
#
PORTNAME= swftools
PORTVERSION= 0.5.1
PORTVERSION= 0.6.0
CATEGORIES= graphics
MASTER_SITES= http://www.quiss.org/swftools/
MAINTAINER= ports@FreeBSD.org
COMMENT= SWF manipulation and generation utilities
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
freetype.9:${PORTSDIR}/print/freetype2 \
aviplay.0:${PORTSDIR}/multimedia/avifile
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
USE_REINPLACE= yes
USE_BISON= yes
USE_GMAKE= yes
USE_PYTHON= 2.2+
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGSS="-L${LOCALBASE}/lib"
LDFLAGSS="-L${LOCALBASE}/lib" \
FREETYPE_CONFIG=${FREETYPE_CONFIG}
MAN1= font2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 swfbbox.1 swfc.1 \
MAN1= avi2swf.1 font2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 swfbbox.1 swfc.1 \
swfcombine.1 swfdump.1 swfextract.1 swfstrings.1 wav2swf.1
post-patch:
@${REINPLACE_CMD} -e 's| -O | |g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| -O | |g' \
-e 's@/usr/lib/python@${LOCALBASE}/lib/python@' \
-e 's@/usr/include/python@${LOCALBASE}/include/python@' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|;make|;\$$\(MAKE\)|g' ${WRKSRC}/lib/Makefile.in
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (swftools-0.5.1.tar.gz) = 5419c516905427f36ae9c53150b09c80
SIZE (swftools-0.5.1.tar.gz) = 1679519
MD5 (swftools-0.6.0.tar.gz) = 39bf9fd9bc90571f296638ccca177fe3
SIZE (swftools-0.6.0.tar.gz) = 1405412

View File

@ -0,0 +1,31 @@
--- configure.orig Mon Aug 16 11:29:43 2004
+++ configure Mon Aug 16 11:30:57 2004
@@ -10269,7 +10269,8 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
-#include <$ac_header>
+#include <ft2build.h>
+#include FT_FREETYPE_H
_ACEOF
rm -f conftest.$ac_objext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
@@ -10313,7 +10314,8 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
-#include <$ac_header>
+#include <ft2build.h>
+#include FT_FREETYPE_H
_ACEOF
if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
(eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
@@ -10413,6 +10415,8 @@
echo $ECHO_N "checking whether we can compile the freetype test program... $ECHO_C" >&6
cat > conftest.c << EOF
+#include <ft2build.h>
+#include FT_FREETYPE_H
#include <freetype/freetype.h>
#include <freetype/ftglyph.h>
#include <freetype/ftsnames.h>

View File

@ -0,0 +1,11 @@
--- lib/modules/swffont.c.orig Mon Aug 16 11:32:50 2004
+++ lib/modules/swffont.c Mon Aug 16 11:33:05 2004
@@ -32,6 +32,8 @@
#ifdef HAVE_FREETYPE
+#include <ft2build.h>
+#include FT_FREETYPE_H
#include <freetype/freetype.h>
#include <freetype/ftglyph.h>
#include <freetype/ftsizes.h>

View File

@ -1,3 +1,4 @@
bin/avi2swf
bin/font2swf
bin/jpeg2swf
bin/pdf2swf